[International / GSM] [HOW TO] Root the GSM/HSPA+ Samsung Galaxy Nexus


Last Updated:

  1. nj02vette

    nj02vette Well-Known Member

    Wow, was this easy. Honestly, not a single hiccup.

    Here's what I did.

    Downloaded Samsung "Naked" drivers, v1.7.
    Downloaded r2-galaxynexus-superboot.zip
    Downloaded GNexus-root-package-FYA.zip

    Extracted the drivers and the GNex root package to c:\Gnex
    Copied only the boot.superboot.img file from the r2-galaxynexus-superboot.zip to C:\Gnex.

    Turned phone off.

    Plugged into USB.

    Entered fastboot (Vol up & down + Pwr)

    Went into device manager and pointed the unidentified device to the C:\Gnex directory and it installed and recognized the drivers.

    From C:\Gnex prompt ran "fastboot devices" and the phone was recognized.

    From C:\Gnex prompt, ran "fastboot oem unlock". This presented an option on screen that asked for confirmation of unlock. Volume keys to move selection, power to select. Selected to unlock, and it was done in a matter of seconds. (No waiting for 5+ minutes).

    From C:\Gnex prompt, ran "fastboot boot boot.superboot.img". It ran and the Google logo with unlock padlock showed up for a minute. Then it booted for another minute. I did the activation screen and backup assistant.

    After all was said and done, I'm unlocked and rooted. Woot! Total time including gathering all the drivers, 10 min.
    Rebooted just to be sure, and everything is still there. I'm not sure what I did that worked for me and others are having trouble with, but if I can help, let me know.

    For some reason, the formatting of this post is messed up.

    Advertisement
  2. fiatandroid

    fiatandroid Active Member

    Edit: figured out the problem

    when i do ./fastboot-mac devices,
    i'm getting
    -bash: ./fastboot-mac: Permission denied

    any idea why?
  3. NextNexus

    NextNexus Well-Known Member

    What's the difference between Naked Samsung 1.7 and the drivers found on the Samsung website?
  4. EraserXIV

    EraserXIV Member

    So I completely missed that whole part about how the boot can take up to 5 minutes right after you unlock the bootloader, and I pulled the battery during the fist boot since it seemed like it was taking forever. I've since restarted the phone and it loaded up okay and seems to be running fine. Is there any damage I could have done, should I factory reset in CWM just in case?


    The unlock did work and I have succeeded in rooting it as well.
  5. wyandt

    wyandt New Member

    my gn lte will not start with bootloader in the normal/safe secured mode. help. newbie with android coming from att iphone 4. thanks for the help.
  6. jeremyx2

    jeremyx2 New Member

    Having problems on my mac. Cant get it to see my phone. Wonder if anyone has tips or tricks about where to unzip the Gnexus-root-package-FYA, any help would be most appreciated.
  7. William T Riker

    William T Riker Well-Known Member

    Well I finally anted up and tried again with the r3-superboot, went into the bootloader ran the .bat and this time instead of bootlooping on me like the boot.img this morning it did what everyone else has been posting just stayed on the Google logo instead of looping, so I let it sit for 15 mins, pulled the battery, and it was rooted. Much easier and definitely not as FUFFUFUFU as yesterday morning was for me lol.. good luck
  8. Airmaxx23

    Airmaxx23 Well-Known Member

    Where did you get the GNexus-root-package-FYA.zip?
  9. nj02vette

    nj02vette Well-Known Member

    Yes. Should have mentioned that. ;)

    All of the files mentioned are linked in the first post of this thread. Both in the somewhat easy method and the easy method.

    What I haven't seen anywhere was after you run the oem unlock command, the GNex screen asks for confirmation. Follow the screen prompts and it unlocked in like 5 sec.
    Airmaxx23 likes this.
  10. Airmaxx23

    Airmaxx23 Well-Known Member


    Thanks, FedEx screwed up my shipment so my phone won't be here until Monday. :(
    brandonhutch likes this.
  11. soy.lor.n

    soy.lor.n Well-Known Member

    Thanks so much! This worked great and was super easy. The only difficult part for me was figuring out how to download the superboot package from filesonic...:rolleyes:

    Also thanks to Scary Alien and everyone else who worked on getting root and making these guides!
  12. Needz_Android

    Needz_Android Well-Known Member

    guys, do i have to unlock my bootloader before rooting? i plan on running stock ICS for the foreseeable future so I'd like to skip that step if possible.

    are there benefits to unlocking the bootloader other than flashing roms?
  13. Needz_Android

    Needz_Android Well-Known Member

    are there issues with the superboot method? if so, i'll probably hold off since I don't know if I'm able to do it manually without bricking my phone
  14. GorillaTheHutt

    GorillaTheHutt Well-Known Member

    yes, you need to unlock to root with the method in this thread.

    in order to root you need to boot a temporary, unsecured image file, which requires unlocking the phone.
  15. scary alien

    scary alien not really so scary Moderator

    nj02vette and sgrinavi like this.
  16. Needz_Android

    Needz_Android Well-Known Member

    thanks. is there no one click method like unrevoked?
  17. iowabowtech

    iowabowtech root@android:/ #

    The only hiccup I had was during unlock...pc didn't recognize bootloader. Used some driver files provided by Berzerker in irc and all was gold after that. Unlock was easy, BUT:

    After you accept the unlock terms, the phone will reboot and start a factory reset. You'll see the boot animation for a long time, then it will reboot and you'll see it again for a shorter time. Do not confuse this with a bootloop and get all nervous. Instead wait it out, please do not pull the battery. Took about 7-8 minutes in my case but eventually, you should end up at the Google setup screen.

    So with the release of the new Clockwork, rooting took all of 5 minutes. Download the cwm recovery img and superuser zip:
    http://download.clockworkmod.com/recoveries/recovery-clockwork-5.5.0.4-toro.img

    http://download.clockworkmod.com/test/su.zip

    Place both of above files (leave SU zipped) into the sdk tools or platform-tools folder if using a more recent version of sdk, then:

    adb push su.zip /sdcard/

    then...
    adb reboot bootloader

    Bootloader fires up and fastboot is selected by default so assuming you already have the fastboot.exe in your sdk tools or platform-tools folder:

    fastboot flash recovery recovery-clockwork-5.5.0.4-toro.img

    Once the recovery img is flashed, use the volume keys until you see "Recovery Mode" appear on the screen in red, then press the power button. Should boot Clockwork (may see Google screen with lock first, chill, it'll get there, give it a sec). Once in Clockwork, choose "install zip from sd card", then "choose zip from sd card". Should bring up a list of your storage which will include the su.zip. Use volume keys to scroll to it, power button to select it, then do the same on the next screen to confirm install. When installed, use the "go back one menu" (or similar verbage) option in Clockwork till you get to the screen that has "reboot to system" option at the top. Select that and it'll reboot.

    Now that you're up and running, go to market and get Rom Manager. Select the top most option to reflash recovery and then be sure to flash the one for CDMA Galaxy Nexus.

    Done.
    woodstorm and nj02vette like this.
  18. teddyearp

    teddyearp A guide with guides Guide

    Very nice and concise write-up.

    Thank you.

    p.s. and yes, that is missing in the OP. The fact that the phone will ask for action after you issue the "fastboot oem unlock" command.
    nj02vette likes this.
  19. Needz_Android

    Needz_Android Well-Known Member

    does this process include unlocking the bootloader?
    nj02vette likes this.
  20. soy.lor.n

    soy.lor.n Well-Known Member

    yes

    Is there a particular reason you want your bootloader locked, or do you just not really care about having it unlocked?

    The bootloader unlock is the part that wipes your data (as I understand) so it makes sense to do that now and get it out of the way. If you don't want to flash a different rom, you don't have to. That's my plan.
    Needz_Android likes this.
  21. cggorman

    cggorman Well-Known Member

    A lot of people seem to skip the most important step: RTFM
    nj02vette and scary alien like this.
  22. Needz_Android

    Needz_Android Well-Known Member

    i don't really care whether its unlocked or not. i figured its just more stuff i have to do that could potentially screw up my phone. so i figured i would skip if if i could to save time and potentially messing up my phone haha.


    so if i follow nj02vette's instructions i should be able to successfully unlock and root my phone?

    i'm just terrified of bricking/or getting a boot loop on my phone and being totally screwed. it was kind of impossible to screw things up using unrevoked
  23. binary visions

    binary visions Well-Known Member

    I did this process this morning and must have rebooted and fussed with the phone for 25 minutes before I read the BOLD, RED text right above the instructions that said it was normal to the phone to sit at the Google logo when booting the insecure boot.img and to proceed with the adb commands :rolleyes:

    I'm a dumbass.
    nj02vette, soy.lor.n and scary alien like this.
  24. binary visions

    binary visions Well-Known Member

    Unlocking the bootloader doesn't really do anything. That is, it doesn't modify your phone in any material way besides disabling the security check when flashing firmware.
    Needz_Android likes this.
  25. Needz_Android

    Needz_Android Well-Known Member

    yea and i'm fine with that. i just want to root as quickly as possible with as little a chance to mess my phone up.

    i'm not super knowledgeable when it comes to rooting

Share This Page