[International / GSM] I may have really bricked my phone this time...


Last Updated:

  1. maluze

    maluze Member

    I have a Galaxy Nexus Maguro (HSPA+). I wanted to update to 4.2. I have Clockworkmod on my Nexus, so naturally it didn't work. I then proceded to wipe out everything on my phone, sdcard and system, so that i could flash the stock ROM...everything was going to plan, until I tried to connect it to my Macbook running 10.8.2. Turns out that my mac will not recognize it, even though I had USB debugging turned on beforehand. I tried using adb, and the nexus still won't show up. (It says "no device found")

    Short story, my nexus will not boot up past the Google screen, and won't be recognized through adb. What can I do at this point?

    Advertisement
  2. breadnatty08

    breadnatty08 pain rustique VIP Member

    I think you're quite far from a bricked phone. I'm not familiar with rooting and ADB on a Mac, but do you have a Windows PC you have access to?
    scary alien likes this.
  3. scary alien

    scary alien not really so scary Moderator

    Yep--what dread, said ;) :).

    Also, it's likely you simply have to use sudo when invoking adb:

    $ sudo adb devices

    (this is what was necessary on my Linux laptop and I understand the same rules might apply to a Mac).

    Let us know! :)
    Fuzzy13 likes this.
  4. ankitrihal

    ankitrihal Member

    Nexus can never be bricked Bra :p
  5. scary alien

    scary alien not really so scary Moderator

    I had bricking earlier this summer...must have been a hardware fault, though.

    I had rebooted and the device never responded to me again (no lights, no USB / adb / fastboot response, etc.).

    But if your device is responsive at all, you've still got options and hope :).
  6. maluze

    maluze Member

    I have access to a friend's computer. I downloaded the adb tools, and the the drivers for the Nexus, but it when I try to install the pdanet drivers for the nexus, i keep getting an error message saying that there is no android phone detected, even though it's connected to the pc.
  7. scary alien

    scary alien not really so scary Moderator

    See if this thread helps: http://androidforums.com/verizon-galaxy-nexus-all-things-root/480632-im-going-make-hardest-part-rooting-easy-newbs-right-here-yup-i-am.html

    (stupid USB connectivity on Windows PCs...grrr :p)
  8. heat57

    heat57 Well-Known Member

    I agree with Scary it's more than likely a USB connectivity issue with Windows. Here is a link to the latest Samsung driver package in .exe form http://drivers.softpedia.com/progDownload/SAMSUNG-USB-Driver-for-Mobile-Phones-1560-Download-170044.html download it and install in Windows as per usual. The plug in your GNex and wait for the connection sound, which will happen again because Windows will fail to find the correct drivers and install them.
    Now go to Device Manager and you should see an entry lie Android... with an exclamation mark! Double-click/or right-click that entry and choose 'update driver software', then go to driver tab and click 'browse my computer'. Now press on 'let me pick a list of device drivers on my computer' then you will be presented with the box where the Samsung ADB drivers are listed. Select the latest one followed by 'Next' - if you get a Windows warning select to install anyway. Viola, you should no be able to communicate with your device and flash a Google factory image of your choice or custom ROM.
    scary alien likes this.
  9. maluze

    maluze Member


    I installed the Samsung driver like you mentioned, but when I plugged in my Gnex, there was no sound, and no entry for "Android" or the like in Device manager. I tried disconnecting and connecting several times, but with my GNEX in fastboot mode, there seemed to be nothing occurring when I connect to my friend's WIndows XP pc.
  10. heat57

    heat57 Well-Known Member

    Try a different USB cable. Sometimes they are faulty. f that's not doing it then it may be a hardware problem.
  11. idic

    idic Well-Known Member

    I don't think you can get to adb before the OS had loaded. You need to be using fastboot. Try typing

    fastboot devices

    and see if you get a serial number returned. ADB will only work once Android had loaded, and possibly if you're in a custom recovery, but not 100% sure about that.
    scary alien likes this.
  12. scary alien

    scary alien not really so scary Moderator

    idic,

    You are indeed 100% correct about adb also being accessible in custom recovery.

    Well done! :)

Share This Page