[International / GSM] Installing 4.2.2 via CMD on Windows 7 Home Premium 64bit


Last Updated:

  1. Melzi

    Melzi Member

    I'm trying to install the 4.2.2 update manually via cmd and I keep on getting the same error message after hitting enter. The error message is "adb is not recognized as an internal or external command, operable program or batch file".

    I have the 4.2.2 update in zip form in my downloads folder and I've directed cmd to there and then I've typed:

    adb sideload 07501b11ad3b.signed-yakju-JDQ39-from-JOP40D.07501b11.zip

    Am I doing something wrong or is my computer being stubborn?

    Melzi

    Advertisement
  2. sdrawkcab25

    sdrawkcab25 Guides Guide

    Your cmd prompt needs to be directed to where you have adb installed, then you direct adb to your downloads folder.

    Or alternately download wugs root toolkit and it has the side load commands built in.
  3. Melzi

    Melzi Member

    I have adb via the Android SDK and have put that in a folder named Android in the program files x86 folder, so how would I tell cmd to go to it then onto the downloads folder for the 4.2.2 zip file?

    EDIT: So I have the path to adb:

    C:\Program Files (x86)\Android\ADT Bundle\adt-bundle-windows-86_64-20130219\sdk\platform-tools>

    If that's the correct path to adb as I can see the adb app in the list, how do I point it to the 4.2.2 zip file from there?
  4. sdrawkcab25

    sdrawkcab25 Guides Guide

    Easiest way to know if you are in the right path is to just type in
    Code (Text):
    1. adb devices
    and if it should return your device as being attached.

    Then just copy and paste the zip folder to where your adb folder is, then run the side load command.

    Copy and paste your command prompt screen in between [code] [/code] boxes if you have problems or take a screen shot.

    But like I said above Wugs nexus toolkit really simplifies the whole process and is a great tool to have on your computer in case of emergencies.
  5. Melzi

    Melzi Member

    I typed adb devices and got back

    *daemon not running. starting it now on port 5037*
    *daemon started successfully*
    List of devices attached

    C:\Program Files (x86)\Android\ADT Bundle\adt-bundle-windows-x86_64-20130219\sdkplatform-tools>

    I'm assuming that it didn't detect my nexus phone as it didn't appear in the list?

    I've already tried using ADB Sideload Update via Wugs but it wouldn't detect my device via any of the usb ports on my pc and I don't have another usb cable to test with unfortunately.
  6. sdrawkcab25

    sdrawkcab25 Guides Guide

    Did you go through the driver install process? Not going to get anywhere without the right drivers installed.
  7. Melzi

    Melzi Member

    I'm quite sure I did, how can I double check that? If I didn't what would the process be and where would I get the right drivers?

    EDIT: I can connect the phone to the pc & transfer photos & music with no issues so I don't know why my phone can't be detected via wugs or cmd unless I've missed something.
  8. sdrawkcab25

    sdrawkcab25 Guides Guide

    Make sure you are running the latest version of wugs toolkit, and there is a driver installation tuturial . Sounds like you are missing the adb drivers, but the toolkit will take you through the process.
    Melzi likes this.
  9. Melzi

    Melzi Member

    I have the WugFresh Nexus Root Toolkit working now :D I got the drivers installed and having a laugh at myself about how silly I was forgetting to double check if I had the drivers installed! I really appreciate the help sdraw so I've given you Thanks for it ;)
  10. Melzi

    Melzi Member

    Now I'm just having troubles getting the zip file to install. I'm using adb sideload update and this is what I'm getting on my nexus...

    Now send the package you want to apply to the device with "adb sideload <filename>"...
    Finding update package...
    Opening update package...
    Verifying update package...
    Installation aborted.

    Now I'm a sad panda cause the 4.2.2 update won't install for some reason or another :(
  11. sdrawkcab25

    sdrawkcab25 Guides Guide


    Hmmm. Do you have the md5 for the update ? I'd double check it if you have it.
  12. Melzi

    Melzi Member

    Yeah it's 130db16f58ef96b8e5f813a9e3173186.
  13. sdrawkcab25

    sdrawkcab25 Guides Guide

    The md5s match I'm assuming? I don't have too much experience side loading updates, have you tried installing it through recovery?

    You are currently on JDQ39?

    Edit: you should be doing this:
    Then do the side load command
  14. Melzi

    Melzi Member

    According to google, the previous MD5 checksum doesn't match the one from developers.google.com as they it's 2fe041ac195086ef09274204c7e265e2. So maybe downloading it directly from google's site would be better that androidpolice.com's google's link?

    While on the issue of downloading from google's site, would be fine just to get the takju (with google wallet) instead of yakju or would that be a bad idea even though either build is for my "maguro (GSM/HSPA+)" phone?
  15. Demache

    Demache Well-Known Member

    If possible, give it a shot.
  16. jhawkkw

    jhawkkw Chinchillin' Moderator

    The image on goggle's developer site is the full factory image. This is completely different but would also install the build. However installing the factory image has to be done through the bootloader and will completely wipe the device.
  17. Melzi

    Melzi Member

    Well since I've tried sideloading the 4.2.2 update multiple times with no success I've decided to stay with 4.2.1 for now and do some research into AOKP's JB mr1 build 5 & build 6 ROMs' as I've been seeing some wonderful customisations and I think that's more to my style :D

    I wish to say thanks to everyone and hope all of you enjoy a wonderful day :)
  18. trophynuts

    trophynuts Well-Known Member

    recommend moving this thread to the All Things Root section.
    jhawkkw likes this.
  19. jhawkkw

    jhawkkw Chinchillin' Moderator

    Done. :)
  20. Melzi

    Melzi Member

    This is my 1st time installing a custom ROM so please excuse my lack of experience guys & gals :)

    I have build 6 downloaded, same with GApps but I'm not sure whether to open & save them somewhere or just to leave as is and point the toolkit to them. Also I'm not sure if I need to download a ROM manager or not so any help would be much appreciated.
  21. jhawkkw

    jhawkkw Chinchillin' Moderator

    What you want to do is download the build 6 and gapps to your device in a place that you know where they are located. After they are downloaded, boot the device into custom recovery (either twrp or cwm). If you don't have them installed, but are rooted, you can install cwm through rom manager and twrp through goomanager. If the device is not rooted, get that done first. Once in recovery, backup your current rom in case something goes wrong that we have something to fall back on. One the backup is made, we will want to factory reset, wipe cache, and wipe dalvik cache. Doing this prevents the device from bootlooping. After the three wipes, we will install rom and then gapps in that order. One that is done reboot and wait for it to boot. It might take a couple of minutes to boot, but then you should be set.
    Melzi likes this.
  22. Melzi

    Melzi Member

    I've got my phone unlocked & rooted YAY! OMG I'm a rebel chic now! lol

    I've already done a backup of my stock 4.2.1 before I unlocked & rooted the phone. So now here come the questions again lol

    Since I'm using the nexus root toolkit, is this the step in which I create the nandroid backup so if something goes wrong this is what I'm falling back on? If so what options do I choose from the list it's providing?

    The options are: System partition, Data partition, Cache partition, Recovery partition, Boot (kernal) partition.

    I've downloaded ROM manager since goomanager isn't compatible with my nexus according to google play.

    Edit: Apparently google play was being stubborn with me, so now I have goomanager installed :) Is it ok to have both installed or only 1 of them?
  23. Melzi

    Melzi Member

    Success!! I went with GooManager & TWRP and got AOKP mr1 build 6 installed! It looks & feels fantastic! I can't wait to really dig in & enjoy all of the different customisations that it has to offer :D

    Jhawkkw, you've been a big help & can't say thanks enough to you!
  24. jhawkkw

    jhawkkw Chinchillin' Moderator

    Congrats, enjoy the improved device :D

Share This Page