[International / GSM] MTP Device Driver Errors

Last Updated:

  1. dren

    dren Well-Known Member


    I've been trying all night and all morning to get the samsung driver's to install on my computer. I've downloaded them from samsung's site (exe), I've downloaded the zip of them to install manually, I've downloaded the naked samsung drivers. Nothing seems to be working. I get the following screen pop up every time I plug my phone into the computer:


    Oh and every time I'd install a new set of drivers I always made sure to uninstall the drivers installed previously.

    Does anyone have any ideas on this?

  2. eddieruko

    eddieruko Well-Known Member

    do you happen to be listed as an admin on your computer? i was able to download and begin installing the drivers at work before i realized i wasn't logged in with my admin account.

    if you're running XP, the samsung drivers worked for me (actually following the Droid-Life HOW TO was a easier for me).

    if you haven't tried rebooting your computer, that may help as well.
  3. Kevmueller

    Kevmueller Well-Known Member

    I was having this problem and then saw a post that I did not believe over on XDA but tried it and it worked.

    Make sure you have Windows Media Player 11 installed. Once I upgraded to this one mine worked with no problems.
  4. dren

    dren Well-Known Member

    Well I'm at work and my computer is on a domain... So I logged out of the domain and logged in locally to the Administrator account and it worked long enough for me to unlock the bootloader and that's it. Now that I'm trying to do the adb push su.zip, it won't detect any devices and now that same window keeps popping up (See OP) every time I plug my phone in.

    I haven't tried installing WMP11... I don't understand how that would help but if it worked for you maybe it will work for me??? I don't know... :(

    Anyone else want to take a stab at this one?
  5. eddieruko

    eddieruko Well-Known Member

    yep. had the exact same problem.

    your adb push su.zip command... is that using the "soft-boot" CWM recovery?

    i ended up rebooting the phone, flashing CWM (overwriting stock recovery) and using this command from the HOW TO

    there are plenty of experts around here to chime in why some commands don't work. but i imagine having the correct privileges on your machine has something to do with it.

    if you want to try with the soft-boot CWM method, try using the same adb push form above.

    this worked for me. hope it helps.
  6. igotgame

    igotgame Well-Known Member

    This is amazing...this fixed my issue as well.

    Installed WMP 11 and now MTP works perfectly fine and I can see my Nexus on my PC now to browse through it.

  7. Kevmueller

    Kevmueller Well-Known Member

    No problem, like I said that would have been one of the last things I would have tried myself. I tried it because I had no other ideas and someone else said that is what worked. I tried it and sure enough it works. I guess in WMP 11 it puts the MTP files it needs for XP on your computer.
  8. tanbin

    tanbin New Member

    my one is windows media player 12........ but yet i get the WMP error... :(

    *** found the solution.... just had to turn the usb debugging on from the phone... :)

Share This Page