1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[International / GSM] Waiting for device - Help!

Last Updated:

  1. Ked

    Ked New Member

    Hi! First time posting, looking for some help!

    I've been thinking about rooting my Galaxy Nexus for a while, and then saw a post on androidcentral.com on how to manually install the stock 4.0.4 update. Started doing this, and now ran into some problems.

    First, I managed to unlock the bootloader after some trouble. My PC wouldn't recognize the phone when in fastboot moe, but I then got it working and got the drivers updated. I'm not really even sure why it started working all of a sudden.

    So anyway, now trying to install the Clockworkmod recovery image (fastboot.exe boot cwm.img in Command Prompt), and this is where it stops and says Waiting for device. I looked around and found some pointers that the device isn't recognized via ADB, but that didn't really get me anywhere.

    I did check that ADB and everything is installed. I enabled USB debugging as well, but the adb devices command also doesn't give me any results. I've tried multiple different drivers, ADB/FB Driver Naked Samsung Driver 1.7 from XDA for one, also the Google USB drivers and SAMSUNG_USB_Driver_for_Mobile_Phones_1.4.8.0 that I found in one of the stickies.

    Probably a stupid question with an easy solution, this is all new for me so I hope someone might be able to help out here. :)

  2. scary alien

    scary alien not really so scary Moderator

    Welcome to the AndroidForums, Ked!

    Just to make sure we're on the same page here, but you can only use the fastboot utility while the phone's in fastboot / bootloader mode.

    The adb utility is available when the phone is booted-up normally in Android when you've got USB debugging enabled. Its also always available when in custom recovery mode (which is different from fastboot mode).

    So, if you're trying to softboot ClockworkMod (fastboot boot cwm.img) or install it (fastboot flash recovery cwm.img), you'll need to make sure you are in fastboot / bootloader mode.

    Does that help and/or make sense?

  3. Ked

    Ked New Member

    It does indeed. I was thinking I'm getting stuff mixed up. Got past the original problem, but not in the clear yet.

    I came across this: How to Root Galaxy Nexus! | GalaxyNexusRoot.com and went with that. Easy enough, everything worked just as it should.

    However, when it starts to reboot in the end it doesn't. It's been a good 10-15 minutes now and still Google and the unlock mark on screen.

    Gonna wait a bit longer, I'm really hoping I didn't break the whole thing.
  4. scary alien

    scary alien not really so scary Moderator

    I'm not familiar with that thread or site, but it sort of looks to me like its rooting using a Superboot (insecure boot image) that also installs root (and is soft-booting--so, you've not actually flashed (written) anything other than hopefully just the root binaries).

    Some of these Superboots were known to never finish rebooting (there are/were device differences that accounted for this). I'm guessing if you do a battery pull and reboot, you'll find that you now have root (su and Superuser.apk) installed.

    quiklives likes this.
  5. Ked

    Ked New Member

    That's exactly what happened, looks good now!

    Thanks a lot for helping out!
    scary alien likes this.

Share This Page