[International] HELP! S4 stuck at Boot Logo after installing custom ROM.


  1. mpshah

    mpshah New Member

    Hi Guys,

    I'm fairly new at this (iPhone user) so any dumb questions that I may ask please ignore it.

    So here's the thing, I have a unlocked Samsung S4 I9505 (international version) and everything was working well till yesterday. I wasn't happy with the Touchwiz so when I saw the GE ROM I gladly downloaded it, rooted the S4 and installed the ROM. All was good till now, then I got adventurous and tried to install the Omega ROM V 7.0 and thats when the problems started. After installing this ROM, the phone never passed through the boot logo of Omega.

    Fearing that the phone was bricked, I went ahead flashed the stock firmware using ODIN thinking it would take the phone back to stock firmware. But I was wrong, everything on ODIN went OK but this time the phone got stuck ast the Samsung Boot logo. I've flashed the stock firmware at least 5-6 times with multiple battery pulls but to no avail. I can't even get in to stock recovery which is the frustrating part.

    So guys could you help me out here please?

    Thanks.

    Advertisement
  2. ironass

    ironass Well-Known Member

    Hello and welcome to Android Forums mpshah! :)

    Sorry to hear that you're having problems. Lets see if we can sort you out...

    Oh, dear... you have become, "Flash Happy". This is the state whereby you flash anything and everything on your phone in the hope of getting it working.

    The term, "bricked", is reserved for the inability to even turn the phone on and usually indicates a fried motherboard which is a very expensive repair job.

    Your original problem between the flashing of the 2 custom ROM's probably occurred because you did not wipe the cache partition and dalvik cache in Recovery mode and had all the detritus from one ROM cache in the new ROM cache. The problem was further increased when you then flashed the stock firmware.

    However, now that you have flashed a stock firmware, (hopefully the correct one for your model of phone), your options are a little more limited as you now have the stock kernel and recovery.

    I would suggest biting the bullet and doing a Factory reset whilst booted into Recovery mode by pressing and holding the following buttons... Volume Up +Home (centre hard key) + (lastly) Power. Continue to hold these buttons until your phone boots into the Recovery screen. This will wipe all data on your phone but not the firmware that you have flashed. You will need to sign in to your Google account and re-sync afterwards.

    For future reference... always do a nandroid, Titanium and efs file backups after rooting in case of such problems. See post #3 of the Rooting Galaxy S4 - Dummies Guide.
    lardos likes this.
  3. mpshah

    mpshah New Member

    Thank you so much for the reply. But here's the thing I cannot get in to Recovery mode. Tried numerous times but it gets to the boot logo with SAMSUNG and Recovery Booting in blue text. It does not go further than that.
    :(
  4. ironass

    ironass Well-Known Member

    Remove your battery for 30 seconds and then replace it and boot into Recovery mode with the phone switched off.
    lardos likes this.
  5. mpshah

    mpshah New Member

    I have tried that as well with no luck. So what I'm doing is Volume Up + Power button + Home button while the phone is off. Then when it says Samsung GT-I9505 and Recovery Booting (top left corner) I let go of all the buttons. Is this the right way???
  6. mpshah

    mpshah New Member

    Alright so I was able to get into Recovery Mode. Performed a Data Wipe/Factory Reset and rebooted the phone. All is good now. Thank you so much for the advice.

    Since we are on the topic of flashing , what is a good ROM that you would recommend without the bloatware of Samsung?

    Thanks.
  7. sntaylor

    sntaylor Well-Known Member Contributor

    The most greatest ever question and answer ever..... :p
  8. ironass

    ironass Well-Known Member

    :hahaha:
    Now that the Mods have removed the spam posting, it sounds like you're commenting on the whole thread!

    Perhaps we should both be removed... for the sake of everyone's sanity. :hmmmm:

    Nah!
  9. sntaylor

    sntaylor Well-Known Member Contributor

    Their......;-)
  10. lardos

    lardos New Member

    Hi all, thanks very much for the tips in this thread I have been looking for a solution for the past day and this is the first place that seems to be looking at the same problem I'm having. Unfortunately after my initial excitement on seeing your method for getting into recovery I still am having the same problem.:(

    First as much as I can remember about how I got to where i am now. I rooted my phone using cf auto root method then flashed CWM 6.0.3.3 with SGS4 flasher which I got from the Google Play store. I then installed Revolt Rom with CWM and after I didn't like that I installed JellyBam which I have been using on my SII for the last year.

    I turned some permissons and boot startups off for 3rd party apps with rom manager but only things like ebay app and games definitely no system apps. Then using Android tweaker pro I changed a few settings but only to Audio, GPS wi-fi nothing to do with boot etc.
    After I rebooted my phone using power button and reboot it wouldn't boot past samsung code screen. My first action was to boot into CWM recovery with power,home volume up buttons but this just took me to samsung code screen with recovery rebooting in blue text very small text at top of screen and then rebooting to samsung code screen again and hanging there. When this didn't work I flashed current stock firmware for my carrier (which I had previously downloaded from sammobile.com) with odin 3.07. When phone passed samsung code screen I thought I was sorted but it just stayed on carrier logo screen. When this didn't work I re flashed firmware again (and again and again and probably again) all to the same end.After each seperate flash I removed battery and then tried to start in recovery each time blue text then nothing. I then went to samsung-updates.com and downloaded the original firmware for the phone/carrier in the hope that if I installed this I could then update to current firmware on the phone like I did when I first got it. When this didn't work I looked online for fixes. I found this thread: http://androidforums.com/internatio.../733986-djembey-roms-i9505-dummies-guide.html
    and hoped that this would help. I downloaded Kernel, Recovery and Firmware from the xda site linked on the page. First I flashed just the firmware, same result, next I flashed the firmware, then the kernel, then the recovery same result.

    This has led me to where I am now as I said at the start after searching some more and finding this thread and seeing it helped mpshah I thought I had the solution but even after following all your instructions I am still stuck on boot screen and cannot get into recovery. Please help I am starting to get worried
  11. lardos

    lardos New Member

    If it helps I STUPIDLY didn't make a nandroid back-up not that I think it matters if I can't get into recovery mode
  12. ironass

    ironass Well-Known Member

    Hello and welcome to Android Forums lardos! :)

    Normally I quote a new poster's problem but as you have given such a concise and lengthy description, which does help, I won't bother.

    In a nutshell, it would appear that you have become, "Flash Happy", in an effort to sort out your problems... which they have not.

    PLAN A:

    Assuming that you are still rooted, try flashing the PhilZ.tar in recovery via Odin as per #1.1 - #1.5 of the PhilZ CWM Recovery - Dummies Guide and see if that helps.

    PLAN B:

    IMHO the time has come to bite the bullet, and do a Factory Reset and flash a stock Samsung firmware using Odin before going on to root and recovery and custom ROMs.

    Just a thought... you haven't, during all your flashes, changed your .PIT file by any chance have you? :ahhhhh:
    lardos likes this.
  13. lardos

    lardos New Member

    Hi Ironass,

    Thanks very much for your help. You are correct in saying I was flash happy when I couldn't get the stock firmware working I got worried. In going back over this thread I found the you tube video of how to get into recovery mode and was able to factory wipe and get started from there . The one thing that really video helped in the vid was saying that you should let go of the the buttons when the blue text comes up. I had been continuing to hold down the buttons and this seems to be why I couldn't boot is to recovery. I have always held down buttons until recovery opens with previous devices and never had this problem before. Prehaps you can add this into your instructions to help others in the future. I am very pleased to have my phone back up and running. Thanks again for your help.

    Lardos
    dynomot likes this.
  14. oscar_h_m

    oscar_h_m New Member

    hey I need help with this too.
    I tried to install WanamLite V1.8 ROM and I got stucked on the samsung logo rebooting after the installing was completed. I took off the batery enter on the cwm recovery and wipe the data and the cache (but the rom said NO WIPE) and after rebooting got stucked again on the samsung logo. Then I obviously panicked and restored my backup… Everything is OK now but I want to install this rom.. Why happened this? Should I try again or not??
    BTW my phone is the gs4 gt-i9500 4.2.2 rooted. thnks
  15. JMS23

    JMS23 New Member

    My unrooted s4 phone gets stuck with the blue colour legend Recovery booting. I am unable to enter safe mode, any ideas? been surfing google for 12hrs with no proper answer for MAC. Thanks!!
  16. mikesalive83

    mikesalive83 New Member

    I just recently purchased my galaxy S4 I rooted it and was ready to install the nightly app which IS specific for my device.. MY problem.. I booted into recovery ( I DID create a back up) then I followed the instructions as told. I wiped the data and the cache devik and everything exactly as I read. I PRE loaded the zip files to my SD card from my computer. Everything was going smooth UNTIL I tried to load the ZIP files from the SDcard in order to install my new rom. For some damn odd reason The zip files were magically not there anymore... Not knowing what to do clicked the recovery tab in the TWRP client. I am now screwed... I get stuck on the samsung logo with no way out. I removed my battery turrned on the phone booted back into recovery and did a factory reset.. still nothing.. Any help would be nice.

    - MikesAlive but his phone is dead.
  17. mikesalive83

    mikesalive83 New Member

    My phone is also feeling a bit warm too
  18. Shotgun84

    Shotgun84 Well-Known Member

    Welcome to the forum Mike:wavey:

    It sounds like the files didn't transfer to your sd correctly. Did you have enough space when you tried. If not try deleting a few things and transfer it again. I hope you're taking about an external sd as that'll be easier to fix. Just connect it back to the pc and transfer again
  19. Shotgun84

    Shotgun84 Well-Known Member

    Sorry just noticed the "nightly" I'm assuming that's cyanogenmod? CM's very specific when it comes to recoveries so maybe change recovery and try the flash again. I'm sure the CMmod instructions never used to mention twp so that might be where's your problem at:)
  20. abdulnm

    abdulnm New Member

    Hi seniors,

    My warranty of Samsung Galaxy S4 ran out a couple of months ago.
    A week later my phone didn't boot up. It always remains at the Samsung logo.

    A read a few threads and tried the following options with no luck

    1. Entered Recovery mode (Volume up + Home button + power)
    In this mode the Volume down button is not working to select any option other than 'Reboot system now' which is selected by default.
    I assume no button is working in this mode other than a long press on the power button.

    2. I downloaded the ODIN (3.09) and tried to root my phone with the (CF-Auto-Root-jflte-jfltexx-gti9505.tar)
    The phone restarted but again remained at the logo and didn't go any further

    I would appreciate any suggestion on my issue.

    Thanks in advance.
  21. Uboat

    Uboat New Member

    Hi!

    I am also suffering from not getting past the boot logo and the tiny blue "Recovery Booting...." message:

    I wanted to root my Galaxy S4 LTE GT-I9505 (with XXUGNJ8 Android 4.4.2 Stock Firmware) in order to remove
    Samsung apps I did not like to gain available storage and to make my android faster. I used the tutorial found in http://nasirtech.blogspot.se/2014/11/root-i9505xxugnj8-android-442-stock.html
    I rooted the GT-I9505 (now Developer Mode and USB-debugging ON) using Odin 3.09 and the CF-Auto-Root-jflte-
    jfltexx-gti9505.tar.md5. The rooting process went well and I could now verify I had root-access. Please note that I did not do any wipe cache or Factory Reset in this step.

    After this step I wanted to use a script already developted to remove most of Samsungs bloatware using a Truly Clean Script (see http://forum.xda-developers.com/showthread.php?t=2307355)
    I entered the Recovery Mode (Vol Up + HOME + Power) correctly, but could not find the correct Recovery line that should say "install zip from sdcard", only found "apply update from sd card" and selected that. Then pointed out the script-zip-file and pressed power to start the process. The update process started but returned a couple of red warning lines saying "wrong footer and signature verification failed". I retried the same process a couple of times with the same result, i.e. no bloatware removed.

    Searched the Internet for a reason and found that I was probably entering recovery mode in the wrong way, installed ROM Manager from Google Play och tried to enter the correct version of recovery mode from there. But this also did not work, always got the same error messages as mentioned above.

    Searched Internet forums and realised that I might have to install a custom recovery ROM and found the popular Philz touch (PhilZ CWM Recovery - Dummies Guide on http://androidforums.com/threads/philz-cwm-recovery-dummies-guide.733389/). I used the "Method #1 for rooted phones with STOCK Recovery" but somehow ended up using the wrong file. I used the "philz_touch_6.07.9-i9500.tar.md5" which is for GT-I9500 Octa core, instead of the "philz_touch_6.58.7-jflte.tar.md5" for my GT-I9505 LTE!!!!

    I then used Odin to install the wrong philz touch version on my phone :(. It all went OK in Odin (I did not know I had selected the wrong file at this time). Then I tried to install the bloatware-removal script, as mentioned above, in recovery mode, but still did not see the expected "install zip from sdcard" line and became quite frustrated. I started up the phone and went into ROM manager and from there started the phone in Recovery mode.

    After using the last ROM manager step, I cannot go beyond the boot logo step with the small blue line in the upper left corner saying "RECOVERY BOOTING....". Now I cannot enter the recovery mode anymore (have tried many ways, Vol Up + HOME then Power, releasing power as soon the "RECOVERY BOOTING...." appears, but nothing helps (not even taking out battery + waiting +30sesc)!!

    I cannot go into download mode anymore either (Vol Down + HOME + Power, then Vol up...).

    I have read all possible pages on several forums the whole day but nothing seems to help since I cannot enter neither Recovery mode nor Download mode.

    Is it possible to get the phone working again (can I do it myself or only Samsung Service Point?) or do I have to throw it in the trash bin (would be quite sad since I only had it for a couple of weeks..).

    I would really appreciate any help in this matter (and hope You didn't die reading this loong description :))....

    Cheers,
  22. ironass

    ironass Well-Known Member

    Hi Uboat!

    It would take too long to explain where you have gone wrong... so lets put things right.

    Your best bet is to download the stock Samsung firmware for your model of phone and CSC code and flash it via Odin by following the instructions in the links of #1.5 of 29 Galaxy S4 models - know yours?

    Once you have the phone up and running, you can then root and install a custom recovery by following the instructions in posts #1, #2, #3 and #4 of Rooting Galaxy S4 - Dummies Guide.

    After you are rooted you can then move on to de-bloating your firmware by following the instructions in Bloatware removal - Dummies Guide.

    Please take the time to carefully and thoroughly read all posts and links before posting any questions.



    ironass motto..."Flash in haste... repent at leisure" ;)
    dynomot likes this.
  23. dynomot

    dynomot Well-Known Member

    Uboat cannot get into download mode ironass, old bean.

    I can only suggest a USB jig to force it into download (odin) mode. Never have I spent a measley couple of quid on a more valuable piece of hardware.

    http://www.ebay.co.uk/bhp/usb-jig
    ironass likes this.

Share This Page