[International] Help with rooting S4 GT-I9506

Last Updated:

  1. dochollidae

    dochollidae Member

    Hello all,
    I frequent these forums a lot, but I don't post much because I always find what I need. I've bricked and/or successfully rooted my fair share of devices, but right now I am having a bit of a problem.

    I am trying to root my Galaxy S4 GT-I9506, but I am having absolutely no success. I've read the posts about the GT-I9505 but my attempts have been unsuccessful for my GT-I9506.

    I got the phone here in Germany (I moved here from the US and my super-slick HTC One SV doesn't work here). My contract is with T-Mobile, but the device is completely unlocked and should (from what I was told) work with any carrier.

    Any help would be greatly appreciated. I would really like to root this device. It has been bothering me since I got it, and I soft-bricked it a couple of times trying various things. Thanks in advance.

  2. AndroidProf

    AndroidProf Well-Known Member

  3. dochollidae

    dochollidae Member

    I have tried this. But I keep getting an error message while trying to apply an update from the SD card. It says something along the lines of "E: signature verification failed".
  4. ironass

    ironass Well-Known Member

    Have you tried going into PhilZ Recovery > Install zip > Signature Verification (toggle this off)
  5. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

  6. ironass

    ironass Well-Known Member

  7. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    That is true it isn't but the op still needs to state what os they are on cause it can be made with a few clicks :eek::D


    The URL is the closest so far cause it uses a cwm if u read the URL I posted it say it states safestrap recovery ..
  8. ironass

    ironass Well-Known Member

    Yes, that would be helpful BRAINZ2013. ;)
  9. dochollidae

    dochollidae Member

    Hmmm. That's interesting. Perhaps the recovery isn't successfully installed. When I enter recovery, I don't think it's the Philz recovery that I attempted to install via Odin. When I go into it, the little green alien thing falls dead and has a red triangular thing sticking out of his/her chest with an exclamation mark on it. At the very top, it says "Android system recovery <3e>"

    There is no option to turn off signature verification.

    I am running Android version 4.3, Kernel version 3.4.0-2210443
  10. dochollidae

    dochollidae Member

    I tried the Easyroot method, and this is the message I got:
    Code (Text):
    1. Plug in your phone and Press any key to continue
    2. [*] Waiting for your phone to appear
    3. [*] Your phone is detected and ready for rooting.
    4. [*] Sending files to your device...
    5. [*] Starting rooting program.
    6. ro.build.product=ks01lte
    7. ro.build.id=JSS15J
    8. setsockopt() failed: Bad address.
    9. this device is not supported.
    10. kallsyms_addresses search failed.
    11. [*] Checking if rooting succeeded
    12. [*] Unfortunately, rooting failed. Cleaning up.
  11. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    Do you have the phone drivers on your PC/laptop
  12. dochollidae

    dochollidae Member

    I've tried this. It seems to do nothing. The recovery never seems to install.
    Yes. I have Samsung Kies installed.

    But at the same time, I guess I should add that I installed some awkward USB 3.0 drivers on my computer so that I could root my HTC One SV. I'm not sure that it matters, but I guess I should mention that.

    The specific details involve installing Intel(R) USB 3.0 eXtensible Host Controller drivers from Intel instead of the drivers that came from Microsoft. I'm mentioning that because I don't know if that might be interfering with the seemingly simple processes that you guys are trying to help me with.

    Thanks in advance
  13. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    Do you have Odin installed and which version you have installed
  14. xvision00

    xvision00 New Member

    Hey did you have any luck with it ? Im experiencing the exact same problem not being able to root this phone..Mine is the vodafone version jellybean 4.3 I9506XXUBNB2. not sure if the firmware version affects whether it can be rooted or not but tried both:
    Philz_Touch__CWM_6.3.7_V5.15.0_unofficial_(fixed_preload) and
    and no luck :(

Share This Page