[International] How To Unroot/Upgrade?

Last Updated:

  1. BreShiE

    BreShiE Member

    Hello there, I've just signed up to this forum to ask for some help and I'm not exactly sure where to put this.

    I own the HTC One and a few months back I rooted the device. It somehow unrooted itself and this never really bothered me. However, I've been recently wanting to upgrade my Android version as I'm stuck on 4.1.2 but the upgrade corrupts every time.

    My phone is pushing for a 4.2.2 update, but it doesn't work. I can download the update fine, but when my phone reboots to install, my phone goes into recovery mode which in-turn boots up my root bootloader. Is there a way to stop the bootloader from loading, and change it back to how it used to be?

    I just want to upgrade, I don't care about my phone being rooted. In fact, I don't want it rooted at all. Speaking to a friend, he's advised me to flash the ROM to the phone, but I want this to be a last option. I don't feel like loosing all my files again.

    I hope you can help!
    ~ BreShiE

  2. scotty85

    scotty85 Guides Guide

    your update is likely failing because youre running a custom recovery,and/or you may have deleted some system apps or files.

    if youve kept your phone stock without delteing anything,prolly we can use re-install a stock recovery.

    if you have modified or deleted things,then you may need to run an ruu to get everything back to stock,wich will mean having to re-set up the phone.

    at any rate,the starting point is to know exactly what you have.

    if you can do the below,and post the output(x-ing out your esn and imie) we can go from there. it would also be helpful to know how you rooted the phone,and what mods you made afterwards.

    first download and install these drivers: revolutionary drivers (mirror)

    then,download this small file:

    -unzip it,and place the unzipped folder onto the root of your C drive(not inside a folder)

    -open a cmd window(with win 7,click start bubble,type "command" or "cmd" in hte search box)

    -now change to your mini-adb directory(assuming you didnt chagne the name). type in the black cmd window that opened on your PC:
    cd c:\mini-adb

    -pull the battery in your phone for a few seconds. hold volume down,then power. hold them both until you see the white/colored writing hboot screen

    -select "fastboot" from the hboot menu with the vol rocker/power button

    -in your cmd window type:
    fastboot devices

    it should output your phones serial number. if so youre good to go. if not,youre apparently having a driver issue. i usually recomend these drivers from Revolutionary: modified htc drivers download and install the drivers(you should just have to run that file). afterwards,unplug your phone,plug it back in. make sure its in fastboot. as soon as you get a result from "fastboot devices" your ready to procede to the next step.

    -in your cmd window,type(or copy/paste,is much easier):
    fastboot getvar all

    -copy the info that outputs here. right click in your cmd window,click mark,highlight it all in white. hit enter. paste the info here. it will help us know which ruu for you to run. :)
  3. BreShiE

    BreShiE Member

    Thanks for your reply! Here are my results:

    C:\mini>fastboot getvar all
    INFOversion: 0.5
    INFOversion-bootloader: 1.44.0000
    INFOversion-baseband: 4A.14.3250.13
    INFOversion-cpld: None
    INFOversion-microp: None
    INFOversion-main: 1.29.401.12
    INFOversion-misc: PVT SHIP S-ON
    INFOserialno: xxxxxxxxxxxxxx
    INFOimei: xxxxxxxxxxxxxx
    INFOmeid: 00000000000000
    INFOproduct: m7_ul
    INFOplatform: HBOOT-8064
    INFOmodelid: PN0710000
    INFOcidnum: HTC__001
    INFObattery-status: good
    INFObattery-voltage: 4254mV
    INFOpartition-layout: Generic
    INFOsecurity: on
    INFObuild-mode: SHIP
    INFOboot-mode: FASTBOOT
    getvar:all FAILED (status read failed (Too many links))
    finished. total time: 0.046s
    scotty85 likes this.
  4. scotty85

    scotty85 Guides Guide

    ahh you are in luck!

    here is your stock recovery:

    *if* you are still on the stock rom,and have not deleted bloat or otherwise modified it,all you need to do is download and install,just as you did your current custom recovery.

    -place in your adb/fastboot folder
    -open cmd window,change to adb/fastboot directory
    -flash recovery with:
    fastboot erase cache
    fastboot flash recovery recoveryimagename.img

    ( fastboot flash recovery recovery-1.29.401.2.img if you do not change the name )

    hopefully that will get your OTAs rolling again.

    holler if you have firther questions :)
    lhuge likes this.
  5. BreShiE

    BreShiE Member

    Hey, I was told by someone that I am not able to flash a ROM due to me being S-ON. Is this true? I'm guessing this isn't flashing a ROM though and is just loading a recovery.

    EDIT: Also, how long does the cache erase take? It's been going now for like 1 hour and 30 minutes and still nothing. Still the same old; Erasing 'cache'...
  6. scotty85

    scotty85 Guides Guide

    It is absolutely NOT true. If you leave a custom recovery in place,you can certainly flash roms while s on if you wanted to.

    Sounds like its hung. Erase cache should only take a couple seconds. Make sure that you have the phone in fastboot mode,and not hboot. You should have a red "fastboot USB" on the screen while plugged in.
  7. BreShiE

    BreShiE Member

    Yes, it does have this. I would take a picture but I have no way to.

    It is it fastboot mode, so I am not sure what's wrong?

    EDIT: Rebooted my phone and tried again. The cache erased straight away. When I tried to use recovery, however, it errored:

    C:\mini>fastboot flash recovery recovery-1.29.401.2.img
    sending 'recovery' (9594 KB)... OKAY [ 1.802s]
    writing 'recovery'... INFOsignature checking...
    FAILED (remote: signature verify fail)
    finished. total time: 2.742s
    scotty85 likes this.
  8. scotty85

    scotty85 Guides Guide

    Is your boot loader still unlocked? Are you sure you still have a custom recovery installed?

    What happens if you chose recovery from the hboot menu?
  9. BreShiE

    BreShiE Member

    Ah, I was advised by someone to re-lock freeboot. Should I unlock it again? If so, how do I do that?
  10. scotty85

    scotty85 Guides Guide

    yes,you will need to re-unlock the bootloader to install the stock recovery. you will need to do it just like you did the first time,by using the htcdev website.

    if you have your original unlock_code.bin,you can use that. if not,youll have to repeat the entire process to get a new unlock_code.bin.

    unfortunately,this may wipe your data again in the process.

    what concerns me is that with a relocked bootloader,you would prolly not have a booting,working phone if you do have a custom recovery installed. you would be stuck in bootloader,with a security warning

    if you do still have a stock recovery installed,then your OTAs are failing for a different reason.

    so before you unlock again,we need to figure out what recovery youre running.
    -power on into hboot
    -select recovery from hboot menu
    -what do you see?

    if a custom recovery like twrp or clockwork comes up,it will be obvious. if you have the stock recovery,youll get a black screen for a minute,then a red triangle and !

    if you have the stock recovery,hold vol up and power until you see a menu. try erasing cache,and then reboot.

    let the phone try and OTA again,and pay close attention so that you can give us the exact error message if it fails.

    im off to work,but ill try and watch if you have questions :)
  11. BreShiE

    BreShiE Member

    Hi again.

    When I try to select recovery, it brings up the "HTC" screen, then goes into FASTBOOT. This is confusing, haha.

    Would it just be easier to go S-OFF and flash my stock ROM again? I've backed up all my important pictures.
  12. clsA

    clsA Well-Known Member

    updating will fail due to the files that are deleted when the bootloader was initially unlocked. I forget all of them but flashlight and calculator,ringtone trimmer,pdf viewer, sound recorder are some of them.

    Ruu back to stock is the best option
    theirs guides here >> [GUIDE] nkk71's SuperGUIDE to returning 100% back to stock - xda-developers

    and here >> [GUIDE] How to Return to 100% Stock - xda-developers
  13. BreShiE

    BreShiE Member

    Hey, thanks for your reply.

    I still have all the applications you mentioned in your posts. The flashlight I use constantly, so I'm 100% sure they're still there.

    I'll check out those guides now, thanks! I hope they can help me getting S-OFF.

    EDIT: When I do the following command:

    Code (Text):
    2. adb push revone /data/local/tmp
    I get

    Code (Text):
    2. error: device not found

    I managed to get to:

    Code (Text):
    2. ./revone -P // This was successful
    Yet, after restarting the device, adb cannot find the device again.
  14. clsA

    clsA Well-Known Member

    you have to be in recovery/or booted to OS for the device to use adb
  15. BreShiE

    BreShiE Member

    Yeah I know this.

    I think the problem is that the device driver isn't working properly. I'll try and update the driver and get back to you.

    Thanks for both of yours help so far.
  16. BreShiE

    BreShiE Member

    Still no dice. I'm getting the error code -1 with revone when I try the following command:

    Code (Text):
    2. ./revone -s 0 -u

    Code (Text):
    2. ./revone -t
    This command says it works, but it still says *** TAMPERED *** on the fastboot. Not sure what the hell is going on. It's not letting me obtain S-OFF.

    I did a little research and apparently revone is for 4.2 only? My phone is running 4.1.2 currently.
  17. scotty85

    scotty85 Guides Guide

    prety sure i was on 4.1 when i used revone. the prollem is with the lack of root access. some sprint users were able to get s off from revone without unlocking the bootloader,but i dont believe any of us with a gsm device were that lucky. i was unlocked and had supersu installed in the stock rom.

    heres a copy of what i did:
    Code (Text):
    1. c:\miniadb_m7>[COLOR="Red"]adb push revone /data/local/tmp/[/COLOR]
    2. 3272 KB/s (646704 bytes in 0.193s)
    4. c:\miniadb_m7>[COLOR="red"]adb shell[/COLOR]
    5. shell@android:/ $ [COLOR="red"]cd /data/local/tmp[/COLOR]
    6. cd /data/local/tmp
    7. shell@android:/data/local/tmp $ [COLOR="red"]chmod 755 revone[/COLOR]
    8. chmod 755 revone
    9. shell@android:/data/local/tmp $ [COLOR="red"]su[/COLOR]
    10. su
    11. root@android:/data/local/tmp # [COLOR="red"]./revone -P[/COLOR]
    12. ./revone -P
    13. revone successful - please reboot to continue.
    14. root@android:/data/local/tmp #
    16. [COLOR="Blue"]*physically reboot phone(dont use adb reboot)[/COLOR]
    18. c:\miniadb_m7>[COLOR="Red"]adb shell[/COLOR]
    19. shell@android:/ $ [COLOR="red"]cd /data/local/tmp[/COLOR]
    20. cd /data/local/tmp
    21. shell@android:/data/local/tmp $ [COLOR="red"]su[/COLOR]
    22. su
    23. root@android:/data/local/tmp # [COLOR="red"]./revone -s 0 -u[/COLOR]
    24. ./revone -s 0 -u
    25. revone successful.
    26. root@android:/data/local/tmp # [COLOR="red"]exit[/COLOR]
    27. exit
    28. shell@android:/data/local/tmp $ [COLOR="red"]exit[/COLOR]
    29. exit
    31. c:\miniadb_m7>[COLOR="red"]adb reboot bootloader[/COLOR]
    33. c:\miniadb_m7>[COLOR="red"]fastboot getvar all[/COLOR]
    34. (bootloader) version: 0.5
    35. (bootloader) version-bootloader: 1.44.0000
    36. (bootloader) version-baseband: 4A.14.3250.15
    37. (bootloader) version-cpld: None
    38. (bootloader) version-microp: None
    39. (bootloader) version-main: 1.27.531.7
    40. (bootloader) version-misc: PVT SHIP S-OFF
    41. (bootloader) serialno: HTxxxxxxxxxx
    42. (bootloader) imei: xxxxxxxxxxxxxxx
    43. (bootloader) meid: 00000000000000
    44. (bootloader) product: m7_ul
    45. (bootloader) platform: HBOOT-8064
    46. (bootloader) modelid: PN0713000
    47. (bootloader) cidnum: T-MOB010
    48. (bootloader) battery-status: good
    49. (bootloader) battery-voltage: 4107mV
    50. (bootloader) partition-layout: Generic
    51. (bootloader) security: off [COLOR="Blue"]<-hooray![/COLOR]
    52. (bootloader) build-mode: SHIP
    53. (bootloader) boot-mode: FASTBOOT
    54. (bootloader) commitno-bootloader: dirty-60fafa5b0be2807a0ad050f62f94e0010
    55. getvar:all FAILED (unknown status code)
    56. finished. total time: 0.087s
    (the above is from this thread: http://androidforums.com/international-one-all-things-root/728504-two-s-off-methods.html )

    rather than continue with the fustration at this point,i would prolly recomend that you re-unlock the bootloader and install superuser. i think youll have no issues at that point getting revone to work,and then it will be easy to ruu back to a stock "OTAable" build.

    the other option is,as clsa said,to ruu back to stock while s on,wich is going to also erase your data.

    even if you wish to run stock,it is good,IMO to be s off. its a great safety net,as having no security checks gives you lots of options when you have issues with your phone. it also lets you easily re-root later without htcdevs website,if youre ever so inclined :)
  18. lhuge

    lhuge Member

    @scotty85, I think you've helped me even more in this thread than in my own noob-questions thread ... thanks.

    I'm in a similar boat to the OP, maybe in slightly better shape: I'm rooted, S-OFF, un-"TAMPERED", on 4.1.2 / hboot 1.4.4 / SW# 1.27.531.8

    I had to downgrade from SW # 1.27.531.11 to .8 in order to get S-OFF with revone, and now I'm being offered the OTA to go back to .11. From the thread I followed to do that downgrade I understand that I don't need to stay on .8, since my S-OFF will survive basically anything. But when I tried to install the OTA, of course it booted to my now-custom recovery.

    I think I understand how to download and flash a stock recovery image which would allow me to install the OTA - in fact I've downloaded tmo_fw_1.27.531.8 and extracted the recovery image.

    What I don't know is whether it's silly to do things incrementally like that, or if I should just decide on the 4.3 or 4.4 ROM I want to install and flash it. I don't know how "Software Number" relates to "Android Version", and whether upgrading one necessarily means upgrading the other.

    Am I right that because I am S-OFF on hboot 1.44, I can kind of do whatever I want, ie try a custom ROM and then if I don't like it switch back to a stock ROM, etc?

    Am I also right that flashing a ROM requires wiping all my data, but flashing a (custom or stock) recovery image does not?

    If anyone can recommend a noob-friendly next step, like "just stick with stock ROM - get the 4.4/5.5 ROM from the xda thread" or "Get Avatar's latest custom ROM, it's super-easy" etc... that would be great. I'd like to start getting the benefit from rooting without spending too many more hours hunched over my computer rebooting/reflashing/fastbooting etc...

    scotty85 likes this.
  19. scotty85

    scotty85 Guides Guide

    the only issue with flashing a rom,is that youre staying on your old firmware. firmware is pulled from an OTA package for rooted users to flash,but they only contain whats new for that update. i.e.,if you flashed a new firmware package,its not updating everything.

    what i would prolly recomend is to run the 4.3 ruu: Shipped ROMs

    this will update all firmware and give you a newer,more stable "base" to flash 4.3/4.4 roms on. afterward youll just need to re-install your custom recovery and then flash away! :D

    there is nothing wrong with incremintally OTAing all the way to current,but it will take you a bit longer ;)

    hope that helps,holler if you have further questions :)
    lhuge likes this.
  20. lhuge

    lhuge Member

    Thanks again @scotty85. I actually went ahead and did the 2 OTA's pending just to get comfortable with the process of switching recoveries & re-rooting etc, and to see where that got me.

    The link you posted gets me to the following message:

    Looking at the file name of that RUU file:

    ... it matches up with my current setup pretty well:

    ... but I don't know if the RUU you're suggesting (assuming I could still find it somewhere) is different somehow or would give me some stability benefit that I'm not understanding.

    I notice in the getvar output that my bootloader is up to 1.55 from 1.44 - is that a bad thing or does it not matter since I'm already S-OFF?

    more thanks.
  21. scotty85

    scotty85 Guides Guide

    not sure whats up with that,it gave me the same error,and if i click on it to download i get it as well. must be an issue with shipped roms. at some point i will try and re-upload it.

    the one section of shipped roms is here: Shipped ROMs

    and there are ruus here as well: AndroidRUU | The #1 source for Android RUU files

    fear not,i have the ruu and if you need it before i can upload it,i can get it to you.

    nope,the OTAs updated you to the exact same setup,so youre good to go. there is nothing different that the ruu gives you that the OTAs dont,or vice versa. the ruu was just a slightly faster way there. no biggie :)

    the newer bootloaders do not allow you to use the fastboot boot command,but other than that,the newer version is ok. since your s off,you can still install things and do whatever you want. some folks like to stay with the older 1.44 hboot,but i personally like to always be on the newest stuff :cool:

    i converted my t mobile one to us developer edition CID and MID so i could get those OTAs,but thats not something you have to do,especially if you like some of t mobiles included apps and features(wifi calling for example).

    until the t mobile version gets its own 4.4 update,you are on the newest firmware now,and are clear to try some 4.3/4.4 roms if thats your fancy :cool:
  22. Hadron

    Hadron Well-Known Member Contributor

    Oh, even I'm running the latest hboot now. :)

    I figured that since I am S-Off already if I ever really need to fastboot boot I can always reflash 1.44, so thought I'd try running a coherent set of firmware for a while, see whether I noticed any difference.
    scotty85 likes this.
  23. clsA

    clsA Well-Known Member

    I've been very happy using the Dark Bootloader (hboot 1.54.000) from the KitKat Google Play Edition. Fastboot works with windows 8.1 with this version.

    I use the last AT&T firmware 3.17.502.3 it seems to have the best radio for my area.


    If you want the Dark/Inverted splash screen I have shown on my phone it can flashed separately from here.
    Just install from recovery.

    Hadron and scotty85 like this.
  24. Hadron

    Hadron Well-Known Member Contributor

    I'm currently running the 4.19.401.8 firmware from the international 4.4.2 (my phone is an international model after all). As I don't use Windows I've not had to worry about Windows 8 compatibility ;)

    I've grabbed the splash screen though :)
    scotty85 likes this.
  25. scotty85

    scotty85 Guides Guide

    I think I am slowly but surely moving away from windows. Even on my windows machine,I've stayed with 7 since 95% of what I do on my pc is phone crap ;) hadron,what are you using?

    Clsa,does the little padlock change with your bootloader lock/unlocked status? If so,is that a function of GPE hboot? I.e.,do you see it no matter what splash you run?

    Since were sharing firmware,im on 4.06.1540.3 developer edition firmware on my t mobile branded phone. When the phone is using LTE,it only displays one lonlely signal dot,no matter what the signal strength actually is. I assume this is a 4.4 quirk,since I've had it on all 4.4 roms I've used,no matter what firmware.

Share This Page