[International] HTC ONE Bricked and no ruu find in xda site.... pls help

Last Updated:

  1. Pls help my HTC bricked on
    eMMC-BOOT 2048MB

    Pls help me what to do there is no os in my HTC One, and which ruu file need to download, it was stuck since last 10 days, i had tried many files but it was showing error 170, while running ruu file, i had tried RUU_M7_UL_JB_50_hTC_Asia_WWE_1.26.707.5_Radio_4A.13.3231.20_10.30.1131.05_release_309365_signed_2_4.exe and RUU_M7_UL_JB_50_hTC_Asia_WWE_1.29.707.3_R_Radio_4A.14.3250.13_10.33.1150.01_release_311678_signed.exe this file but showing same error no 155. Which ruu file i need to download for this, pls help me.

  2. Hadron

    Hadron Well-Known Member Contributor

    You have a M7_U, not an M7_UL (i.e. you have a non-LTE model), which is why the RUUs you've listed don't work. Unfortunately the only RUU I've found for that so far (at Androidruus.com) is older, so probably won't work either (but look for the M7_U RUU there if you wish to try - editing on a different device now so can't link).

    If you are unlocked you could install a custom recovery and then a custom ROM. That would be another way of getting it going. The "HTC One root thread" in this forum should tell you what you need to do to install a recovery on an unlocked phone.

    I have to go offline now, but someone will be able to advisedev if you need help.

    If you can tell us how the phone got into this state it may help identify other options.
    scotty85 likes this.

  3. Hi, i m new to htc world, i m actually a iphone user, and this is very first time i used htc android phone after a 7 years of iphone world, can u pls help me how to process all this, is there any software from which i can run and directly do all this, or i need to used cmd from pc for doing all this. pls help me i m from india so which rom i need to download from xda site.
  4. Hadron

    Hadron Well-Known Member Contributor

    If you can't boot up the phone then you will need to use a PC.

    What did you do to get the phone in this state? I'm guessing you (or someone) tried to modify the software (as it says "tampered" ), but what exactly did you do and actually happens if you try to boot the phone? And if you select recovery from the bootloader menu (the white screen with the information you quoted in the first post) what happens?

    Just trying to understand the state of the phone and what is needed.
    scotty85 likes this.
  5. it was stuck in htc logo and if i long press power and down volume key it was showing me status and if i put it in recovery mode, it was showing same htc logo with entering recovery mode, but not go forward. So i m wrongly put some viper rom and install it after root without s-off, after installation i dont like that rom. i m trying to go back to previous version, so i wipeout all, but by default my default htc kitkat version deleted. and its brick. now i m trying to download this file "RUU_M7_U_JB_50_hTC_Asia_TW_1.20.709.101_Radio_4A.13.3227.06_10.27.1127.01_release_307831_signed_2_4.exe" is this file work for me? pls help...
  6. Hadron

    Hadron Well-Known Member Contributor

    You say you wiped all, does that include erasing system? If so then that did erase the ROM, and as a phone only has one ROM that would leave no OS (any ROM you install overwrites the previous one).

    That looks like the one M7_U RUU I found. It's older than your previous software, so may well not work, but there's nothing to lose by trying.

    Do I understand correctly that you cannot get into recovery?
    scotty85 likes this.
  7. scotty85

    scotty85 Guides Guide

    do the following,and paste the output for us here. make sure to delete your esn and imie. doing this will get you working adb/fastboot and get us some additional info about your phone.

    first download and install these drivers: revolutionary drivers (mirror)

    then,download this small file:

    -unzip it,and place the unzipped folder onto the root of your C drive(not inside a folder)

    -open a cmd window(with win 7,click start bubble,type "command" or "cmd" in hte search box)

    -now change to your mini-adb directory(assuming you didnt chagne the name). type in the black cmd window that opened on your PC:
    cd c:\mini-adb

    -pull the battery in your phone for a few seconds. hold volume down,then power. hold them both until you see the white/colored writing hboot screen

    -select "fastboot" from the hboot menu with the vol rocker/power button

    -in your cmd window type:
    fastboot devices

    it should output your phones serial number. if so youre good to go. if not,youre apparently having a driver issue. i usually recomend these drivers from Revolutionary: modified htc drivers download and install the drivers(you should just have to run that file). afterwards,unplug your phone,plug it back in. make sure its in fastboot. as soon as you get a result from "fastboot devices" your ready to procede to the next step.

    -in your cmd window,type(or copy/paste,is much easier):
    fastboot getvar all

    -copy the info that outputs here. right click in your cmd window,click mark,highlight it all in white. hit enter. paste the info here. it will help us know which ruu for you to run. :)
    Hadron likes this.
  8. ok...Thanks
  9. when i put it into recovery mode, it shows only htc logo with text "entering recovery" and stuck here only
  10. C:\Users\Tanveer\Desktop\mini-adb>fastboot getvar all
    INFOversion: 0.5
    INFOversion-bootloader: 1.56.0000
    INFOversion-baseband: 4A.23.3263.28
    INFOversion-cpld: None
    INFOversion-microp: None
    INFOversion-main: 4.20.707.7
    INFOversion-misc: PVT SHIP S-ON
    INFOserialno: HT367W905447
    INFOimei: 354435054484522
    INFOmeid: 00000000000000
    INFOproduct: m7_u
    INFOplatform: HBOOT-8064
    INFOmodelid: PN0711000
    INFOcidnum: HTC__038
    INFObattery-status: good
    INFObattery-voltage: 3841mV
    INFOpartition-layout: Generic
    INFOsecurity: on
    INFObuild-mode: SHIP
    INFOboot-mode: FASTBOOT
    INFOcommitno-bootloader: dirty-59adc32b
    INFOhbootpreupdate: 11
    INFOgencheckpt: 0
    all: Done!
    finished. total time: 0.054s
  11. now what to do? pls help
  12. scotty85

    scotty85 Guides Guide

    -download this recovery image: Techerrata Downloads - Browsing m7
    -place it into the miniadb follder you used above.
    -place your phone into fastboot
    -open the cmd window like you did above and enter:
    fastboot devices

    fastboot flash recovery openrecovery-twrp-

    fastboot reboot

    -give the phone a few minutes,then do a hard reset(hold power) and get back to hboot,then choose recovery

    hopefully now you can get to twrp recovery,where you can either push your rom to the internal storage,or use the recoveries sideload feature to install a rom.

    we can give some more detail later once youve got a recovery working,but in a nutshell:

    *place a rom into the miniadb folder. then:

    push to internal storage
    -open cmd window,and put the phone into recovery
    adb devices

    if you get serial number recovery back,then try:
    adb push romname.zip /data/media/0

    if that is successful,use recovery menu options to reboot recovery,then attempt to install the rom normally,it should now be on internal storage. make sure to wipe data/factory reset

    -place phone in recovery,open cmd window
    -start sideload on phone
    -enter in cmd window:
    adb sideload romname.zip

    once you have a working recovery,you can also use a usb "OTG" adapter to flash a rom from an external flash drive or sd card.

    im off to work,but holler if you have questions :)
    Hadron likes this.
  13. Pls help me i buy a new OTG Cable and i put a rom "ViperOne_2.1.0.zip" inside it
    and install, it was install successfully but dont boot again
  14. scotty85

    scotty85 Guides Guide

    you may need the newest recovery,if thats not what youre using.

    try to wipe data/factory reset,wipe cache,and wipe dalvik cache and try flashing the rom again
  15. i do the same...... now i m trying to download One_4.06.1540.2_odexed.zip
  16. finally it was started thanks.... but i installed paranoid rom instead of original one
  17. scotty85

    scotty85 Guides Guide

    awsome! glad you are sorted :)
  18. i want reset my tempered and do my s-off... can u pls help me for it.....
  19. scotty85

    scotty85 Guides Guide

    Once you're up and running,you can use rurunner or firewater to s off. Then there is a thread here that you can use to.reset tampered and locked.
  20. yes it was working properly with android 4.4 version. but i need to do s-off so i can update my htc with samsung s4 rom....
  21. clsA

    clsA Well-Known Member

    bad idea :rolleyes:
    scotty85 and Hadron like this.
  22. Hadron

    Hadron Well-Known Member Contributor


    S-Off has many uses, but it isn't actually needed for installing custom ROMs. And while it makes many things much easier, because it allows you to bypass various safety checks it's up to you, once you are S-Off, to make sure you don't do anything that could damage the phone.

    ROMs are device-specific, to the extent that they don't always work between different versions of the same device (e.g. a ROM for the International HTC One may not work on a Verizon HTC One), and they don't work between different devices even from the same manufacturer (a ROM for a HTC One M7 will not work on a HTC One M8, for example). You'll see some ROMs, e.g. CyanogenMod, which are available for many devices, but those have been built separately for each device they support, and if you try to install the wrong build on the wrong device it won't work at all.

    So if you are thinking of trying to install a Samsung ROM on a HTC device, just don't even try it. The best that could happen would be that it would fail to install. If you got the ROM installed the best you could hope would be that it didn't do any permanent damage and that you were still able to load a compatible ROM afterwards. There is no way a HTC phone can work with Samsung software, but depending on what you did you could damage the phone trying.
    scotty85 and clsA like this.
  23. i m still having problem while updating my os from 4.4 to 4.4.2, it was shows me tempered and unlocked with s-on, can u pls help me how to fix it and need to do s-off.
  24. Hadron

    Hadron Well-Known Member Contributor

    If you look in the HTC One All Things Root Guide sticky post in this forum ( http://androidforums.com/showthread.php?t=685946) you'll find links to threads for the firewater and rumrunner S-Off tools Scotty suggested. Just use one of those for S-Off. The same sticky thread also has a link to instructions for removing the tampered flag.

    When you say you are having trouble updating, how are you trying to update? Also what ROM are you running and what recovery are you using?
  25. i m stuck on rumrunner. it shows me error it was stinky, try again later.... i really frustated with s-off. my hboot is 1.56 can u pls help me how to resolve it, even i had tried for moonshine... MY cid is HTC__038 which ruu file i need to be download for india my handset is manufactured by taiwan and import it to india...

Share This Page