[International] HTC One:- Vodafone branding removal


Last Updated: 2014-03-29 19:25:29
  1. peachy125

    peachy125 Well-Known Member

    Hi all,

    could anyone point me in the right direction to remove the vodafone branding from my HTC One please?

    Advertisement
  2. heat57

    heat57 Well-Known Member

    You need to either have an unlocked bootloader (via HTC Dev) or be S-Off, which I'd recommend in order to flash another ROM (also requires a custom recovery). I'd recommend S-Off as it's the only way to remove the 'Tampered' mark from bootloader screen and reset your phone back to complete stock for warranty purposes.

    Once done, you can download and flash either a stock based RUU (ROM Update Utility, unbranded version) or flash a custom ROM.
    scotty85 and peachy125 like this.
  3. peachy125

    peachy125 Well-Known Member

    Hi, and thanks for your reply. On going through the instructions to achieve s-off, I firstly have to unlock Hboot, but a lot of the links were dead or full of trojan's. So that is pretty much as far as I got. :confused:
  4. heat57

    heat57 Well-Known Member

    Hi again Peachy. First of all let me encourage you to read as much about the subject as possible as there is no substitute/magic wand for getting to grips with what you want to achieve.

    Amongst others on here, I'll try and guide you and provide sources of information to enable you to do this successfully. Be warned, don't just make a cursory read, if uncertain go and ask or 'Google'.

    Now to the nitty-gritty. The best source (imho, and no offence to anyone in this forum) are the developers over at XDA. They usually provide in-depth guides, from rooting, bootloader unlocking, S-Off, custom recoveries and custom ROMs, as well as general stuff of interest. You simply join and its FREE.

    P.S. I bought a HTC One from eBay (for an incredible price) and that also came with Vodafone firmware and ROM, so I have gone through what you want to achieve and I have successfully flashed a custom ROM, have unlocked the bootloader and am S-Off with 'Tampered' flag removed from bootloader. I had a lot of drama with my PC not recognising the HTC in adb (you'll read about this in the links, it is essentially the means of communication between your PC and your android phone). This was entirely due to my PC operating system being Windows 8.1, which doesn't play nicely with the drivers needed for adb, but I got around it in the end. Just thought I let you know.
    Go to this forum at XDA for a good guide to achieving S-Off and SuperCid on HTC phones. With SuperCid you can flash any ROM regardless of for which country/operator they where issued. Here is the link [Guide] Vomer's Ultimate AIO - S-OFF, SuperCID, Firmware Upgrade & Custom Recovery - xda-developers

    You might also want to look at this thread for flashing guide to get back to 100% stock and how to unlock your bootloader - [GUIDE] Complete Flashing Guide | Rooting | Going Back To Stock | 05.05.2013 - xda-developers

    Finally, once you become a member there you can look at the HTC Development forums for custom ROMs, Stock and rooted ROMs, custom recoveries and kernels. The forums are here HTC One - xda-developers

    Finally, first things first.

    1. Unlock your Bootloader at HTC Dev (just follow the instructions on the site Welcome to HTCdev (beware, you will loose any warranty after you have unlocked; there are ways of relocking the bootloader and going back to S-On, but this is a bit more involved. First get into it and read through the forums.)

    2. Gain S-Off - you need this in order to update the Firmware (this is not the ROM, but the hardware codes for bootloader, Radio, recovery, etc.). You can flash recoveries and ROMs without S-Off but if you want to return to a stock HTC at any point in the future you can only do this with S-Off (remove 'Tampered' Flag and return to an original CID and so on.

    3. Flash custom recovery, followed by Superuser (gain root access) - I'd recommend Chainfires SuperSu (he's also a developer at XDA.

    4. Before flashing manipulating your HTC read, read, read and good luck.
    peachy125 likes this.
  5. scotty85

    scotty85 Guides Guide

    if youre useing the guide here,there should not be any prollems with dead links. if you do encounter something let me know and ill look into it.

    rest assured that alot of the phone exploits are just seen as trojans by your security programs,there should not be any issue. if youre concerned,you can always run the tools from an ubuntu live cd(wich is a better idea,anyway,imo)

    otherwise,you may just need to temporarily tone down or turn of your securities to run them on windows.

    wether you want to stay s on,or go full s off(my recomendation as well) the first step is unlocking the bootloader. see this thread for info: http://androidforums.com/international-one-all-things-root/720478-htc-one-root-thread.html

    just holler if you have questions :)
    heat57 and peachy125 like this.
  6. peachy125

    peachy125 Well-Known Member

    Firstly, cheers guys. I'm going to have a good read up about all of the info provided and I think I will attempt the procedure this evening
    scotty85 likes this.
  7. heat57

    heat57 Well-Known Member

    If you carefully follow instructions on the sites mentioned (including scotty85's advice) you should be fine - if in doubt ask before 'pressing the button' (can save you a lot of grieve).

    Other than that you'll never look back and ask yourself what it was all about. You can do so much with a rooted device that you'll ask yourself why you never ventured that way before.
    scotty85 and peachy125 like this.
  8. peachy125

    peachy125 Well-Known Member

    Hi guys, tonight I started to follow instructions to achieve s-off but I'm already scratching my head, feel like an idiot to be honest ha. Firstly, via Vomer's ultimate AIO to get adb and fastboot, I downloaded and extracted to C: drive but not sure how to check the file path is exactly this C:\adb\. Also when going to the adb folder in C:, when I hold shift and right click, there is no option for "Open command window here". If I just click "open", a command window does open but only for a split second, scrolls a bit then disappears. I wouldn't mind but I've done something similar once before with an old HTC Desire HD, successfully too! Just a bit scared of messing this one up though. Thanks for all your help and advice so far, I'm hoping this is just a minor blip and can get past it haha.

    P.S if it helps, my o/s is XP Pro.
  9. clsA

    clsA Guides Guide


    your going to need the command prompt here
    try this
    Add Command Prompt Here Shortcut to Windows Explorer
    peachy125 likes this.
  10. scotty85

    scotty85 Guides Guide

    Have you gotten the bootloader unlocked yet? If so,you're making the command window harder than it needs to be ;) if you used the guide here,you can just use the miniadb files.

    You can do the shift/right click thing,or you can open it and change to it as described in the root guide.

    If you've used the cmd window with your dhd,its not any more difficult with this phone :)
  11. heat57

    heat57 Well-Known Member

    What Windows platform is your PC on?
  12. heat57

    heat57 Well-Known Member

    Sorry, just noticed a reference to XP Pro. In that case drivers should not be an issue and Scotty seems to have a simple alternative to Google's SDK that includes adb in the form of the mini adb, although I must confess I never used it. Either way, you should be able to get comms up-and-running between your One and your XP Pro PC.

    Once you've crossed that bridge you will be on your way. To check a healthy comms open a command window in the folder where you have your adb (mini adb) .exe located and connect your phone via USB after your rebooted into bootloader mode then make sur you're in Fastboot. In Fastboot type into the command window fastboot devices and if you have a valid connection it should return some text along with a 13 or so digit number or alpha-numeric code (which represents your devices Serial No.). If that is the case you are good to go and unlock your bootloader and go S-Off and so on.
    scotty85 likes this.
  13. peachy125

    peachy125 Well-Known Member

    Guys I'm so sorry and feel like I'm wasting your time, I can't even get adb to recognize my phone! My wife thinks I've gone mental too ha.
  14. heat57

    heat57 Well-Known Member

    No. I don't think you've gone mental! Trust me, the biggest hurdle in rooting is to get your device to communicate with your PC as unlocking the bootloader, S-Off and initial flash of custom ROM rely on low-level communications between PC and the phone via adb (Android Debug Bridge) - that reminds me, have you checked in your phone's settings that you have USB debugging enable in Developer Options in Settings? Just in case.

    After you get adb working the rest is fairly easy. Having XP Pro should in theory be straight forward. If you still struggle and you can access another PC with Windows 7 I'd try that route.
    peachy125 and scotty85 like this.
  15. peachy125

    peachy125 Well-Known Member

    Hi heat57, i managed to get adb working this morning but when I came to run rumrunner and the ccommand window came up, it executed fine but stopped 5 minutes or so in to it telling me to go to rumrunner.ru or something like that to use an updated version. I'm at work at the moment but I will be carrying on when I get in. I won't give up! Ha. Thanks so much for all your help and support.Martin.
    scotty85 likes this.
  16. scotty85

    scotty85 Guides Guide

    It's a bit tricky getting rumrunner to run on a windows pc,as the exploits used are flagged as virus... Many folks have had to temporarily disable their firewall and.security programs. Another option(the better one,imo) is to run the tool from an ubuntu live cd.

    Have you gotten the bootloader unlocked and superuser installed?
    heat57 likes this.
  17. peachy125

    peachy125 Well-Known Member

    Hi Scotty85, I haven't done as yet as ill need to get the updated version of rumrunner later. I have totally disabled my avg and firewall, I do have an ubuntu live disc so if I fail then I'll run it all with ubuntu. Cheers, Martin.
  18. scotty85

    scotty85 Guides Guide

    It seems you are a little confused about the proper order of things. You must unlock your boot loader at htcdev.com,and install recovery/root before you can use rumrunner for s off.

    The steps you need to follow:

    -unlock boot loader
    -install recovery
    -flash superuser
    -rumrunner or firewater for s off
    *debrand( there are a couple ways to skin this cat that we can go over when you get to this point )
    heat57 likes this.
  19. heat57

    heat57 Well-Known Member

    ...also beware! Some S-Off exploits only work with certain bootloader versions! If you're on hboot 1.44 you need to use 'revone', for hboot 1.54 and 1.55 I believe it's Rumrunner and for the latest hboot 1.56 it needs to be 'Firewater'.

    But as scotty already said, first things first, you need an unlocked bootloader before trying to gain S-Off. So unlock then check your hboot version and choose the correct exploit. My One was on hboot 1.44 intitially.
  20. peachy125

    peachy125 Well-Known Member

    Ok, just followed instructions to unlock bootloader at htcdev.com, typed in what was required (fastboot oem get_identifier_token), and this is what I get :-

    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\Martin>fastboot oem get_identifier_token
    'fastboot oem get_identifier_token' is not recognized as an internal or external c
    ommand,
    operable program or batch file.

    C:\Documents and Settings\Martin>fastboot oem get_identifier_token
    'fastboot' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Documents and Settings\Martin>

    Also when I download, extract and execute fastboot binaries I get this, This application has failed to start because AdbWinApi.dll was not found. Re-installing the application may fix this problem
  21. scotty85

    scotty85 Guides Guide

    Sounds like you do not have the phone in fastboot
  22. peachy125

    peachy125 Well-Known Member

    Hi scotty85, my phone is definitely in fastboot.
  23. scotty85

    scotty85 Guides Guide

    Sounds then like the fastboot utility is no located in documents and settings \martin
  24. peachy125

    peachy125 Well-Known Member

    I said I wouldnt give up but I think I may have to, sorry guys. Thank you all so much for your help. I've tried but I'm pulling my hair out with it, absolutely nothing wants to work. Thanks, Martin.
  25. scotty85

    scotty85 Guides Guide

    Well,peachy,I think if this is something that you want to do,you are capable of doing it. I suspect that you possibly are confused with all the different links and trying to follow somewhat less clear instructions.

    Sorry for the short answers earlier,but 1) I was at work,and 2) its hard to know what you're doing,what guide your following,what you've tried,etc when your posting in this thread here.

    I suggest you take a few deep breaths and follow the guide here. Go slow and do each step one at a time and it will work for you I promise. I'm not saying that other guides are wrong or bad,just that I wrote this one with folks who've never done anything like it before in mind,as I remember the confusion I had when I first got into all this. Also,I 100% support anything i do here on android forums and will do my best to help you thru it if you have problems.

    Remember,one bite at a time you can eventually eat an elephant :D

Share This Page