[International] No FASTBOOT USB or ADB? It was available but now gone!

Last Updated:

  1. dkonkin

    dkonkin Member


    Over the last couple months I have been searching and troubleshooting but still do not have an answer.

    A couple months back I lost the ability to get FASTBOOT USB. After plugging in HTC One (m7ul) to Mac while in boot loader FASTBOOT would not change to FASTBOOT USB. Also, it is not recognized when doing ADB.

    I have tried different cables and numerous other recommendations with no success.

    Interestingly, when I connect my HTC One X (evita) using the same computer and cable it does go into FASTBOOT USB and I can access it via ADB. Which confirms the issue is in the HTC One.

    Recently I tried to connect via USB with Android File Transfer but it did not see my HTC One. I downloaded HTC Sync Manager to my Mac and it does not see the HTC One.

    Has anyone experienced this before? Does anyone have any ideas what could be wrong?

    Thank you for your time,


  2. Rukbat

    Rukbat Well-Known Member

    The simplest. most likely problem (and the cheapest one to fix) would be a bad connection on the microUSB port. There are 4 active pins - 2 for power, 2 for data. If one of the data pins isn't making contact, no computer will see the phone. If you can see the data on the phone from the computer, that would eliminate that problem and point to a firmware or motherboard problem.
    dkonkin, scotty85 and Hadron like this.
  3. Hadron

    Hadron Well-Known Member Contributor

    Yeah, there is no software commonality between fastboot and adb (in one you are in the bootloader, the other you are running Android), so if both fail the USB connection itself is the simplest cause.

    The cheapest would be if there's a bit of dirt on the pins.
    dkonkin and scotty85 like this.
  4. dkonkin

    dkonkin Member

    Hadron and Rukbat

    Thanks for the response. Confirms what I have been thinking. A couple days back I shot the USB port with pressurized air to see if cleaning the area would help. I thought I saw something blow out but it did not rectify the problem.
    Now it is to the shop to have the USB port fixed.

    Thanks again.


Share This Page