[International] Not allowed by sim only on MIUI


Last Updated:

  1. AzurA86

    AzurA86 New Member

    im having this problem only on miui
    this is so weird i dont know what to try next
    when on miui V5, i cant make any calls
    i can text
    i can use the 3g internet
    i can receive calls
    but whenever i try to make a call, i get "not allowed by sim" error
    the miui V5 is 4.2.2
    ive tried stock roms - 4.2.2, 4.3, 4.4.2, all of them worked fine
    ive also tried custom roms, Arrow and Omega , they worked fine too
    im only having this problem when on miui
    ive tried flashing just the modem of all of the above roms and got the same result
    what else could be different to cause this problem ?

    Advertisement
  2. Rukbat

    Rukbat Well-Known Member

    A bug in MIUI. Contact the dev.
  3. AzurA86

    AzurA86 New Member

    i tried 3 different versions of MIUI and none of them worked
    they cant all be bugged, can they ?
  4. mikedt

    mikedt 你好 Guide

    It does still sound very much like a bug from what you're describing, especially given that other ROMs are working ok. If it is a bug, only people who can fix that are the MIUI devs. Unless you want to try and debug it yourself.


    Maybe it's your particular carrier's SIM that's doing it, but only with the MIUI ROM. Something that the devs may not be aware of, until it's reported as a bug. Have you got a Xiaomi cellphone or are you using something else?
  5. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    What's your device/network? Maybe other folks are having the same issue?
    mikedt likes this.
  6. AzurA86

    AzurA86 New Member

    im on a standard I9500 not xiaomi phone or something
    im gonna try a different sim card today from another carrier
    the carrier is Pelephone in Israel
  7. mikedt

    mikedt 你好 Guide

    Don't suppose you got a China Mobile SIM you could try? ;)

    Yeh, try another SIM from another carrier. It sounds like a compatibility issue with the SIM or carrier. MIUI was originally developed by Xiaomi for their phones, and have made it available for other phones as well like Samsung. It's developed in China, so most testing was probably done with Chinese SIMs and carriers.

    Others may have come across this before and maybe not reported it as an issue, and just moved onto another ROM. MIUI do have a forum and support site in Beijing, but it's in English...
    MIUI Official English Site - Redefining Android
  8. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Moved to the SGS4 International Root area, the guys here will be better placed to help.
    mikedt likes this.
  9. ironass

    ironass Well-Known Member

    If you have updated to stock Android 4.3 and beyond, then you now have a locked bootloader and Knox security and therefore cannot revert to 4.2.2 . See, Knox Security & locked bootloader on new firmwares.
    El Presidente likes this.
  10. AzurA86

    AzurA86 New Member

    Dont know what you are talking about
    ive updated to 4.3 , then 4.4.2, then i got back to 4.2.2 again
    nothing is locked

    anyways, heres an update, i tried a different carrier today, and boom everything works ok on miui
    so either im switching carrier on sunday or do any of u got any suggestions of anything else i can try ?
    i tried flashing this modem JKUAMD9
    which my girlfriend has on her phone, she is on the same carrier as me but on stock rom
    for some reason that modem kills my imei, changed it to 0049, i flashed back to my previous modem and it got back to normal
    mikedt likes this.
  11. mikedt

    mikedt 你好 Guide

    Might be helpful if you got onto Xiaomi and MIUI, and tell them what you found and what you did. So they can possibly fix it. Devs can't fix bugs they don't know about. :thumbup:
    El Presidente likes this.

Share This Page