1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[International] Not seeing Recovery Menu, help is appreciated!

Last Updated:

  1. Propolandante

    Propolandante New Member

    I have been following the HTC One rooting guide outlined by scotty85:http://androidforums.com/international-one-all-things-root/720478-htc-one-root-thread.html

    Everything has gone swimming so far, and I have completed the last step of Section 2: Flash a Recovery (I went for the permanent recovery route). I got the following (expected) output at the end:

    [HIGH]C:\miniadb_m7>fastboot flash recovery recovery.img
    sending 'recovery' (7916 KB)...
    OKAY [ 1.108s]
    writing 'recovery'...
    OKAY [ 0.667s]
    finished. total time: 1.777s[/HIGH]

    I feel like I am missing something... is booting into recovery supposed to take me to the recovery menu? Am I supposed to navigate to this menu somewhere?

    When I enter the command adb reboot recovery, the following happens:
    1. HTC splash screen appears
    2. Very quickly, a white screen flashes with purple text at the very top "Entering Recovery..."
    3. My phone starts normally (with all the normal splash screens)

    I tried flashing ClockWorkMod recovery instead, but got the same results. I have since re-flashed the openrecovery.

    Any ideas as to what I am doing wrong? Let me know if any more info is needed to properly assess this. Thanks!

  2. scotty85

    scotty85 Guides Guide

    what variant do you have? it sounds like you hve flashed the sprint version on a gsm phone or vice versa. the fist part of what you describe is normal(splash screen,entering recovery...), then you should see the recovery menu. the fact that the phone reboots to the OS instead indicates there is a prollem with whatever is in the recovery partition.
    Propolandante likes this.
  3. Propolandante

    Propolandante New Member

    I have no idea what I did differently, but it worked!

    I have the AT&T variant, and I am confident that I chose the correct recovery.img before (the md5 was 3c568f1b53aaae266b75f6649d0372ab). Regardless, I decided to trash the recovery I was using and re-download it and follow all your steps again, and I am now at the recovery menu.

    I'm thinking maybe I had a typo in the file name before, and didn't notice it because I used TAB to auto-complete it?

    Thanks for your help, I'm on to step three :)
  4. scotty85

    scotty85 Guides Guide

    It sounds like you may be just had a bad or corrupt download. Glad you got it working! :)

Share This Page