1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[International] PhilZ CWM Recovery - Dummies Guide

Last Updated:

  1. dynomot

    dynomot Well-Known Member

    Perfectly willing to try in the interest of research Ironass. If call is quiet this evening ( p*ss off Mrs Smith your bog will wait to be unblocked, you say you have another three use one of them, you silly cow - now if only I could say that to some of them) I'll flash the latest Philz and give it a whirl.

  2. dynomot

    dynomot Well-Known Member

    Right to check for Ironass, here goes.

    Phone GT-I9505

    Firmware :I9505XXUBMH1 (DjeMBeY MH1, "full fat" version deodexed)

    Kernel: Adam 1.6

    Recovery: Philz 5.14.9

    Nandroid done to a blank memory card, md5 check sum on, note the time two hours ahead of when it was actually done.


    Philz 5.17.1 Flashed using Odin 1.85 on Windows Home Premium Vista (spit,spit) PC:


    Nandroid with Philz 5.17.1 to external SD card (Philz now calls it sdcard1). Note time is still two hours ahead




    All hunky dory and restored. Unless your doing something I'm not that previously worked for you that now does not I'm puzzled Ironass.
  3. ironass

    ironass Well-Known Member

    Thanks for all your effort dynomot! :thumbup:

    PhilZ 5.14.9 worked great for me too!

    In fact, all releases up to and including v5.15.8 worked for me.

    As per my posts #95, #97 and #98, it was the PhilZ releases 5.16.2, 5.17.1 and 5.17.6 that caused me problems.

    Phil has now removed 5.16.2, 5.17.5 and 5.17.6 from downloads and has left the one you tried, 5.17.1.

    My storage under Advanced in Recovery is set to, "/data/media/0", and I am using the stock DjeMBeY kernel and not Adam.

    Have re-downloaded 5.17.1 and tried it, yet again, after wiping cache and dalvik and I am getting the message, "Can't mount backup path", when attempting to create a backup with ROM Manager. I tried changing my backup path and still, no go.

    My gut feeling is that Phil uses either the Ausdim or Adam kernel images in the latest releases and they may be causing a problem for me and other stock kernel users on the xda thread, who have also returned to 5.15.8.

    Thanks for all your effort though dyno... do you want Syd's old job of chief kamikaze test pilot? ;)
  4. dynomot

    dynomot Well-Known Member

    No I couldn't take Syd'd crown off of him !

    I enjoyed last night apart from waiting for the massive Nandroid back ups to complete. I was fully intending to go and try your base set up Ironass, but it got a bit late. I tried with Adam 1.6 as I had my suspicions too.

    With my missus being on nights next week, a flashing fest is on the cards. However tonight I have a couple of hours once the kids are in bed to try your set up. I shall start from scratch factory wipe it. Flash your Kernel format memory card, flash Philz 5.14.9 do a Nandroid, flash Philz 5.17.1 do another Nandroid then try and restore the 5.14.9 one. My guess is it'll throw a wobbly, but we'll see.
  5. Sydney99

    Sydney99 Well-Known Member

    What. 5.17.7 up for 24 hours and nobody posted......

    Standard are slipping

    UPDATE: couldnt get zip to flash thru recovery, fine thru Odin and all working just fine and dandy.Hooray, working Philz releases again
  6. ironass

    ironass Well-Known Member

    Too busy testing 5.18.0. ;)
  7. Sydney99

    Sydney99 Well-Known Member

    Well if you will experiment with the beta releases.....
  8. Shotgun84

    Shotgun84 Well-Known Member

  9. ironass

    ironass Well-Known Member

    Shotgun84 likes this.
  10. Sydney99

    Sydney99 Well-Known Member

  11. ironass

    ironass Well-Known Member

  12. ironass

    ironass Well-Known Member

    Strange! :confused:

    There is a difference in the backups, for me, made with PhilZ 5.15.8 and all the later versions as shown in the 2 screenies below.

    The Philz 5.15.8 contains 14 files, including the all important, "nandroid.md5", file. The latest PhilZ recoveries after 5.15.8 only have half as many files, 7, and are missing the, "nandroid.md5", file.

    It seems that even if I re-flash the PhilZ 5.15.8 recovery I still only get 7 files and no, "nandroid.md5", file.

    I had to go back and do a full re-install and re-root from scratch before I could get a 14 file backup again with, "nandroid.md5".

    Try it yourself. Make a nandroid with a PhilZ recovery later than 5.15.8 and check the number of files and then try and restore it. I obviously received an, "md5 mismatch",

    I am on the stock, modified, DjeMBeY MH1 ROM with his kernel.

    PhilZ backup made using 5.18.0


    PhilZ backup made using 5.15.8


    Of course, as always, it could just be me as I had a few sherberts over the weekend but this has happened on every nandroid since 5.15.8 and renders them useless for restoring for me.

    Just a thought... perhaps the latest versions are more suited to TWRP and not CWM. :dontknow:
  13. Sydney99

    Sydney99 Well-Known Member

    You certainly look to have caught the KOD old boy......

    How strange. Is it therefore an sd card issue??
  14. ironass

    ironass Well-Known Member

    No, I don't believe it is. :confused:
  15. Sydney99

    Sydney99 Well-Known Member

    ironass likes this.
  16. Hawker

    Hawker Well-Known Member

    I've not used philz or any other recovery backup for quite some time now.
    I use OBackup.
    With this for me, 3.2Gb takes approx 8 mins onto my external sd card (Samsung 64Gb class 10)
    Sydney99 and ironass like this.
  17. Sydney99

    Sydney99 Well-Known Member

    Nandroid manager is also a fab recovery app that I use, you can restore individual elements from your nandroid without doing a full restore. Very handy!
    Hawker likes this.
  18. ironass

    ironass Well-Known Member

    Was that using ROM Manager to back up?

    I have been using OBackup ever since you put me on to it but in the interests of testing the latest PhilZ releases, I have been doing nandroids through ROM Manager.

    It's probably just me then. I've lost the plot! :stupid:
  19. Hawker

    Hawker Well-Known Member

    Lost the plot?
    Did you ever find it in the first place old fella?
  20. Sydney99

    Sydney99 Well-Known Member

    That was backing up within philz recovery itself.
    ironass likes this.
  21. Hawker

    Hawker Well-Known Member


    - user can enable/disable nandroid backup/restore of selinux context: speed up things for non JB 4.3 users
    - fix bug where restore compressed archive from external storage caused minivold crash because of busy volume
    - S4 mini (i9195/i9190): use exfat/ntfs ko modules with custom kernel from samsung sources (thanks to @wanam)
    - Xperia Z (yuga): use stock Sony + exfat ko module instead of fuse
    - misc bug fixes
    - fix const correctness
    ironass likes this.
  22. ironass

    ironass Well-Known Member

    6/10 for effort old Welsh warlock!

    This is positively, absolutely, the last time I show you...

    PhilZ Recovery 5.18.2 is up! :)

    "- user can enable/disable nandroid backup/restore of selinux context: speed up things for non JB 4.3 users
    - fix bug where restore compressed archive from external storage caused minivold crash because of busy volume
    - S4 mini (i9195/i9190): use exfat/ntfs ko modules with custom kernel from samsung sources (thanks to @wanam)
    - Xperia Z (yuga): use stock Sony + exfat ko module instead of fuse
    - misc bug fixes
    - fix const correctness

    Download for i9505, v5.18.2.

    Download for i9500, v5.15.0

  23. Hawker

    Hawker Well-Known Member

    Update v5.18.5

    - unmount /data on user request for /data/media devices
    - Asus Nexus 7 2013 (flo) support
    - HTC One AT&T support
    - HTC One m7ul, m7spr, m7att, m7tmo: support exfat kernel module instead of fuse
    - Galaxy S3 i9300/i9305: add exfat kernel module support in minivold
    - fix bug when reading partition link target
    - do not ever log to screen mount/unmount events for sdcards (this will preserve ui_print for USB OTG volumes)
    - write recovery version on exiting recovery instead of start: spare an extra partition mount/unmount on start
  24. ironass

    ironass Well-Known Member

    PhilZ Recovery 5.18.7 is up! :)

    "- optimize Install zip menu + order entries
    - merge "minui: Allow devices to blank/unblank using LCD backlight" into cm-10.2
    - merge "recovery: Add a proper CleanSpec.mk * Clean all the stuff that conflicts with AOSP recovery."
    - merge "Add guard makefile for allowing simple recovery build"
    - merge "Quickly install from last install path"
    - merge "Enable optional swipe based touch controls

    Download for i9505, v5.18.7.

    Download for i9500, v5.15.0


    Personally, I'm still on PhilZ 5.15.8.
    Hawker and Sydney99 like this.
  25. Sydney99

    Sydney99 Well-Known Member

    A nice retro recovery you're using there.....

Share This Page