[International] Repenting at leisure...


Last Updated:

  1. Marc1969

    Marc1969 Well-Known Member

    If you've been around here for a while, I'm reasonably sure you can figure out why I've named this topic the way I did...

    Yes, I made a mistake, to put it nicely :mad: I experimented with a couple of roms, ran into things I didn't like within half an hour with each of them, so I returned to DjeMBey's rom. As ironass states in his opening post about this rom, this one comes closest to Sale of all the S4 devs I've come across (don't you all wish Sale got an S4 instead of an S3 :eek:?)

    I put back the MK8 version of the rom, let TB do it's thing and wanted to leave for the gym. Almost in my car, I remembered that I forgot to flash the 3Minit mod. So I hastily (yes, I know, there I went...) went into recovery and with my carkeys in one hand and my phone in the other, I (think I) selected the wrong mod. Some old one I still had on my SD card, probably something like CRT-off or something...

    Long story a bit longer: all I get is Sammie's logo. No recovery, only download mode.
    So I should be able to use Odin to get me back on track. But here is where I get lost :confused: I do not want to get the new bootloader with the KNOX thingy on it (who would?), so DjeMBey's roms mentioned here in #1.1 and #1.2 are out of the question. But which roms CAN I use to flash through Odin and NOT get the new bootloader? All I can find are links to the latest stockroms, but they are 4.3 and are on KNOX

    Am I making things to complicated for myself? Or is the solution not as simple as I would like to think?

    Advertisement
  2. ironass

    ironass Well-Known Member

    There's always one! :trytofly:

    Check your PM's. ;)
    Marc1969 likes this.
  3. Marc1969

    Marc1969 Well-Known Member

    Great!! All I need now is the password for the zip file...
  4. iT0mm0

    iT0mm0 Well-Known Member

    i have a copy of stock MEA if you need it just let me know
    Marc1969 likes this.
  5. ironass

    ironass Well-Known Member

    Some people are just never satisfied! ;)

    Password = handy-faq.de
    Marc1969 likes this.
  6. Marc1969

    Marc1969 Well-Known Member

    When it comes to satisfying me... Ah no, Let's not go there :ahhhhh:

    Anyway, a big thanks to you ironass!!

    Only thing I have to do now is get through a phoneless day :s:
  7. Marc1969

    Marc1969 Well-Known Member

    Still repenting over here...

    Flashed the firmware I got from ironass, everything seems OK, but it will not go past the Samsung logo.

    Not a happy camper :(
  8. iT0mm0

    iT0mm0 Well-Known Member

    give it 10 mins

    if still nothing pull the battery and hard reset (vol, home and power button for 20 secs)

    it worked for me when a custom rom borked my phone
    Marc1969 likes this.
  9. ironass

    ironass Well-Known Member

    Also, try wiping cache and dalvik in Recovery. You may even need to flash the stock ROM twice. ;)
    Marc1969 likes this.
  10. Marc1969

    Marc1969 Well-Known Member

    I gave it two hours...

    Did that every time I tried to flash the stockrom (four, five times) to no avail... At least, I thought I was wiping... But what I forgot was the one thing I know is in there but always skip when I read guides: make sure your phone is fully charged. Turns out everytime I tried to wipe, the phone shut down.

    After charging and trying the whole thing again, I got back my 'Life Companion' ;)

    Now back to rooting and putting back DjeMBey :)

    Thank you both for taking time to help me!
  11. Marc1969

    Marc1969 Well-Known Member

    (nothing to do with flashing new updates, but didn't want to open a new topic)

    I'll be repenting a while longer from today... Both menu and back button stopped working yesterday, so it's got to go to the repairshop :(

    Just a quick question: To be on the safe side, guarantee-wise: Am I right that the only thing to do is reflash the stockrom ironass has sent me? Or is there something else that needs to be reset? I can remember from my S2 that some counter started when I flash a custom rom which sometimes could void my guarantee

    O, and I'll be on Knox when it returns... :mad:
  12. ironass

    ironass Well-Known Member

    See, #2.6. Resetting the hidden flash counter in the Rooting Galaxy S4 - Dummies Guide. You will need to use Triangle Away whilst still rooted and it should work OK on the pre Knox based ROMs but be warned, "use at your own risk". The other alternative used to be the USB jig but I am given to understand that these no longer reset the hidden flash counter.
    Marc1969 likes this.
  13. dynomot

    dynomot Well-Known Member

    Yup, a USB jig is still useful for forcing a recalcitrant boot looped Galaxy (of all types I've used or had) into download mode, but it stopped resetting the flash counter ages ago, due to newer bootloaders.
    ironass likes this.
  14. Marc1969

    Marc1969 Well-Known Member

    Got it back to unrooted stock now, packed to be sent to repair tomorrow. Will be on a Galaxy Y Pro for the next couple of days/weeks. Yes I feel sorry for myself...
  15. Marc1969

    Marc1969 Well-Known Member

    Got my phone back from repair two weeks ago, all Knox'd up...

    My first thoughts were to leave it unrooted and live with it. But after two weeks I'm a little tired of all the bloatware updating every other day and missing out on the options a rooted phone has.
    So I've been reading up on the topics concerning rooting S4's with the new bootloader and Knox. And I'm confused :confused:

    So rooting is no problem. It will trip the Knox flag, but I don't care. Getting a custom recovery is easy. What I'm really confused about is which kernel and rom I can use. Can I use any rom I want, since the Knox flag has already been tripped by then? Or am I restricted to certain kind of rom?

    My thoughts are that I can use any one I want, but I'm not 100% sure. So before I brick my beautiful S4, I thought I'd get some advice from all the wise people here (yes I'm sucking up :p)
  16. ironass

    ironass Well-Known Member

    Congratulations and commiserations, (on Knox).

    Rooting Galaxy S4 - Dummies Guide

    Anyone you want... The world is your lobster!


    (N.B. Any ROM so long as it is Android 4.3 or above)
    Marc1969 likes this.
  17. Marc1969

    Marc1969 Well-Known Member

    OK, thank you. Just as I thought then. Always great to have one's own views confirmed by the higher levels ;)
  18. dynomot

    dynomot Well-Known Member

    Yep 4.3 and above only though. Don't try and flash an earlier 4.2 or whatever you'll end up in a bootloop (Samsung logo glowing only on booting, never getting any further), while relatively straightforward to get out of, an earlier firmware than 4.3 just won't work :(
    Marc1969 likes this.
  19. Marc1969

    Marc1969 Well-Known Member

    Nevermind, I found the problem. Now looking for a fast download 4.4.2 stock, preferably unrooted
  20. Marc1969

    Marc1969 Well-Known Member

    All solved now, but it's very strange that using a different USB port with Odin gets the job done...

Share This Page