[International] [Rooted user w/stock OS] Telus MMS can not recieve

Last Updated:

  1. chicoquente

    chicoquente Member

    I am having issues with my Telus HTC One. I have been using it for a week and am able to send MMS pictures without issue, however I am unable to receive pictures. I am new to Android so maybe I am missing a setting. I am using Chomp SMS and have disabled all notifications and "auto receive" in the stock SMS app and have turned those settings on in ChompSMS.

    However when I am sent a picture it just shows a message "Multimedia Message. Message size: xxxKb" and a button to download. When I click the button a little wheel shows up and spins for a bit but then disappears and never displays the image. I have no idea why. Even if I switch over to the stock app it shows the same thing and responds the same way.

    What can I do to fix this? I am beyond annoyed at this point. If it matters, I bought my HTC One new from Telus, locked to them and purchased an unlock code online. I have also rooted the phone but am running the stock software. I looked in the "Access Point Names" and the settings match when I found on the Telus website.

    Here is an image of what it looks like:

  2. marctronixx

    marctronixx Moderator Moderator

    have you tried using the STOCK SMS app to send and receive MMS messages? this will determine if its an issue with the phone or with that 3rd party app.

    if you tried the stock app and you cant receive mms there, then contact your local cellular provider to make sure your account is setup properly.

    if you can receive mms messages from the stock app, then the issue is with the 3rd party app and a ping to the dev is in order.

    since you are rooted (even though you run stock os, could still be something tangled there), lets move the discussion to the rooted users section.
  3. chicoquente

    chicoquente Member

    Sorry I should have mentioned that yes the results are identical in the stock SMS app. As well this issue existed before I rooted the phone.

    Some other notes that I have since tried: I have turned off wifi and made sure my only connection was mobile data and the results were the same. Outgoing pictures work fine and are received by my friends, the only issue is incoming images.

    Would the SIM unlock I bought be a potential candidate for problems?
  4. chicoquente

    chicoquente Member

    I found the culprit. AdBlock Plus was the issue. I removed it and now things are good. Problem solved.
    scotty85 likes this.
  5. scotty85

    scotty85 Guides Guide

    glad you got it fixed,and thanks very much for sharing the solution :)

Share This Page