[International] Sixaxis controller and S4

Last Updated:

  1. lotus49

    lotus49 Well-Known Member

    I have recently acquired an S4 and I have bought a copy of Modern Combat 4. I want to play this with my PS3 controller just like I did with my S2 and MC3, which worked very well.

    I have made a profile but the only buttons that are recognised are the D-pad (arrow) buttons and the Start button. I had this problem the last time but it was about 18m ago and I cannot remember how I fixed it.

    Has anyone else encountered this problem? If not, has anyone successfully used the Sixaxis controller software with their PS3 controller on any game on the S4 that uses the analogue sticks? Just knowing it's possible would be useful.

  2. DigitlCaffeine

    DigitlCaffeine New Member

    I also recently bought a S4 and also cannot get Sixaxis or any other controller app to work yet. I've been able to get everything fully working except for the right joy stick.

    My S4 is rooted and it seems the only problem I am running into is emulating touch. I've been reading through forum after forum for days now and I haven't found a fix yet. I am starting to get discouraged.

    I have tried Modern Combat 4, Real Racing, and Dungeon Hunter 4 with several different PS3 controllers both wired and through BlueTooth so I know mine isn't broken.

    I'll let you know if I solve it or find a fix somewhere. I feel your frustration.


    Found pre-made profiles here: http://forum.xda-developers.com/showthread.php?t=2035695
    I'm going to try them now.
  3. lotus49

    lotus49 Well-Known Member

    I found those and they didn't work for me.

    I had the same bug on my S2 playing MC3. The developer found and fixed the bug so I have contacted him again. I'll report back if I hear from him.
  4. DigitlCaffeine

    DigitlCaffeine New Member

    Was your S2 rooted? I unrooted my S4 today since this was the only reason I did it in the first place.
  5. lotus49

    lotus49 Well-Known Member

    Yes it was.

    This was the main reason I rooted my S4 so I'm a little disappointed. However, there are other apps that need root such as Titanium Backup Pro so I shan't be unrooting mine.
  6. DigitlCaffeine

    DigitlCaffeine New Member

    I wonder if it might be a problem with the S4 and not the sixaxis app. I tried two other controller applications and had the same problem with each one. I could do everything except use the right analog.

    EDIT: Might also just be my root since I've seen videos of correctly working controller apps on the S4... Can I ask what root you used?
  7. kapteg92

    kapteg92 New Member

    I have also issues with sixaxis and the galaxy s4. My galaxy S4 is rooted and i can connect with sixaxis. The problem is that the touch emulation profile is not working. No buttons or stick respond in the game.
    I tried joystick center 7 and there is the same problem. I am sure it is because the Galaxy S4 has a full HD screen and these applications (sixaxis and joystick center) do not work yet with full hd resolution and the touch emulation is then messed up. We need to wait for an update.

    But i have found the only one touch emulation controller that is working right now with the galaxy s4. It is called Gamekeyboard on the google play. It works very well with the ps3 controller (already tried it successfully with dungeon hunter 4 and modern combat 4). The only drawback is that it is very less userfriendly (for me) than sixaxis.
  8. lotus49

    lotus49 Well-Known Member

    I don't think it is anything to do with which rooting tool you use since root access is root access, regardless of how you get it. However, FYI I used CF-Autoroot.
  9. lotus49

    lotus49 Well-Known Member

    It is good to know that there is at least one option that works even if it is not user friendly.

    I hope the developer gets round to fixing this. He was very helpful and responsive 18m ago when I had this problem before but he hasn't responded to my email of a few days ago yet so we shall have to wait and see.
  10. lotus49

    lotus49 Well-Known Member

    If I connect my PS3 controller to my S4 using a USB OTG cable many of the buttons are recognised and work automatically in Modern Combat 4 so I can move around and fire but the right analogue stick doesn't work so I cannot look around. This obviously rather hampers my ability to play.

    Has anyone successfully played MC4 using a PS3 controller?

    I'd rather do this wirelessly but using Sixaxis doesn't work at the moment on the S4 (I posted separately about this but if you know how to do that, please tell).
  11. sntaylor

    sntaylor Well-Known Member Contributor

    Are you rooted?
  12. lotus49

    lotus49 Well-Known Member

  13. sntaylor

    sntaylor Well-Known Member Contributor

    Then sadly I can't help.Lol

    Was hoping you'd say no, so I could say sixaxis requires root :p I've not tried it yet in the s4 as I tend to use the nexus to play games requiring a controller. Sorry!
  14. lotus49

    lotus49 Well-Known Member

    Having dug around the net it appears that Samsung uses a non-standard bluetooth stack, which is why Sixaxis doesn't work. The developer is aware of this but hasn't yet fixed the problem (but I believe he is trying to).

    This question was really about using a wired connection. This works but not enough to allow me to play properly.
  15. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    I merged both your threads together since they are related and also moved it to the ATR section. Cheers ;)
    sntaylor likes this.
  16. kapteg92

    kapteg92 New Member

    I am almost certain it is not a problem of bluetooth stack because connecting a ps3 controller with sixaxis and the galaxy s4 work. I can connect it with my galaxy s4 and sixaxis and i can perfectly play wireless Virtua tennis or dead trigger for example. All native gamepad compatible games work with sixaxis and galaxy s4. The problem is only now the touch emulation profile, which is for all the games not natively compatible with a gamepad and that you have to map the touch control.
    If it was a bluetooth stack problem i think you will not even be able to connect the ps3 controller via sixaxis and the galaxy s4.

    For modern combat 4 i play it perfectly with the application i told you before and both analog stick (moving + looking around) work very well by mapping. But as you said it is not wireless but with OTG cable.

    hope it can helps
  17. Rastan350

    Rastan350 New Member

    Mind if I ask you how you got the 2nd analog stick to function correctly on MC4 for the look? I have it working somewhat by using the pan option but its very jerky and not enjoyable. Were you able to get it perfect? Thanks
  18. seb269

    seb269 New Member

    Hello. i'm new in here. But want to solve the emulation problem too on my s4.!!
    Tried it since yesterday to get it running with gamekeyboard. But didn't get any succes.:(
    Kapteg. can you please explain how you did it with this app??:confused:
    Sixaxis is real more friendly to use!!
  19. lotus49

    lotus49 Well-Known Member

    Sixaxis has been updated and now it seems to working perfectly with MC4. It appears that I was doing everything correctly because I haven't changed anything apart from updating Sixaxis and now both sticks work and everything is as it should be. I'm very pleased.

    Well done to Dancing Pixel Studios for sorting this out. Playing MC4 with a PS3 controller is a million times better than the on screen controls.

Share This Page