[International] Stuck in Clockworkmod Recovery


Last Updated:

  1. Headzyy

    Headzyy Member

    Like the title says my phone is stuck in recovery if i try to boot it just reboots to the recovery menu

    Advertisement
  2. DragonSlayer95

    DragonSlayer95 Resident Air Bender Moderator

    What carrier so I can get this moved over to the appropriate root forum.

    Do you have a good working backup to fall back on?

    If not, have you tried wiping your cache/dalvik/data then rebooting?

    Or even flashing another rom?
    scary alien likes this.
  3. Headzyy

    Headzyy Member

    No i dont have a backup, im with optus, and yes i have tried clearing cache and rebooting
  4. DragonSlayer95

    DragonSlayer95 Resident Air Bender Moderator

    Optus? I'm not familiar with that carrier. Is that international?

    Google tells me that's an Australian carrier. Moving over to the international forum.

    Have you tried flashing another rom yet?
  5. Headzyy

    Headzyy Member

    Yeah optus is an australian carrier and im very new to this i have no idea what flashing a rom means
  6. DragonSlayer95

    DragonSlayer95 Resident Air Bender Moderator

    Alright moved to the international root forum.

    Did you do anything in particular before it started booting only into cwm?
  7. Headzyy

    Headzyy Member

    I tried to install android kit kat but it gave me this error

    When i try to install First-m7ul.zip i get a error that says No File-contextset_metadata_recursive: some changes failed
    Error in First-m7ul.zip (Status 7)
    Installation aborted
  8. Headzyy

    Headzyy Member

    Is there a way i can just reset it to default
  9. DragonSlayer95

    DragonSlayer95 Resident Air Bender Moderator

    Hmm okay from what I've found it has something to do with the updater script.

    http://forum.xda-developers.com/showthread.php?t=2302599

    hey!*
    while flashing roms, many times we get a "status 7 error". while searching in many threads, we do not get how to resolve it. i will tell you each and every thing step by step
    so i made a*NOOB FRIENDLY WAY TO RESOLVE STATUS 7 ERROR

    make sure that the rom you have downloaded matches your phone model, if you flashed some other rom, you may hard brick your device.

    1. First extract your rom (for example using 7-zip)
    2. Go to the folder META_INF > COM > GOOGLE > ANDROID
    3. Here you will find a file "updater-script"
    4. Rename this file as updater-script.doc (microsoft word format)
    (in some pc, extensions are nor visible. to make them visible, follow these steps)
    Open Folder Options by clicking the Start button , clicking Control Panel, clicking Appearance and Personalization, and then clicking*
    Folder Options.
    Click the View tab, and then, under Advanced settings, do one of the following:
    To display file extensions, clear the Hide extensions for known file types check box, and then click OK.

    5. Double click to open it( microsoft word preferred)
    6. delete text, starting from "assert ....... till the semicolon(of the last getprop command. (see image in attached file-lines to delete)
    7. Now save the file
    8. Again rename the file, and delete the .doc extention
    9. now go back to the main rom folder where you extracted the 3 files. zip these files again. and you will get a zipped rom.

    and the status 7 error has now been removed!
    happy flashing*



    while moving to any kitkat rom from previous android versions (..,..., 4.0,....,4.3)

    Kitkat roms have some special permissions statements in the updater script (set_metadata). Older recoveries do not have the ability to handle these statements. Update to the newest recovery available for your phone. Otherwise status 7 error cannot be resolved
  10. DragonSlayer95

    DragonSlayer95 Resident Air Bender Moderator

    Sure we can find an ruu for your device to reset it back to bone stock.

    What's your baseband/bootloader?

    I'm heading off for some sleep, but I've requested some help for you.
    scary alien likes this.
  11. Headzyy

    Headzyy Member

    Im sorry im not much help.
    I have no idea i just held the volume down button and the power button to get to the white screen bootloader thing
  12. Headzyy

    Headzyy Member

    Someone please help i want to restore to stock rom PLESAE HELP
  13. scotty85

    scotty85 Guides Guide

    there are not many ruus available for the international carrier specific phones. you can give us some basic info by doing this,and reporting the results( xxx out your esn,meid,and imie):

    first download and install these drivers: revolutionary drivers (mirror)

    then,download this small file:
    mini-adb.zip

    -unzip it,and place the unzipped folder onto the root of your C drive(not inside a folder)

    -open a cmd window(with win 7,click start bubble,type "command" or "cmd" in hte search box)

    -now change to your mini-adb directory(assuming you didnt chagne the name). type in the black cmd window that opened on your PC:
    cd c:\mini-adb

    -pull the battery in your phone for a few seconds. hold volume down,then power. hold them both until you see the white/colored writing hboot screen

    -select "fastboot" from the hboot menu with the vol rocker/power button

    -in your cmd window type:
    fastboot devices

    it should output your phones serial number. if so youre good to go. if not,youre apparently having a driver issue. i usually recomend these drivers from Revolutionary: modified htc drivers download and install the drivers(you should just have to run that file). afterwards,unplug your phone,plug it back in. make sure its in fastboot. as soon as you get a result from "fastboot devices" your ready to procede to the next step.

    -in your cmd window,type(or copy/paste,is much easier):
    fastboot getvar all

    -copy the info that outputs here. right click in your cmd window,click mark,highlight it all in white. hit enter. paste the info here. it will help us know which ruu for you to run. :)

    edit:
    -i dont see where youve ever answered how your phone came to be in this situation. that will help us also.
    -i dont see an answer for wether or not you have a backup you could restore

    if you could elaborate on those 2 things,as well,that will help us help you
  14. Headzyy

    Headzyy Member

    No i dont have a backup and heres the info
    c:\mini-adb>fastboot getvar all
    INFOversion: 0.5
    INFOversion-bootloader: 1.55.0000
    INFOversion-baseband: 4A.21.3263.04
    INFOversion-cpld: None
    INFOversion-microp: None
    INFOversion-main: 3.63.980.2
    INFOversion-misc: PVT SHIP S-ON
    INFOserialno: FA37ZW901961
    INFOimei: 355859054259767
    INFOmeid: 00000000000000
    INFOproduct: m7_ul
    INFOplatform: HBOOT-8064
    INFOmodelid: PN0714000
    INFOcidnum: OPTUS001
    INFObattery-status: good
    INFObattery-voltage: 3940mV
    INFOpartition-layout: Generic
    INFOsecurity: on
    INFObuild-mode: SHIP
    INFOboot-mode: FASTBOOT
    INFOcommitno-bootloader: dirty-fd1bd949
    INFOhbootpreupdate: 11
    INFOgencheckpt: 0
    all: Done!
    finished. total time: 0.046s
    scotty85 likes this.
  15. scotty85

    scotty85 Guides Guide

    thanks for the info. the bad news is that there does not appear to be an ruu available for your particular build. we are going to have to flash a rom to get you up and running.

    open a cmd window and change to the miniadb directory as described above. place your phone in recovery,and plug it in. now enter:

    adb devices

    this should spit back: "serialnumber recovery" in your cmd window

    if thats the case you can download a stockish rom,and place it into the miniadb folder(maybe this rom: [SYSTEM DUMP][29.01.2014] HTC One *STOCK* ROM | 4.19.401.8 | KitKat 4.4.2 | HTC Sense 5.5 - xda-developers )

    you now have a couple options:

    1)push with adb

    2)install via adb sideload


    1)push to sd card via adb
    1)place rom into adb/fastboot folder
    2)boot to recovery
    3)open cmd,check connectivity:
    adb devices
    (should return serial number)
    4)push rom to sd card:
    adb push romname.zip /data/media/0/ (where romname is your actual zip file name)
    5)you should then be able to simply wipe and flash the rom as you normally would:
    -factory reset
    -flash zip(chose /0 then chose the rom that you pushed)



    2)install from adb sideload
    1)place rom into adb/fastboot folder
    2)boot to recovery
    3)open cmd,check for connectivity
    adb devices
    (should return serial number)
    4)select "install from sideload" from the recovery menu
    5)in cmd,enter:
    adb sideload romname.zip (where romname is your actual rom's name)
    you should see it installing on the phones screen

    im off to work now,but ill try and watch if you have questions. im sure some others will be along as well,so fear not,we should be able to get it up and running :)
    DragonSlayer95 and scary alien like this.
  16. Headzyy

    Headzyy Member

  17. scotty85

    scotty85 Guides Guide

    you are welcome for the help,its why we are here. :) you do have the phone plugged in,and in CW recovery,correct? what version of CW are you using?

    also,if you dont mind just copy/paste your cmd window and paste the code here. it will be difficult to see pics on my phone at work. the pasted code will be just as good :)
    DragonSlayer95 and scary alien like this.
  18. Headzyy

    Headzyy Member

    Where you said 1)place rom into adb/fastboot folder
    Where do you mean cause theres no folder callede that
  19. scotty85

    scotty85 Guides Guide

    The miniadb folder(it contains adb and fastboot utilities)
    DragonSlayer95 and scary alien like this.
  20. Headzyy

    Headzyy Member

    I tried to install the rom but it said
    Can't open "romname" (bad)
    Installation Aborted
    scotty85 likes this.
  21. clsA

    clsA Well-Known Member

    turn off any download managers when downloading things for your phone. Check the MD5 for the file you download before pushing or copying it to your phone. every file comes with an MD5 use it. md5 tool - Google Search

    and I hope your actually using the rom name ...not romname
    scotty85 likes this.
  22. Headzyy

    Headzyy Member

    Thats the MD5 1F9253A64D5B0A0566C8B40EC809D05F
    But i have no idea what it means
    scotty85 likes this.
  23. clsA

    clsA Well-Known Member

    did you even check the link I posted ?
  24. scotty85

    scotty85 Guides Guide

    an md5 sum is a unique string of characters generated for any particular file,and is a means of checking that files integrity,as if one byte is changed or missing,the whole md5 sum will be different.

    as computer viruses(and therefore firewalls and antivirus protections) have become more complex, there is a good change that the PC has screwed up your rom during download so now it will not flash.

    what clsa is suggesting is that you download one of the tools from the google search he provided,and use it to check the file that you have tried to sideload. compare that string of numbers to the one that is provided for your rom download. this will tell us that the install is failing for some other reason,if we find your rom download to be intact.

    hope that makes sense :)

    i assume youve gotten past the adb devices prollem? if you havent,we need to work on that first. its important for the sideload to work.
    DragonSlayer95 likes this.
  25. Headzyy

    Headzyy Member

    The Md5 is fine but and yes i have gotten past the adb devies problem
    So i dont know whats going wrong
    scotty85 likes this.

Share This Page