[International] stuck on fastboot

Last Updated:

  1. zionz

    zionz Member

    I tried flashing CWM Recovery on my new G2
    but after flashing my phone boots and I see on the screen:
    fastboot mode started

    And it's stuck like that.
    I tried downloading SDK and replacing recovery by fastboot commands, but my pc doesn't seem to recognize the phone.
    After installing a usb driver I see in device manager that the driver is still not installed correctly.
    I guess it's because my phone isn't loading, right? maybe it needs to be installed when Android is running?

    I even tried factory reset (boot in recovery - power + vol up) but still no change

    Please help me if you have an idea how, I only bought it last week and now it's bricked!


  2. strodda

    strodda Well-Known Member

  3. zionz

    zionz Member

    thank you, but my phone is varrient-free, and I don't think any rom will work.don't see anything on the list that seems fit.
    also, isn't there a way to only recover boot, and not wipe the rom entirely?
  4. strodda

    strodda Well-Known Member

  5. zionz

    zionz Member

    Yes, I looked but I'm from Israel and I bought the phone through an independent importer and not a cellular network.

    about the thread you suggested, I tried it but fastboot can't recognize my phone.
    it's stuck on 'waiting for device'

    thank you for trying to help
  6. iowabowtech

    iowabowtech root@android:/ #

    Have you been in that mode since it happened? Ever try long pressing the power button to force a reboot? (can take up to 10 seconds or more)

    If that works, does it bring you back to fastboot mode or something else?

    Were you able to issue fastboot commands previously and have the device recognized? I'm just not sure what driver would be necessary for this situation but I'm wondering if my vzw united drivers would work in this instance. ADB interface and fastboot might take a universal driver for all the G2's, not sure but it could be worth a shot if it comes to that. Because the LG United drivers I've seen come from a .exe which won't execute in your situation. I'd think you're in a position where a manual driver update is a likely a must and my drivers are in a zip so we can point device manager to them.
  7. zionz

    zionz Member

    Thanks for the reply

    I rebooted many times, also into recovery mode (and tried factory reset) and download mode.
    after it always returns to fastboot

    However, now I can issue fastboot commands. not sure what exactly changed.. maybe changing a usb port.
    I tried flashing a new recovery like explained in the link strodda suggested, but it doesn't help.

    is there a way to completely remove fastboot? sorry if it's a dumb question, I no nothing about these things

    thank you
  8. iowabowtech

    iowabowtech root@android:/ #

    I think we'll still want to know what model you have. I'm assuming it'd be a D802 which is what we're calling the "international" version. It's carrier free.
  9. zionz

    zionz Member

    Yes, it's D802
  10. iowabowtech

    iowabowtech root@android:/ #

    So I agree, I think you've borked your stock recovery. I'm thinking the best way to get out of that would be to use fastboot to flash the stock recovery img. I just can't seem to find one. :(

    I've been trying to extract the necessary files from the stock D802 kdz file to eventually obtain the recovery.img but I can't seem to get it to work.

    Idk, if you can use that return to stock thread mentioned a few posts above, it may be worth trying that. I don't know if it'll work while in fastboot mode but if so, that could be your answer. Just choose the kdz that is for D802 (sometimes listed as Europe/open)
  11. zionz

    zionz Member

    Thanks, I'm trying to do that, but now there's a new problem..
    When I try getting into download mode (phone off, vol-up + plug in usb), I see the indication for download mode for a second, but then it returns to fasboot mode.
    It worked yesterday. does anybody know this behavior?
    So frustrating :(
  12. iowabowtech

    iowabowtech root@android:/ #

    I think I've finally found a stock recovery IMG for the 802:

    xda-developers - View Single Post - [RECOVERY] TWRP touch recovery [2013-09-22

    Proceed at your own risk!!

    But theoretically, you should be able to flash the IMG in fastboot thereby (I hope) getting you out of this fastboot only situation. If that does not work, or if you think your recovery might still be in tact, there is also a boot.img for the 802 posted later in that same thread.

    Might be easiest to rename that recovery file to recovery.img first (so the filename matches the command I typed below). So via fastboot then, place the recovery.img into the same directory you're running fastboot from and then run the command:

    fastboot flash recovery recovery.img
  13. zionz

    zionz Member

    Wow, Thank you very much!
    I'll give it a try and write back
  14. cbigmtich

    cbigmtich Well-Known Member

    I tried putting the paranoidandroid rom on my att lgg2 and its stuck on the paranoidandroid3+ splash screen. it looks like a little shark type android, it just changes colors. never finishes booting. not a bootloop, but a splash screen lock. anyone have any suggestions?
  15. cbigmtich

    cbigmtich Well-Known Member

    no worries, I rebooted into recovery and loaded a backup. I kept reading that going into recovery with hardware buttons would result in a boot loop, so I was reluctant, but I was already in a loop so I had nothing to loose. I did it, it worked fine, I'm all good!
  16. zionz

    zionz Member

    ok, there's a change now, I'm just not sure if for the better..
    I tries flashing the stock recovery and boot in the link iowabowtech suggested. now on turning on the phone I see:
    ERROR: boot certification verify
    Secure booting error
    cause: boot certification verify
    and after a second or two the screen blacks out. the phone is still turned on but nothing happens anymore.
    I can still get to fastboot mode by pressing vol-up and plugging the cable, but have no idea what to do next.
    Thanks all
  17. zionz

    zionz Member

  18. iowabowtech

    iowabowtech root@android:/ #

    Good deal. Yeah I was really hoping you didn't flash the kernel that was posted in that link. The boot.img is in that same thread but you'd have had to read through the whole thing to find it. But either way you got it so all is well that ends well.
  19. zionz

    zionz Member

    thanks, appreciate your help
  20. vinfred

    vinfred New Member

    hi there, I got the same problem but the different is that i can't go into fast boot. It always on and on at the boot certification verify msg.
    If i plug usb into the computer, it opens up many drive and ask me to format it if i want to use it. Only one drive contain many files and i have no idea what that is.
    Any help? Greatly appreciated.
    My variants is F320s
  21. iowabowtech

    iowabowtech root@android:/ #

    Is that the Optimus S G2?
  22. udaasali53

    udaasali53 Member

    Also known as LG Optimus G E973, LG Optimus G E971, LG Optimus G E975
    how to fix any solution
    fastboot mode started
    -- reset --
    --portchange --
  23. hbhbhb

    hbhbhb New Member

    hi I got the same problem my device stock on fastboot and doesn't do any think and my pc does not recognized my mobile I download and install LG mobile driver I have the d802 version my pc recognized my phone as abase system device and on cmd it stock at waiting for device plz any help

Share This Page