1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[International Tegra 3] HELP! problems unlocking bootloader in linux!

Last Updated:

  1. TobyJamesJoy

    TobyJamesJoy New Member

    hi, i've been trying today to root my new htc one x but i can't seem to get the bootloader to unlock using the htcdev instructions.

    i have usb debugging on, the phone is on charge only mode, i boot into fastboot mode, my pc (running ubuntu 12.04) recognises the phone when i run "lsusb" into the terminal but i have no more success than this.

    running "adb devices" or "fastboot devices" shows no results and "fastboot oem get_identifier_token" just hangs indefinitely with a "waiting for device" message. i have the latest ia32-libs package installed

    in addition, when i boot into the phone the normal way i have a list of running processes streaming in the top-right corner of the one x display, extremely annoying.

    can anybody help? anything would be much appreciated, this phone is less than a week old and i really want to get it back into a usable state.


  2. TobyJamesJoy

    TobyJamesJoy New Member

    is it safe to use the factory reset option in the bootloader menu? i don't mind if i lose my apps, i just want to get rid of this annoying text...
  3. TobyJamesJoy

    TobyJamesJoy New Member

    tried things out on my arch linux system, downloaded fastboot from the AUR, made a udev rule and BANG! everything works! arch just rocks so much, i'm new to it but i'm loving the simplicity.

    i applied the same udev rules to my ubuntu setup but no difference... silly.

    so i don't know what i was doing wrong but i am rooted now, sick times.
  4. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Aren't there instructions on the htcdev site for Linux? I thought there were?
  5. TobyJamesJoy

    TobyJamesJoy New Member

    there are, but for some unknown reason they wouldn't work on my ubuntu system, even with the 32-bit compatibility packages installed and modified udev rules (which htc-dev doesn't even mention). after attempting a different method on a different, arch linux, system there were no problems, perhaps due to arch linux's awesome package management system.

    before trying out a completely different system i thought i might post here, to see if the community had any knowledge to share and so that people with the same problem as me might get an answer to their problems too, but i guess that people around here don't like that kind of stuff. sorry mr moderator, i'll have to take my questions somewhere else next time...
  6. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Sorry if you took the above the wrong way, I was just curious tis all. :)

    I was actually going to ask you if you minded detailing the process as I'm sure there are other people who would benefit from it. From memory, the instructions don't really go in to any great detail about what to do if you encounter any errors etc (certainly for Windows systems anyway).

Share This Page