1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[International Tegra 3] HTC ONE X Problem Restore Backup After Flashing JellyBean Custom ROM

Last Updated:

  1. iamdavidchang

    iamdavidchang New Member

    I have serious problem on my phone and need help from you guys out there. I recently flashed JB Custom ROM to my new One X and turns out I don't like it. I decided to change it back to the Ice Cream Sandwich. When I tried to restore my backup using Clockworkmod, the phone just stuck at the HTC ONE logon screen. Been trying to restart and do a few method of resetting but it still the same. What's worse after I went to fastboot and do the 'recovery.img' fastboot, I can't even go into the recovery section anymore. How can I fix this problem so that my phone can start functioning again?

    So much thanks you have any solution. Been looking for answer but still can't fix my phone. Sorry if I have missed any similar thread before.


  2. olbriar

    olbriar Moderator Moderator

    Hello imadavidchang. Welcome to Android Forums. I'm sorry you are having root problems. I wish I had some information to pass along but I'm not a root guy. We do have root areas for your phone and you will find far better support by posting your problem there. I would move your thread into that help area but they are carrier specific. Please follow the link below that reflects your phone/carrier for the best support we can offer. Best of luck to you and thanks for joining and using these forums.
    (Rogers & S4) One XL - All Things Root - Android Forums
    (International Tegra 3) One X - All Things Root - Android Forums
    (AT&T) One XL - All Things Root - Android Forums
  3. iamdavidchang

    iamdavidchang New Member

    Hi olbriar,

    Thanks for the reply. I bought my phone in Malaysia so I believe mine is the international carrier. Anyway, will post my problem to the proper forum.

    Thanks again!
  4. iamdavidchang

    iamdavidchang New Member

    Hi guys,

    I'm pretty new here and sorry if I have missed a similar thread before. I have problem with my new HOX. I flashed JellyBean into my phone (get the tips from here). It works and after few days, I started to dislike it. Then I decided to go back using Ice Cream Sandwich. When I tried to restore back from my backup using CWM, the phone just stuck at the HTC logo screen when I reboot. Then I tried to do restore factory settings. Same thing happen again. After a while, I tried to do the "recovery.img" using my fastboot then erase cache. I thought it would help but turns out it making things worse. Now my phone can't even get to the recovery mode in CWM. Please help me if you have any suggestion on how to make my phone working again.

    Thank you so much!
  5. TarekElsakka

    TarekElsakka Well-Known Member

    Oh man, that's a tough situation. If I were you, I'd just flash Clockwork Recovery again and see if you can try wiping the device and re-installing the Nandroid backup of your ICS.

    GSM: http://download2.clockworkmod.com/recoveries/recovery-clockwork-touch-

    CDMA: http://download2.clockworkmod.com/recoveries/recovery-clockwork-touch-

    Download which ever one fits your device, but if it is international, then I'd say it's the GSM one.

    Another option would be to mount the device as USB mass storage AFTER installing Clockwork Mod, backing up all the data you need, and then installing an RUU which will wipe everything on the device but will install the latest ROM for you with no problems.

    You can get the correct RUU from here:

    Directory listing of http://www.htcruu.com/Endeavor


    FileFactory Folder View - Endeavor

    And this is how you find out which one you need:


    And by the way, have you by any chance updated your HBOOT or is it the same version?
  6. iamdavidchang

    iamdavidchang New Member

    Erm I did update my recovery. I accidentally delete my recovery img files. Then I download a new 1 only to realize it's the wrong version. So I track back my history and manage to find the correct recovery that I installed earlier.
  7. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Did you reflash the ICS boot.img after you restored your backup?
  8. TarekElsakka

    TarekElsakka Well-Known Member

    Hello there!

    You already created a thread about this before and received replies and questions, so it'd be better if you continue here since it's about the same subject.

    Best of luck, David. :)

Share This Page