[International] [TOOL] Lock/Unlock Bootloader + Remove Tampered | Aroma GUI

Last Updated:

  1. crushalot

    crushalot Member

    This tool will allow you remove the Tampered flag from your bootloader. It will also allow you to easily Lock and Unlock your Bootloader directly from recovery.
    No root required since it is run in recovery, however you still must be S-OFF.

    Before using this tool you need to be sure you are using the latest version of recovery as the M7 U/UL TWRP requires at least version for this package to work. The current downloads for both CWM and TWRP can found below:

    The latest M7 U/UL TWRP can be downloaded HERE.
    The latest M7 U/UL CWM can be downloaded HERE.

    This should work for Verizon and Sprint as well, however they have different versions of these recoveries, so I am unable to verify.

    Saying this again in case you missed it: YOU MUST BE S-OFF!

    To use the tool simply copy the zip file to your phone and then boot to your custom recovery and choose install. Then browse to where you copied the file and select it. The aroma installer will begin. Follow the steps outlined in the pictures below and choose the options you want to run.


    Now you can just keep this file on your phone and Lock and Unlock at anytime without a PC and without losing data.

    S-trace for originally discovering the location of the lock status flag. See this thread.

    scotty1223 for his ADB shell commands. Threads HERE and HERE. Scotty was also very helpful to me in understanding some of the default values.

    Just to be clear I did not just copy and paste scotty1223's commands into a aroma installer. The echo command can be problematic in aroma, so I developed original code for all four commands. The end result is the same in that the data in the partitions is changed as needed.


    Guru Bootloader Reset Tool

    md5: fdb8264a8f4741bae22939cd7734f7c2


    If this helped you out please consider a small donation or just a thanks would be great.

    rootlinux, kdj67f and scotty85 like this.
  2. crushalot

    crushalot Member

    Demo Video:


    If the installer stays on this screen fore more than a few seconds, then it means you need to delete/format cache. This can be done within both recoveries. You may need to reboot recovery after clearing cache and begin the installer again. This seems to happen more on CWM than TWRP.

    If the installer runs but your bootloader doesn't change, it is proably one of these things:
    • You are not S-Off
    • You do not have the latest version of recovery (I recommend TWRP)
    kdj67f and scotty85 like this.
  3. scotty85

    scotty85 Guides Guide

    awsome! especially thnaks for giving proper credit to s trace. i picked up his ball and ran with it to get the word out to other devices,but there would be none of this without him,and his original work seems to go somewhat un-noticed.

    sprint and vzw are using their own recoveries,so your nandroid tool would need those specific versions,but the flag locations are across the board,so this should work fine on sprint and vzw variants,as well as m7_u.

    i prolly can round up a couple vzw testers if you want :)
    kdj67f likes this.
  4. clsA

    clsA Well-Known Member

    scotty85 likes this.
  5. kdj67f

    kdj67f New Member

    Verizon HTC One user here. Scotty1223 from XDA directed me to this thread, and I can confirm this works great. Stock firmware, rooted, rumrunner s-off and using the latest TWRP recovery.

    Relocked, locked and unlocked again as advertised. Great work on this!
    scotty85 likes this.
  6. scotty85

    scotty85 Guides Guide

    just a thot,maybe you could add the MID change to your tool as well... that would make it really "one stop" shop :)
  7. AndroidSerpent

    AndroidSerpent Well-Known Member

    Ok, so I used the guru tool and now my recovery is not loading. When I go into recovery it sends me back to fastboot. Should I try to install twrp again?
  8. scotty85

    scotty85 Guides Guide

    moved here,so crushalot has tht oportunity to help troubleshoot :)

    were you able to reinstall your recovery?
  9. AndroidSerpent

    AndroidSerpent Well-Known Member

    Thanks Scotty. I tried to install twrp 2.6.3 and had no success.
  10. scotty85

    scotty85 Guides Guide

    Did you have errors when you installed it? The more info you can provide,the better :)
  11. AndroidSerpent

    AndroidSerpent Well-Known Member

    I've tried installing it with flashify and it says that installation was successful. When I go to the boot loader-> recovery it tries but just restarts into the Rom. This happened after I used guru and it didn't remove the locked and tampered flags either. I .did use moonshine tow root and I did some stuff that I don't remember in updating the hboot.
  12. scotty85

    scotty85 Guides Guide

    maybe try flashing it the old fashioned way. put your image into your adb/fastboot folder,place phone in fastboot and flsh the image with:

    fastboot devices

    fastboot erase cache

    fastboot flash recovery imagename.img

    fastboot reboot

    after the phone boots,try and enter recovery

    im a little disapointed we havent heard from crushalot,ill try and get hold of him on xda and see if he can pop in here :)
  13. crushalot

    crushalot Member

    Sorry guys. I had a family issue come up that has kept me away for the past few months.

    After having a look, I know why this is happening.
    Since the tool needed the cache wiped most of time for it to work, I built the script to wipe the cache first.

    The problem is that I have it set to clear/wipe the cache partition on M7 U/UL device types which is mmcblk0p36. Unfortunately that is the Sprint partition where recovery lives, so running the tool would wipe recovery for Sprint devices.

    I will remove the line in the script so it doesn't wipe cache and post it back as version 1.1 so that it will be more universal since the partitions for Locking/Unlocking/Tampered should be the same.

    I will make a new post when the new version is up.

    Sorry for the trouble.
    scotty85 likes this.
  14. crushalot

    crushalot Member

    New version that won't wipe cache/delete Sprint recovery is here:

    Guru Bootloader Reset 1.1 - HTC1Guru

    I know the link looks like 1.0, but the file page and download has been updated to version 1.1. Doing this because I don't have time to update all the inbound links right now.

    Hope this helps.
    Hadron, AndroidSerpent and scotty85 like this.
  15. scotty85

    scotty85 Guides Guide

    Thanks crushalot for figuring out the issue,im sure it will help alot. :cool:

    Androidserpant, Have you been able to reinstall your recovery using fastboot flash ?
  16. AndroidSerpent

    AndroidSerpent Well-Known Member

    No, my adb is not loading correctly. I'm trying to find adb for windows 8. I'm trying to download adb again.
  17. scotty85

    scotty85 Guides Guide

    Do you have an older laptop or desktop you could use? Fastboot flashing should let you reinstall your recovery.
  18. clsA

    clsA Well-Known Member

    ADB works fine in windows 8 / 8.1
    it's only fastboot that is broken on windows 8.1 and only on hboot below 1.55 is it a problem.

    try these drivers
    MD5: e2a21d71954d4164c1a116abb926a363

    and here's the versions of adb and fastboot I use in windows 8.1

    their dated 7/25/2013
    scotty85 likes this.
  19. AndroidSerpent

    AndroidSerpent Well-Known Member

    Thanks for the link. I'll try it.
    scotty85 likes this.
  20. AndroidSerpent

    AndroidSerpent Well-Known Member

    The twrp image that I downloaded said that it is corrupt when I double click it. I did it once by accident then I tried to install it using cmd.exe When it goes to installing the image it says

    FAILED <remote: not allowed>
  21. scotty85

    scotty85 Guides Guide

    Sounds like you are not unlocked. In this case you'll need to install recovery as a zip file using ruu mode
  22. AndroidSerpent

    AndroidSerpent Well-Known Member

    I downloaded goomanager and successfully installed twrp 2.6.3. I have a recovery now. Problem is I need the latest version right? If I run the guru tool to unlock with 2.6.3 recovery would that work?
    scotty85 likes this.
  23. scotty85

    scotty85 Guides Guide

    Awsome. Glad you are finally sorted :)
  24. AndroidSerpent

    AndroidSerpent Well-Known Member

    What's not unlocked? The bootloader?
  25. crushalot

    crushalot Member

    Should work with that version, but I don't have the Sprint variant and sometimes there are tiny differences in the TWRP versions across the different device types.

    And yes Scotty was saying that if you get that error when trying to flash a recovery via fastboot, more than likely your bootloader is not unlocked which is needed to write a new recovery via fastboot.

    Hope you are all set now.
    AndroidSerpent and scotty85 like this.

Share This Page