1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[International] URGENT - Almost bricked HTC One

Last Updated:

  1. CaseyDGeek

    CaseyDGeek Active Member


    So due to some issues, my HTC One is now without an OS. It's stuck in Recovery, TWRP. And for some reason the laptop isn't reading it - which isn't abnormal, the USB drivers were being buggy already. But that essentially means I can't get a ROM onto the storage. So I can't install an OS either.

    Please help. This mobile has been a lot of trouble, but I really do like using it, so I'd really like it fixed. And I don't think Customer Care would be able to handle this issue.

  2. DirtyDee

    DirtyDee Well-Known Member Contributor

    So you can't load from adb sideload. Have you tried flashing a firmware? I am not to familiar with HTC unbricking
  3. CaseyDGeek

    CaseyDGeek Active Member

    I tried starting up ADB Sideload, but it just keeps on 'starting', and doesn't start. I tried for about five minutes.

    And I can't flash a firmware because I am unable to put anything onto the storage, and the USB driver refuses to read the HTC. It only shows a Mass Storage Device or CD Drive folder, opening either of which leads to the notification 'Please insert a (Mass Storage Device/CD) in Drive X:.
  4. Hadron

    Hadron Well-Known Member Contributor

    Does it respond to adb at all? Have you tried different ports/cables?

    If you have a USB OTG cable you can stick a ROM on a USB flash drive and install from there (just select USB storage as the source in the TWRP install dialogue, locate the zip & install as normal).

    I'm assuming you don't have a nandroid?

    Final resort is an RUU and flash back to stock. But OTG will work - I do all my ROM flashing that way.
    scotty85 likes this.
  5. scotty85

    scotty85 Guides Guide

    CaseyDGeek likes this.
  6. CaseyDGeek

    CaseyDGeek Active Member

    I've tried different ports and even different computers with the same cable, to no effect. The HTC MTP USB driver comes up as uninstalled, and attempts to install it via 'update driver' end with Windows saying that the driver is up to date. The OTG cable was my first thought, but the HTC didn't detect the flashdrive.

    No, I don't have a nandroid.

    What effect will the RUU have?
  7. Hadron

    Hadron Well-Known Member Contributor

    An RUU flashes a complete set of stock software. So unrooted, back to stock recovery and factory reset in the process.

    I've never had a problem with OTG in TWRP. Very odd.

    Are the mtp drivers what you want? I'm afraid I don't use Windows for this stuff, so am not familiar with the driver issues, but I'd have thought there would be different drivers for adb.
    CaseyDGeek and scotty85 like this.
  8. scotty85

    scotty85 Guides Guide

    first,lets make sure were all on the same page in that you were trying to use adb with the phone booted to a permanently installed recovery,correct?

    second,what did you have plugged in to your OTG cable? you may not be able to use a flash drive. try the process again using a FAT32 formatted sd or micro sd in an adapter plugged in to the cable.
    CaseyDGeek likes this.
  9. CaseyDGeek

    CaseyDGeek Active Member

    I don't mind rooting it again, frankly, as long as the mobile works again.

    Yeah, that's right. ADB Sideload, to be exact. But the device just isn't detected.

    A flashdrive. Sadly, I do not have the OTG cable with me anymore.
  10. clsA

    clsA Well-Known Member

    I found these OTG USB to work Great in my one
    I have about 4 of them laying around with different sdcard flash drive combinations.
    Be sure and click where it says more buying choices and pick a US shipper else it will take some time coming from china.
    scotty85 likes this.
  11. CaseyDGeek

    CaseyDGeek Active Member

    I'm actually in India; I've ordered an OTG cable, though I'm not sure if it'll work well or not, just in the hope that it will.
  12. scotty85

    scotty85 Guides Guide

    have you used them with a flash drive? is it just neccessary that the drive be formatted FAT32?
    CaseyDGeek likes this.
  13. Hadron

    Hadron Well-Known Member Contributor

    I've used such things with ordinary flash drives with their default formatting (which will be fat32).
    CaseyDGeek and scotty85 like this.
  14. clsA

    clsA Well-Known Member

    yeah they work with fat32 flash drives fine
    I do have one 64gig Memory Master flash drive formatted NTFS that the phone won't read.

    Well I have to correct myself
    I reformatted the 64gig drive to exFAT and it works fine also

    I also have a couple of these it's a great combo
    Wow and their on sale again $17

    Attached Files:

    CaseyDGeek and scotty85 like this.
  15. CaseyDGeek

    CaseyDGeek Active Member

    I've ordered the cable, and formatted my pendrive to FAT32. Just waiting only, now.
  16. CaseyDGeek

    CaseyDGeek Active Member

    Till then, any idea why the RUU cannot read my device as connected, and how I can fix that? I've tried both USB 3.0 and 2.0 ports.
  17. scotty85

    scotty85 Guides Guide

    ruus are notoriously finicky. better bet is to get adb and fastboot working,and then extract rom.zip in this mannter:

    the .exe utilities can be finicky,so if you have trouble getting it to run, you can extract "rom.zip" in the following manner:
    -start the utility
    -check the "i understand" box to move on to the next screen
    -hide the utility temporarily out of site
    -search your C drive for "rom.zip". you will find it in a temporary location(it will be in a different spot each time you run the utility)
    -open the folder location,and transfer rom.zip to a safe location on your PC.
    -unhide and cancel the utility,youre done with it.
    -rom.zip can be renamed to PxxxIMG and flashed in hboot,from a FAT32 sd card

    then flash rom.zip in this manner:

    if youre working with a booted,operational phone,you can flsh the file in the following manner:

    -open a cmd window

    -change to adb/fastboot directory
    cd c:\foldername
    (cd c:\mini-adb if youve used any of my guides :))

    -place the zip file you want to flash into adb/fastboot directory

    -enable usb debug,disable fastboot,plug in phone

    -check for connectivity
    adb devices (should return serial number)

    -boot to fastboot
    adb reboot bootloader

    -check for connectivity again
    fastboot devices

    -flash the file
    fastboot erase cache

    fastboto oem rebootRUU (will put you in ruu mode,black screen silver htc letters)

    fastboot flash zip zipfilename.zip (will send and flash the file. dont interupt it while the cmd window shows its writinging,and the green status bar is moving on the phone screen)

    *sometimes a file will fail with a pre-update error. this is normal,just enter again:
    fastboot flash zip zipfilename.zip
    and this time it will finish

    -when you get "finished" and "OK"
    fastboot reboot-bootloader (takes you back to fastboot)

    -reboot back to the OS
    fastbooot reboot

    you can use this if you dont have an operational phone as well. you just need to manually put the phone in fastboot(select from hboot menu) then skip the "adb" commands and start with fastboot devices

    thats assuming that the utility youre tryiung to use passed all security checks if you are s on(main version,cid,mid,hboot,etc)
    CaseyDGeek likes this.
  18. clsA

    clsA Well-Known Member

    are you by chance running windows 8.1?
    you said you tried a bunch of different combinations are they all windows8.1 ?
    CaseyDGeek likes this.
  19. CaseyDGeek

    CaseyDGeek Active Member

    But the adb drivers are not working either, in the sense that I am unable to install them. The computer just doesn't read the mobile.

    All Windows 7.
  20. scotty85

    scotty85 Guides Guide

    Again,are you trying adb commands(not adb sideload) like "adb devices" with the phone in a permantly installed recovery? Definately no reason you can't get them working on windows 7

    Are fastboot commands working? Make sure to put the phone in fastboot(not hboot) and try "fastboot devices"

    If that works,start the .exe with the phone in fastboot
    CaseyDGeek likes this.
  21. CaseyDGeek

    CaseyDGeek Active Member

    Okay, I'll try that, but till then, another issue.
    I used the OTG cable to install the Viper ROM, but even after the installation, the mobile is telling me it has no OS =/

    And after I attempted to install the stock kernel, it now refuses to go beyond "hTC quitely brilliant".

    Okay, I reinstalled the kernel and then Viper, after it seemed like it was about to load and 'Beats Audio' had come up, but then it stopped.

    No wait. It worked! It worked! There is joy in the world again!

    Thank you so much, all of you!
    scotty85 likes this.
  22. clsA

    clsA Well-Known Member

    First boot of a new rom after deleting everything is always a slow process sometimes the phone looks like it's doing nothing for up to 10 min, and then android updating can take another 5. Then you have your google account restored 5 -10 min. Be prepared to set aside 30 - 40 min on a new clean rom install like that.
    scotty85 likes this.
  23. rootflasher27

    rootflasher27 New Member

    Does the org cable work in download mode.
  24. rootflasher27

    rootflasher27 New Member

    OTG cable sorry stupid 3.5 screens
  25. Hadron

    Hadron Well-Known Member Contributor

    OTG cables work in recovery (certainly TWRP) or when running Android. I don't know what you mean by "download mode" (that's a term I associate with Samsungs, not the HTC One).
    scotty85 likes this.

Share This Page