Internet Browser ProblemGeneral


  1. pintosal

    pintosal New Member

    My Galaxy W has problems browsing the internet.

    When I open a web page, either via Google or directly, I often get a message to say the web page cannot be accessed. The progress bar on the browser moves about 10% and then stops.

    This happens at home, or on the road.

    When I'm home, I use WiFi via my wireless router, where I have a very fast and reliable fibre-to-the-cabinet connection, but I still have problems. However, I can connect to the web using my laptop, so it's not a router wireless problem.

    Away from home, my mobile network connection has plenty of signal, but I still get problems.

    If I use tethering, then I have no problem using the Galaxy as a WiFi hotspot, so the mobile network internet access is working fine.

    This suggested that the problem might be an interaction between WiFi and mobile data.

    As an experiment, at home I disabled Use Packet Data. I then found internet access works OK. So now, at home, I disable this option.

    Does anyone else have similar problems?

    How can I get WiFi working well at home without the need to disable Use Packet Data?

    Advertisement
    Midopo likes this.
  2. blaxican25

    blaxican25 Well-Known Member

    have you tried a different browser? try opera mobile from playstore.
  3. pintosal

    pintosal New Member

    I have tried different browsers (Dolphin, Firefox and Maxthon) all with the same result.

    So I suspect it's an underlying problem with the way that Android handles communications.

    Part of the problem is that at home, my mobile signal is very weak, and I think the OS always tries to use the mobile broadband first. Hence when I turn off the use of mobile data it works fine.

    Just a theory....
  4. RobboW

    RobboW Member

    I've had this issue too. Seems the phone fights over using wifi or packet data as you say. It does auto switch. I assume it sees a better 3G than the wifi so wants to use it. I've also found power saving mode interferes because the phone wants to turn off the wifi. It might help to check your settings for power saving mode. I un-checked the auto off wifi setting.

    As to browsers, I've started using Opera Mini, despite the comments on PlayStore. I find it excellent. Especially having an easily accessible refresh button when using forums :)
  5. amirmurshi

    amirmurshi New Member

    i need help....
    why every time i'm use internet browser my galaxy w will automatically download m.bin from google play store??
    but download not success...
    can somebody help me??
  6. Midopo

    Midopo New Member

    ihave the same problem too
    ican't enter the enternet
    from playstore too !!
    my phone is : samsung mini galaxy
    any help !!

Share This Page