Internet Connectivity Issue over WifiSupport

Last Updated:

  1. waxonwaxoff66

    waxonwaxoff66 New Member

    I have had my DC for about 2 months now and everything has worked great. About a week ago started having an issue with wifi internet.

    Heres the problem:
    * When connected to any wifi network the stock android browser gives me a no internet connection error and loads the default error page.
    * My taskbar says that the phone is fully connected to the wireless network. (Have tried with multiple wirless networks in different locations)
    * It is not a problem with the router because I still have internet connectivity for other apps (i.e. Slacker Radio)
    * When I disable wifi and connect over 3g/4g everything works.

    I tried wiping cookies, internet settings, and data. Still no internet over wifi.

    Also tried factory data reset 1) with google back settings, and 2) with SD card pulled and google back up turned off. Still no wifi browser.

    Went to Verizon store and they are sending me a "new" phone. Anyone have any suggestions before my refurbished replacement gets here.

  2. trparky

    trparky Well-Known Member

    First thing first, when you are connected to your Wifi network on your phone... check some things. Go to Settings -> Wireless & Network. Now find your Wifi network in the list of detected networks, the one you're connected to should be blue. Tap your wireless network, a popup window should appear. Click the "View" button.

    A new dialog should appear. It should have details about your wifi network, like security, signal strength, link speed, and IP address. If it doesn't show an IP address that's similar to your IP addresses that your computers are getting, something is wrong. If it says you're connected but not getting an IP address, check your router to find out why.
  3. waxonwaxoff66

    waxonwaxoff66 New Member

    Checked the ip address and it seems pretty standard. My connection seems good since internet is working in other apps like Google maps.
  4. kshib

    kshib New Member

    @waxonwaxoff66, I have the same issue with my droid charge, even after having it replaced. It happened to me a couple months ago after the software update I am pretty sure. Did your new phone have the same problem? I am wondering if it is a problem with the charge or just individual phones. Thought?
  5. Bozz5384

    Bozz5384 Well-Known Member

    I have found that mine has a hard time connecting to wifi from a 4GLTE connection. It doesnt like to make a successful handoff.

    If I have my phone in 3G mode then it usually hands off just fine.

    Something to try for ya.
  6. rorkin

    rorkin Active Member

    Same Here..I Take it out of 4g mode often
  7. the7thninja

    the7thninja New Member

    ok i have gone thru the guantlet on this and i have figured out the prob with the wifi i think. so try this and im sure you will fix your browser probs with wifi as i did.
    first you need this rom CI510_VZW_EP4_ALL_ONE-LTE-CP_REV03_user_CL706183_ship.tar.md5 it is the factory reset rom for the droid charge and it has gingerbread 2.3.6 firmware which is the latest update to the charge software. download odin v 1.82 start odin then put your phone in dowload mode by powering down and then removing the battery. then hold down volume button then while holding volume down plug in your usb to computer till you see the big yellow triangle. at this point odin should say added and the first box up top should turn yellow. then click pda and choose the rom i refered too earlier. then put your battery back in your phone for this increases the success rate of odin. then hit start. when this is done the phone will clear all the caches itself and then you will have stock software that should allow you to use the wifi with browser again.. do the exact same process with a rom called all_in_one_odin_ep4d.tar.md5 to root the phone and then when the yellow menu comes up with the bananna man use the volume buttons to select and wipe cache and go to advanced and clear the dalvic cache. DO NOT CLEAR ALL SYSTEM DATA. reboot. and you should be rooted and have all functionality with wifi and browser.. haa ninja survive.
  8. the7thninja

    the7thninja New Member

    and im just sayin i dont think everyone on this post is being forthcoming with the fact that they rooted and are havin probs from that, execept me .. just sayin
  9. Bozz5384

    Bozz5384 Well-Known Member

    I had plenty of connection issues before I rooted, in fact my connections seem more consistent since I rooted. I'd say it has more to do with 2.3.6 update but better nonetheless.
  10. countrycoyote

    countrycoyote Member

    Go to > settings> Wireless & networks > Wi-Fi settings > Advanced > Proxy > now erase the info there & leave it blank & you'll get WiFi.

Share This Page