1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Internet Issues, Please Help!!Support


  1. yenial

    yenial Member

    Hi guys, complete noob here. Hoping someone can help.

    Since yesterday, my X10 won't connect to the internet via WCDMA/GSM preferred or WCDMA only. I can only get online by selecting GSM only.

    My X10 is running gingerbread 2.3.3 and is not rooted.

    I've got no problem making calls or texts, just the internet.

    My baseband version is 2.1.71
    Kernel Version 2.6.29-00054-g5f01537 SEMCUser@SEMCHost #1
    Build number 3.0.1.G.0.75

    (not sure what any of these mean but including them in the post incase you need them)

    Any ideas?

    Thanks!

    Advertisement
    :
  2. beau420

    beau420 Well-Known Member

    You have your MMS Settings?

    Settings->Wireless->Mobile->

    When you chose Network Operators, have you selected your carrier?

    And APN. Do you already have your APN set? Are the settings their for your cellular provider?

    Did you update recently and this just happened? How did you update? Did you chose the right x10 software? x10a or x10i? If this just happened after an update, I would suggest a factory reset and to try and do the update again....maybe it didn't properly install everything.
  3. torquey

    torquey Active Member

    I have the same issue. I updated to 2.3 today using the walkthrough. I am on ATT, and after flashing and rooting, I can't get the flashtool to connect except in flash mode, and I can't get a network connection without going wifi. Phone works fine, everything works on wifi. When I select my carrier from the Sony Ericsson settings item, it keeps saying, 'Could not download settings. Retry?'

    I have no xrecovery, but I think I am rooted as I was able to install and run titanium backup and screenshot.

    [​IMG]
  4. beau420

    beau420 Well-Known Member



    So your wifi works fine, but you are missing your MMS settings...your data settings for your cell provider.

    http://androidforums.com/sony-ericsson-xperia-x10/337200-upgraded-t-x10-2-1-a.html

    Manually enter that. If trying to retrieve the settings doesn't work (which rarely works) you have to manually enter them.

    Once they are in...try connecting over 3G or EDGE again (non wifi) and see if it works.
    torquey likes this.
  5. torquey

    torquey Active Member

    Bless you, I've got my H back now!

    Thanks also to:
    http://androidforums.com/sony-ericsson-xperia-x10/475087-x10i-data-issue-t.html#post3742963
Loading...

Share This Page