Support internet verrryy slow

Discussion in 'Android Devices' started by weems, Sep 14, 2010.

  1. weems

    weems Active Member
    15

    Jan 27, 2010
    42
    0
    15
    For some reason my x loads webpages very very slow. I know its not my area because my buddies droid 1 is fine. Sometimes mine wont load at all. Any ideas?
     

    Advertisement
  2. supersales5

    supersales5 Active Member
    15

    Aug 18, 2010
    38
    0
    15
    have to tried *228 and update roaming? Also is this on Wifi or 3G?
     
  3. appleboy

    appleboy Active Member
    16

    Aug 11, 2010
    39
    4
    16
    California
    Are you using Wi-Fi or 3g data?
     
  4. jaymdee

    jaymdee Member
    16

    Mar 23, 2010
    16
    1
    16
    I've been noticing this myself internet has been very slow last couple of days on 3g
     
  5. bigbadwulff

    bigbadwulff Well-Known Member
    143

    Jun 15, 2010
    2,442
    200
    143
    Depends on the signal you have. My WiFi at home is pretty fast like 14,700kbs. I tried it at a local coffee shop at it was like 900...barely able to load a picture with other users on it.

    3G is hit or miss sometimes but usually pretty fast. Around 3,000 here sometimes. 1854 where I am right now. Using Speedtest.net app.
     
  6. weems

    weems Active Member
    15

    Jan 27, 2010
    42
    0
    15
    This is on 3g. I did *228 yesterday with no help. Like I said I can be right next to my room mate and he will load 3 pages before 1 of mine loads.
     
  7. bigbadwulff

    bigbadwulff Well-Known Member
    143

    Jun 15, 2010
    2,442
    200
    143
    Dare I say?................Battery pull?
     
  8. yisagirl1

    yisagirl1 Member
    15

    Sep 18, 2010
    8
    1
    15
    My internet on droid x is sloooow i expected more
     
  9. yisagirl1

    yisagirl1 Member
    15

    Sep 18, 2010
    8
    1
    15
    For the price of this phone i am dissapointed and WHEN IS ADOBE FLASH COMMING TO DROID X....PROMISES PROMISES!!!!
     
  10. Rob71

    Rob71 New Member
    5

    Aug 18, 2011
    1
    0
    5
    What I did to fix this was I had to restart my phone. Just power it down...not battery pull. This worked for me. IT was probably just a CPU usage problem.
     

Share This Page

Loading...