Is it possible to downgrade HBOOT without clockworkmod?


  1. vitalym

    vitalym Member

    I had 2.1 rooted with S-OFF
    I wasn't able to update to 2.2 via OTA so I found an update.zip
    I attempted to load the update.zip but it failed
    Using [VIDEO] HowTo UnRoot Incredible by downgrading I downgraded to stock 2.1 but for some stupid reason I also disabled unrevoked forever and went to S-ON
    I then applied the May OTA update Getting your phone ready for the FroYo update.zip!
    Following that I applied the 2.2 update.zip

    Here are the versions I'm on:
    HBOOT-0.92.0000
    RADIO-2.15.00.07.28

    Now I'm trying to apply unrevoked3 and it fails
    I found 2.1 stock to 2.2 rooted (with links to files)
    I tried to downgrade to stock again and I now get this error:
    Main Version is older!
    Update Fail!
    Do you want to reboot the device?

    From what I understand I'm unable to downgrade to stock due to having an updated HBOOT
    I've found instructions on how to downgrade HBOOT How to revert back to an earlier version of HBOOT but it seems I need clockworkmod to do that

    So my question is, is there a way I can proceed from here or am I stuck waiting for an official root for 2.2?

    Advertisement
  2. bisbers

    bisbers Well-Known Member

    Wait - now you are s-on or s-off?

    I think it says you are s-on.

    Not sure it would work, but I would try to use the original root method (sd card race condition trick) to gain access to system. If I could get there, then I would push su and pals. Try to get custom recovery back in there. Then s-off (or update).
  3. vitalym

    vitalym Member

    Yeah I'm S-ON and I think that's what's causing the problem.
    I have tried the original root method using unrevoked and this guide but, IIRC the error, it fails to push the boot loader.

    I'm not familiar with the "sd card race condition trick", can you link me to a tutorial please.
  4. dsb9938

    dsb9938 Well-Known Member Developer

    I cannot find the link, but basically you create a batch file looping the adb shell command (from the SDK) and run it. Once it's going it will say device not found over and over again as it runs.

    While running that, you pop the sd card in and out of the phone. Eventually it will see the phone. I have never understood this, but I have done it.

    Then you can push what you need to.

    I will search for the link.
  5. dsb9938

    dsb9938 Well-Known Member Developer

  6. bisbers

    bisbers Well-Known Member

    As I was curious about such a scenario, I did some experimenting. It seems the updated recovery that was included in the 2.2 release includes a fix for the sd card adb shell trick.

    First I pulled the new stock recovery from the 2.2 release and instead of exec msg I get "error: device offline".

    As a sanity check since I haven't done that since june, I pushed the original stock recovery and confirmed it did work, so I was doing things correctly (and its all in the recovery, doesnt seem to have anything to do with hboot version).

    As for you, vitalym, (and everyone else who might upgrade to 2.2 then want root) - looks like you might be stuck until someone roots 2.2.
  7. bisbers

    bisbers Well-Known Member

    Can you confirm you don't still have root?
    Like is superuser still in your apps?
  8. bisbers

    bisbers Well-Known Member

    And lastly, check out the post dennis put up - it seems there is a way to downgrade from 2.2, then you can root.
  9. vitalym

    vitalym Member

    Well I had to load a stock 2.1 firmware as I got stuck in a boot loop when I loaded 2.2 on my rooted phone, so I don't have SU unfortunately :/

    As long as there eventually will be a way to root, and hopefully forever root, the phone it isn't a huge deal.

    I'm just kicking myself for going to S-ON, for some reason I thought that was preventing me from running the 2.2 update.zip

    I'll try the link by Dennis later tonight
  10. vitalym

    vitalym Member

    No luck with any method so far
    Does anyone know a way I can re-flash my phone even with the Froyo update, it seems to be acting up.

    For example, when I click a contact to launch a call it will sometimes take 30 seconds to start the call. Or when I click into a text field it sometimes doesn't type and I have to exit and try again a few times before it goes.

Share This Page