Is something wrong with my EVO 4G Radio?Support

Last Updated:

  1. thekeel

    thekeel New Member This Topic's Starter

    Jun 13, 2010
    Likes Received:
    So I've been a happy EVO owner since launch, but there has been one little thing that has been bothering me about my 4G connection.

    My wife and I both have an EVO, and I have noticed that at our house she constantly gets 1 additional bar of 4G. If mine is Poor, the other says Fair. If her's is poor mine just drops the connection.

    We both have the same radio version installed and everything is essentially the same between the two phones.

    So being OCD about my devices, I decided to do some tests at various locations in and outside of our house. I've lost count of how many times I have tested the connection, but 9/10 times her device will jump right on to the Sprint network while mine will just sit there scanning and scanning. Eventually mine may connect, but always with a lower bar. She also gets 1-2Mpbs more than I do on the Speedtest app.

    Video of just one of the many times I have tested this:
    YouTube - EVO Connection Issues.mp4

    So I am thinking I got a EVO with a weaker radio. Should I ask for an exchange? Has anyone else exchanged an EVO, and if so how did you go about it?

    Thanks for your help!

  2. Thefoodman52

    Thefoodman52 Well-Known Member

    Dec 1, 2009
    Likes Received:
    Yea, go swap it out at the store. Just tell them the issue with the radio, then they'll probably replace it.

Share This Page