Is there a way to set 2G only?Support

Last Updated:

  1. visitador02

    visitador02 Well-Known Member

    On my HTC Magic, I am able to set, under settings, whether I wanted 3G, 3G/2G, or 2G only. I found that helpful because there were some areas where the 2G signal is actually stronger and more reliable.

    I don't seem to be able to do so with the X10a. It is either 3G only or a hybrid 3G/2G. When I do the hybrid, the signal in house changes back and forth between 3G and 2G.

    Does anyone knows of an app that will force the phone to be on 2G only? Thanks.

    Oh, btw, I noticed also there is an option to disable mms and data. Is that function actually forcing the phone to be on 2G, i.e., GSM?

  2. Ramboline

    Ramboline New Member

    Try Network in the Market
  3. pontuszaar

    pontuszaar Active Member

    I think it forces it in to 2g if you disable the mms and data. Atleast thers no 3g symbol in the top menu.
  4. Koyanishi

    Koyanishi Well-Known Member

    Go to settings/wireless controls/mobile networks/network mode/ and click on GSM only.
  5. puppet_master

    puppet_master Well-Known Member

    Install Juice Defender (free in the App store) and use the APN on/off widget :)

  6. davethorp

    davethorp Well-Known Member

    Seems to be some confusion here between having a 3G signal (being connected to a 3G network for voice/text/data) and 3G data.

    Koyanishi has it right for what the OP wants to do (force the phone to ignore 3G networks and connect only to a 2G network) BUT some networks (3UK springing immediately to mind though there are others) will stop you from forcing the phone to a 2G signal and require you to be in 3G only or mixed mode

    The post that says disabling MMS and data removes the 3G indicator is correct it does, but that just means it doesn't have a 3G data connection and not that it isn't connected to a 3G network

    Juice defender will just disable the APN again disabling the data but not stopping the phone connecting to a 3G network
  7. visitador02

    visitador02 Well-Known Member

    Thanks. On my Rogers X10a, there is no GSM only. There is WCDMA only or GSM/WCDMA preferred.

    It looks like the settings are different between X10i and X10a.

    Thanks for the idea though.
  8. Blue1k

    Blue1k Well-Known Member

    This will work for the X10 and X10i:

    Open the dialer
    Type *#*#4636#*#*
    Go to section on phone settings
    Change to GSM only (2g)

    This will turn off the 3g radio.

    I did the opposite, as I have no 2g with TELUS.

  9. Ramboline

    Ramboline New Member

    But the Network in Market is the same.
  10. saltorio

    saltorio Well-Known Member

    I can confirm this does in fact work on Rogers-branded phones, which otherwise do not have the "GSM only" option through the main settings menu.

    However, I did experience an odd issue after doing this on my X10, in that after the phone was on standby for a few minutes, "auto-rotate" no longer worked - whether or not is was enabled in the settings - until I restarted the phone. This may have been a random unrelated issues, but it happened both times I tried switching to GSM only through the *#*#4636#*#* menu.
  11. visitador02

    visitador02 Well-Known Member

    Again, thank you everyone for their inputs. I'll try both the network app and the 4636 option and lets see what happens.

    Edit: I tried both and prefer the network app just because it is easier to press the app and change the settings. Now, I have gsm only and "E" shows up in the notification area. This is quite helpful in areas where the 3G signal is weak.

Share This Page