Is there some way to fix my bricked DHD?Support


  1. dezmoinez

    dezmoinez Member

    Hi

    I run CM7 on my DHD. Last week, my computer couldn't recognize my phone when connected by usb. It was only on charge. Yesterday, it couldn't longer find my SD-card. So I guess it is what people call "bricked". To fix this, I followed a desire-bricked guide. But I can't connect to my phone with fastboot, it only says "waiting for device". "fastboot devices" says there is no device. And in the fastboot menu, there is nothing about a USB-connection at all. So I can't use the 'fastboot oem enableqxdm 0' which must be used.

    So now I can't access my SD-card, therefore I can't flash a new ROM. I'm stucked with CM7, and since it won't find my SD-card I can't use the camera and many other functions as well.

    Is there any solution at all?

    Help is most appreciated.

    Thank you guys :)

    Advertisement
  2. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Your phone is definitely not bricked. A bricked device is one that won't even power on and so cannot be repaired. If a phone turns on at all, like yours is, then we can work with that :)

    Can you boot into recovery? You can do that by turning off the phone, turning it on again whilst holding both the volume down and power buttons. That will take you to a white screen on which you need to use the volume buttons to move the cursor onto the 'recovery' option and then hit the power button.

    Once you've done that, you should be able to go to Mounts and Storage >> Mount USB storage. That will let you access the card via USB. At which point I recomend you backup everything off your card to the PC, in case this is caused by a problem with the sdcard.

    Then you can add a new ROM to flash as well. Or you can reflash CM7 to try and fix it.
  3. dezmoinez

    dezmoinez Member

    Thanks for your help.

    The problem is that the computer can't get access to the phone or the sd-card since I've got that USB-brick or whatever it is called.

    Nothing happens when I enter "mount usb storage" when connected via usb. there is only two options, 'unmount' or 'go back'

    So the problem is, I can't access the phone/sd-card via my computer so I can't put a new ROM on it. Not even via fastboot :(

    and my phone does not detect my sd-card, and it is impossible to fix that since I can't do the 'fastboot oem enableqxdm 0' because my computer won't detect my phone/sd-card.
  4. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    I think the easiest thing to do right now is to figure out where the problem lies, if you haven't already. I.e, whether the problem is your phone (CM7) or the sdcard. My money is on the sdcard being corrupted, since sdcards are very prone to errors.

    Have you got a different microsd card you could try in the phone? Similarly, have you got any other device with which you can connect your current microsd to a PC (either directly by using a card reader or putting it into another phone, a camera, etc)? Trying those two things will let you identify the problem.

    If it turns out the sdcard is the problem, you'll probably just have to reformat it. You can do that via recovery, from CM7 or when it's plugged into the PC. It will wipe your data, but if your card was corrupted then your data was already lost.

    If the problem is the phone, then we can worry about why fastboot commands aren't working. The likely explanation for that is your phone isn't S-Off, but that's a lot of hassle to go through if you don't need to.

    Would you mind linking me to the instructions you're following too, by the way?
  5. dezmoinez

    dezmoinez Member

    I will look for another micro SD to put in.

    Actually, the problem with the SD-card started when I formated it in CM7, hoping to fix the USB problem. After that it wouldn't work any longer. I have tried to reformat it in CM7 again, without success.

    I already have S-OFF according to the bootloader. These are the instructions I follow: ::: HTC Desire USB Brick fix - Guide for noob But I can't get pass the first step as I mentioned since cmd says "waiting for device". this is probably because my usb connection isn't working as it should. but I don't think it is something wrong with the cable, because when connected it does charge the phone and the status page in the phone says charging-USB :confused:

    But I will try a different SD-card and see if that works and report back later :)
  6. dezmoinez

    dezmoinez Member

    Okay, so I tested my SD-card in another phone, and it don't work there either, so I guess the SD-card is not working. The status bar says something like: "SD-card is empty or the filesystem ..." then I can't see what more it says. Is it possible to fix or is it just to buy a new one?

    Then I tried another SD-card in my phone. It works, so I flashed CM7 again. Unfortunately, the USB-connection still doesn't work, so I guess there is two options now.

    1. I flash a RUU
    2. I follow step two here: ::: HTC Desire USB Brick fix - Guide for noob

    But the problem with step 2 is, since I can't get fastboot working, I can't get my CID. Can I get it somewhere else? I run CM7 7.0.3 if that helps :O

    I really appreciate your help :)
  7. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Sorry it took me a while to reply to you - suffice to say I've had a long week!

    Having a proper look at those instructions, I don't advise you try it with your phone. The files they provide look like they are system files designed for the HTC Desire, meaning it's doubtful they will work on the Desire HD. Trying to shoehorn system files from one phone to a different phone in that manner stands a far greater chance of bricking the device than fixing it.

    Unfortunately, I'm no developer and I wouldn't be able to identify the equivalent Desire HD files for you to flash with any confidence.

    At this point, I think your best bet is to try and install via a RUU. I've had a google for other DHD users having this problem and I haven't found a similar solution to the one you found for the Desire.
  8. dezmoinez

    dezmoinez Member

    Okey, thanks. I will try to flash a RUU. But how do I do that? I found these instructions: [GUIDE] Installing RUU's - xda-developers Are they ok? But I'm a little bit confused. It says in the beginning: "Download the latest RUU (1.32.405.6).
    Run it as administrator." I can't run a zip file, or can I?
  9. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    You don't need to use those instructions to run an RUU.

    RUUs are windows programs (that you run as an administrator) that update your phone is connected via USB. It's a really simple procedure, and you wont have to even touch the phone once you've plugged it in.

    I would suggest going back to the RUU with the same build number that you had when you originally rooted, so you can root again after this.
  10. dezmoinez

    dezmoinez Member

    I did an unroot of my phone but putting a pd98img.zip on the sd-card and flashed it in the bootloader. Now I run 1.32.405.3 and my SD-card that didn't work now works fine. But, the phone is still not recognized by the computer. I still have S-Off I guess, but that shouldn't really matter? Can I go back to the store and say it is broken, even though it was rooted? If I do S-ON, then they should not be able to see it has been rooted, right?
  11. Xyro

    Xyro 4 8 15 16 23 42 Moderator

Share This Page