Issue - Audio Distortion/Skipping With Screen OffSupport


  1. jikhead

    jikhead Well-Known Member

    Can someone who's now running the updated 4.0.2 software test this problem I found on the phone two weeks ago and report back whether it is fixed or not?

    The Bug I found - First off, let me mention that the software version on the phone was 4.0.1 and not the supposedly final release version of 4.1. The problem I found had to do with listening to music with the screen turned off. I bluetooth'd three songs and one video over to the phone. Two of the three songs are 320kbps mp3s, while the 3rd song was 128kbps. (backlog on this: the 128mp3 came from iTunes a long time ago and that's what you get from them. I quit using iTunes back in 2007 and starting using only 320mp3s because of my deejaying.) Anyway, when you play a song (Google Music is only player on the phone) whether via the speaker or headphones, music experience is fine when the display is on. Once the display turns itself off or you turn it off, the music begins to distort and skip (skip slightly). All this occurs with the sound enhancer (EQ) turned OFF. If you turn the EQ settings to ON, this problem goes away. I tried this many, many times and got the exact same results. Note, that it did NOT occur with the 128kbps mp3. Also note, that it should not have anything to do with the bitrates being used. I have no issues like this on my Incredible nor on my GFs iPhone. Also, the Google Music store's default bitrate is 320kbps as well. Perhaps this is addressed in the ICS 4.1 and the phone needs to be updated, don't know.
    http://androidforums.com/samsung-galaxy-nexus/458566-got-play-w-lte-gn-today-pics-found-bug.html

    Advertisement
    :
  2. NEXUSorBUST

    NEXUSorBUST Well-Known Member

    mine updated within twenty minutes of leaving the store today
  3. jikhead

    jikhead Well-Known Member


    You totally missed my question; did this bug get fixed with 4.0.2?
  4. jikhead

    jikhead Well-Known Member

    Well, I went to the store and verified that this bug is not fixed. I had to update the dam display phone myself, as they didn't have it activated. Anyone know how to report bugs to Google?
  5. NEXUSorBUST

    NEXUSorBUST Well-Known Member

    I have no such bug with mine. Maybe it is centralized to your device?
  6. jikhead

    jikhead Well-Known Member

    Do you have a 320kbps mp3 to test it with?
  7. jikhead

    jikhead Well-Known Member

    I have reported this problem to both Android team and Samsung support. Admins, can we start a sticky for current issues?

    Also changed the thread title.
  8. saltesc

    saltesc New Member

    I'm having the same problem with FLAC and 320kbps tracks. It's the CPU. When the screen shuts it drops CPU power to conserve battery but it does it so much it ****s with audio buffering.

    I'm still looking for a fix. All I can think of so far is rooting and installing SetCPU to set a custom CPU profile of like ~400Mhz when the screen's off.

    On 4.0.1 by the way but I can tell you I know that's the root cause. I am mostly okay in the default music player, but any third-party players and the issue is pretty severe. I assume the default player probably gets some CPU priority but not quite enough for higher quality files.

    By the way, iTunes mostly dishes out AAC files from their store (not that I'd even bother touching that program with 100ft shit-tipped pole). Despite being 128kbps (usually), they are higher quality than MP3 files though they can sound different and sometimes poorer. Can't go wrong with FLAC though.
  9. tdiggitydog

    tdiggitydog New Member

    Same problem. Only seems to happen when the second track plays and so forth. The first track always plays fine with the screen off, but after that it starts clipping. Note i'm streaming music from the google music online on the android app.
  10. bi0nicman

    bi0nicman Well-Known Member

    i have this issue too but i have so few mp3's with 320kbps that its not that big of a deal to me. definately seems like a CPU resource thing.
  11. yohdroid

    yohdroid New Member

    I have the same issue. I only have 320 kb. I read this post, had music playing, went to settings and turned on the equalizer. It somewhat adjusted. The bass boost and 3d effect were already on(I just bought gnex yesterday. I never touched the music settings.), I turned them down. Once I played around with presets the phone crashed. I repeated after boot. Same result. I was able to fix the sound, adjust preset and equalizer with no music playing. Hopefully more updates come soon..
  12. NZtechfreak

    NZtechfreak Well-Known Member

    Same issue here, largely fixed by using PowerAMP with maximum buffer size, and highest priority level in settings (I say largely fixed because I had it once yesterday, first time in several weeks it's happened after setting up PowerAMP).

    If you Root I would think that something like SetCPU could fix this by increasing minimum CPU clock with screen off (obviously at the expense of battery).
  13. invaderpymm619

    invaderpymm619 New Member

    I have a galaxy nexus running 4.0.2 and im having the same problem. I get most of my music for free off the internet and it seems like these lower quality songs are cracking more, but it all goes away while the screen is on. cmon....
  14. *idroid*

    *idroid* Well-Known Member

    I got the fix. I had the same problem with google music. Just uninstall the google music update and it should work fine.
  15. jikhead

    jikhead Well-Known Member

    I finally put Player Pro and Power Amp on my phone. I can confirm that this same issue occurs while using Player Pro; however it does not with Power Amp.
  16. NagaRampage

    NagaRampage New Member

    The issue is with the sampling frequency. From what I've noticed, only songs with 48000Hz are causing proiblems. Those with 44100Hz, do not.
  17. saurabhkhare

    saurabhkhare New Member

    The problem is caused if you use an app like SetCPU to lower the frequency of the CPU at screen off. The solution is not to tune the frequency down below one half the max freq at screen off. To start with you can enable the performance governor ==> no skipping, next set it to conservative ==> lot of skipping. Also disable profiles during music playback if any.

    Thnx! :)
Loading...

Share This Page