Issue: Dismount/disappearing defect in the Included 8GB MicroSD?Support


Last Updated: 2010-06-05 06:34:49
  1. Bek

    Bek Well-Known Member

    After reformatting last night, I'm still seeing the issues this morning. For me, I can always trigger the failure, simply by opening Astro File Manager and trying to browse photos.

    I tried to use your Reload SD widget, and the system does remount the card. However, it only sees the card as being a blank or unreadable card, thus asking me if I want to format it! If I reboot (and thank goodness this phone reboots fast), then it'll see the card again.

    I noted during one try, that I could do plenty of other things like run SD Speed Test (a nice read/write test which doesn't work after the SD card fails), listen to music, or use the Gallery to browse photos.

    I'm going to try a few other things. I'll re reseat the card once again, and maybe test to see if there's wiggle room that could be the root cause. If so, I'll look into maybe using a scotch tape shim to secure it further.

    I'm also curious to try plugging the phone into my laptop after a failure, to see if I can see it as a USB drive still or not.

    Advertisement
  2. shokher99

    shokher99 Member

    i have opposite results. if i don't open the gallery i can look at pics through astro and take pictures all day long. if i open the gallery the photos will show up as thumbnails and maybe work for a short while but eventually when i try to bring a pic up full size it will hang. after it hangs if i try to use the camera it says that it doesnt have the file permissions. i think the gallery isnt letting go of the sd card. the weird part is i can browse the photos all day long if i go to the camera and hit the film icon to look at the pictures that i took. is that the same gallery app? when i plug in the phone to a computer after the failure, it doesn't give me the option to use as a disk drive at all. presumably because the phone doesn't detect it any more. so can anyone else isolate the gallery app as being the culprit??

  3. Exactly, Stop fiddling with the phone and start fiddling with her instead. What's wrong with you? ..:D
  4. Bek

    Bek Well-Known Member

    Alright gang, so I continued having the issue if I had the failure, then plugged the phone into my laptop - my PC wouldn't recognize the USB drive.

    I popped my battery and took a closer look at the card slot mechanism. I cannot describe it, but the mechanism that secures the SD card is spring-based, and does have a tiny bit of play. I attempted to push the card in as far as it would go.

    After rebooting, I have not been able to reproduce a failure - a GOOD THING. I'm going to keep an eye on things and see how it goes. If I suffer a failure again, I'm going to put a few small pieces of scotch tape on top of the SD Card. This'll make it thicker, forcing the battery to push it all the way down, hopefully securing it better.

    I'll report back if I have any further issues. To those who are, try reseating your card and cross your fingers.

    Oh yes, I found out about and secured a copy of h2testw, which can be used to test the data integrity of the card itself. I tested 1/2 of my card (it only tests sectors that are free space) and had no issues.
    SHO_ONE, andddlay, Archon810 and 3 others like this.
  5. Colorado_Al

    Colorado_Al Well-Known Member

    Glad to hear it.
    Re-seating the card did it for me. I think you need to make sure that the card is pressed firmly into the slot and that the release lever is pressed down firmly as well.
  6. Lloyd50

    Lloyd50 New Member

    I switched cards and I haven't had any issues . I tried putting a piece of paper in with the battery to keep the sd card secure but I still had the issue, I currently have my girlfriends blackberry 1 gig sd card in my evo and I have yet to get the no card avilable error. I think it's an issue with the actual card being bad.
    marctronixx likes this.
  7. shokher99

    shokher99 Member

    i think its software related. i bought 2 different cards with the same failure. how long have you had the 1 gig card in your phone without a problem?
  8. Bek

    Bek Well-Known Member

    This aucks, card took a shit again. Even have a tape shim in there! Am out so will try again later.
  9. Lloyd50

    Lloyd50 New Member

    I've had it in since last night , I have one episode of Seinfeld on it and one album and so far I haven't had any issues ..I'll report back with how it's doing later on this afternoon.
  10. mcbtrain929

    mcbtrain929 Well-Known Member

    jeez, this is getting ridiculous.....
  11. PWBarrett

    PWBarrett Member

    I'm having the same problem - Camera app says it can't save to the card due to file permissions. The gallery sometimes shows all blank images, sometimes hangs.

    I looked from a PC and reset the file permissions on some Thumbs.db files
    (attrib -s -h h:\*.* /s)
    When I upplugged the phone said preparing SD card, and now it's working at the moment.
    I don't know if it was these files, or just making it prepare the card again, or how long it will last.
  12. cluckkillerb

    cluckkillerb Well-Known Member

    It pretty much HAS to be a software issue if it's being recognized after rebooting without physically touching the card. They should be able to fix something like this with a software update, all the more reason for them to update the EVO to 2.2 (plus bug fixes) :p
    Archon810 likes this.
  13. PWBarrett

    PWBarrett Member

    I started getting the error again.
    This time I just plugged the phone into a PC as a disk drive, then unplugged it.
    The phone re-prepped the card, and it's working again.
    Must be a software problem. I hope somebody comes up with a fix.
  14. Eguy

    Eguy Well-Known Member

    Living up to your user name I see.
  15. aldo

    aldo Well-Known Member

    I had this problem when I first got my EVO, but have not had it since.

    Tried your way of making it come back - browsing with Astro - and I went back into camera and sure enough it said I didn't have permissions.

    Decided to format the card using the official sdcard formatter here: SD Formatter 2.0 for SD/SDHC - SD Association (takes awhile to do a full format because it writes to the whole card and then formats). I unmounted the card before I did this on the phone.

    Put the card back in, browsed around and did everything I could to make it come back and everything seems ok now. YMMV.
    SHO_ONE, twospirits and Bek like this.
  16. shokher99

    shokher99 Member

    i also did a full format (took about 20 minutes) in vista and have not been able to duplicate the failure anymore. weird because i formatted them both in linux yesterday and that didnt stop it. keeping my fingers crossed...

    also, i didnt put any of my old pictures on the card thinking that some of the files might not be playing nice with the phone.
  17. Diesektor

    Diesektor Well-Known Member

    I've been doing alot of research on Android since first hearing about the evo since this will be my first Android device. I'm still eagerly awaiting Friday but now i'm kinda nervous since I read the sd card post. I will be using the camera religiously for taking pics of my son. Anyone else nervous about this? It's been a known issue for over a year and it's still around...
  18. aldo

    aldo Well-Known Member

    For some reason I remember reading that this official formatter is the one to use because formatting elsewhere might muck up something with the card? I don't remember but I've used it since and it's been good. Hope it helps others.
  19. Archon810

    Archon810 Well-Known Member

    No corruption actually occurs - all my files are always intact after the reboot, so it's not the same issue.
  20. Archon810

    Archon810 Well-Known Member

    That makes a lot of sense, but it can still be hardware related. The hardware can at some point do something that messes with the software, and is reset by a reboot.

    Fingers crossed that it can be fixed, and more importantly, diagnosed.
  21. Bek

    Bek Well-Known Member

    Finally just got back home from running around all day.

    I'm both disappointed and glad to hear that I'm not the only one with this issue.

    Thanks for posting up that SD Formatter - I'm going to try that immediately. Also plan on digging further into the Android Bug Report thread. I'll report back if I find anything useful, that hasn't been shared here already.
  22. marctronixx

    marctronixx Moderator Moderator

    that is not going to affect me. the people who post online do not represent the masses so although we have seen people post about it i dont think its anything to get alarmed about. i have the htc hero (had.. just sold it) on launch day and had a 16gb card in it and it was just fine. i stored facebook photos i would upload and some 3 stooges shorts on the card and never had any issues. the evo is a first gen phone so it will have bugs just like any first gen phone. we will be early adopters of this new tech so bugs will show up... mass produced products have bugs in them... the evo is no different..

    but no im not worried because of a few posts...
  23. Rob_A

    Rob_A Well-Known Member

    if that happens to me, I will try another micro SD card. If the same thing happens, then i know it's an issue with the phone and I will just exchange it.
    neodorian likes this.
  24. Caloy

    Caloy Well-Known Member

    I'm a bit nervous, but hopefully they can fix this issue before my 30 days is through, or I'll be sending the Evo back.

Share This Page