Issue With Camera - "Preparing SD Card"


  1. bad_intentions

    bad_intentions New Member

    Hi all, sorry if this has come up before, but this morning when I tried to use my camera it has the message "preparing sd card" and never lets me use the camera. I can switch to camcorder mode and that works just fine but whenever i switch back to camera mode i get the preparing sd card message.

    My first thought was that the card was somehow corrupt, but I am able to play mp3s and watch videos from the card with no issues. I also opened astro and navigated to the DCIM\camera folder and i am able to view the pictures in the gallery that i've taken with the default viewer.

    when i'm in camera mode and try to view the gallery it just says no media found.

    I have tried rebooting and pulling both the battery and sd card, putting everything back in and powering back up, but it still does the same thing. Anyone ever seen this or have any other advice on a possible fix?

    Advertisement
  2. icstars989

    icstars989 Well-Known Member

    Have you tried, mounting your phone back with your computer, then ejecting it from the computer, and then turning the mount off on your phone?

    Edit: I'll clarify that just in case you dont know what Im talking about, maybe save you some time if you dont. Plug in your phone to you computer, then choose to mount it. Right click the phone from your explorer and click "Eject" then on your phone chose to turn off the mount.
  3. bad_intentions

    bad_intentions New Member

    Thanks for the suggestion. I tried it and still no dice. I also tried safely removing the device from my PC, then unmounting, still i have the same issue.

    edit: I downloaded the camera magic app from the market, and it does not display this error. I can take pics with camera magic and it saves to my sd card with no issues. I don't really like camera magic though, just testing out another camera app to see if it did the same thing and it did not. Also i'm still getting 'no media found' when trying to view pics from the gallery.
  4. taz

    taz New Member

    Let me start by saying that I'm a novice ...

    I've taken a bunch of pictures, and video with the camera (and the only pictures of my small initimate marriage in the JP's office are on here - stupid, I know!)

    I get the message -"no media found" when I try to display the pictures from the gallery.

    And get the message "please insert SD card" when trying to use the camera and video.

    Any ideas of how I can recover my pictures ? and fix the camera issue are appreciated.
  5. obrienjm

    obrienjm New Member

    This happened to me too. What worked for me was not to "eject" the Droid by right-clicking on the drive in "my computer", but to use the "safely remove hardware" icon in the task bar. No problem after that.
  6. jeff275

    jeff275 New Member

    I just had this same problem too and none of this is working. I was copying a bunch of stuff to my Mac. The phone rang while it was happening and that was super slow to let me ignore the call but that's the only thing I can think of that happened. I can still mount it just fine on both Mac and Windows XP. Any ideas?
  7. jeff275

    jeff275 New Member

    I figured it out. I uninstalled Aurora and the problem went away. I had just reinstalled Aurora earlier in the day to see if that would get rid of the force close issues it has. Apparently it was even more problematic than I thought, though this is the only time I have had the camera issue.
  8. hspb

    hspb New Member

    Hello, i may have found another way to help fix the issue with Preparing SD Card when in camera mode. Make sure you are on your home page of your phone, I'm using a Motorola Android A855. tap the menu button and then tap Settings. Scroll down to SD card & phone storage and tap on that. Tap on Unmount SD card and it will tell you that you can now safely remove the SD card. Turn your phone off. turn your phone over and take off the battery cover. take out the battery and then take out your SD card. Leave your SD card out for 30 seconds and then replace it back where it belongs. put your battery back on and your back cover back on. turn your phone back on and go into your camera program to see if it has taken care of your problem. i have also checked the gallery, while in camera mode, and it also works to view pictures.

    Hope this helps as well......take care.
  9. Lvmetndr

    Lvmetndr New Member

    I'm very new to this site and feel the urge to spread some random luck I just had. I too disconnected my usb cord too early and for a while the words "preparing sd card.." stayed on my camera screen and I could not view any of my photos. So I did this instead: I went to SETTINGS, then clicked on APPLICATIONS, then DEVELOPMENT, then clicked the check mark for USB DEBUGGING (debug mode when usb is connected), then I connected my USB cord. (I did not mount) After a few minutes I disabled the debugging mode and went into my camera and it was fine. It read "now use SD card." and I went into my pictures and they were all there. After all was well I went back into settings and unchecked the USB DEBUGGING box.

    I hope it helps. I'm not tech smart but I do like to "play" with my phone while trying to remember what I did so it won't mess up. I guess just try it and if it doesn't work then I guess I'm wrong and I'll recant my post.

    Thanks!:rolleyes:

Share This Page