Issues mounting Evo as hard drive


Last Updated:

  1. farva

    farva Well-Known Member This Topic's Starter

    Joined:
    May 27, 2010
    Messages:
    95
    Likes Received:
    17
    For some reason the SD card no longer mounts as a hard drive in Windows 7 after plugging it in via USB. I have the "Connect to PC" option in the settings menu set as "Disk drive" and the checkbox to prompt for USB connection type is checked but I'm not able to get the SD card to show as a drive. Is there anyway to make this happen manually?
     

    Advertisement
  2. farva

    farva Well-Known Member This Topic's Starter

    Joined:
    May 27, 2010
    Messages:
    95
    Likes Received:
    17
    edit: Also, when plugged in via USB, the Home button now takes me to this screen ... what is this and why is it happening? :)

    [​IMG]
     
  3. marctronixx

    marctronixx Moderator Moderator

    Joined:
    Oct 12, 2009
    Messages:
    5,699
    Likes Received:
    3,503
    thats the navigator screen. used when you are in the car and you need quick access to certain functions.

    do you have a custom rom? rooted? using and task killers??
     
  4. farva

    farva Well-Known Member This Topic's Starter

    Joined:
    May 27, 2010
    Messages:
    95
    Likes Received:
    17
    No root, stock rom and no task killers. I just did a battery pull and tried again, I still just get a charging phone without a hard drive mount - I restarted my computer for good measure as well. It's probably an issue on my end, just wanted to see if anyone had run into the same issue before.
     
  5. kayst

    kayst Well-Known Member

    Joined:
    Apr 14, 2010
    Messages:
    432
    Likes Received:
    63
    I have the same problem with the disk drives on my Incredible. Well, with the internal drive anyway. If I connect as disk drives, only the SD card shows up. To fix this, I set the default connection type to be Charging. After I connect, I pull down the notification bar and change the connection type to Disk drives (be sure and press Done, or whatever it says at the bottom). This time both drives are visible on the PC. Try this and see if it works for you.

    And if it doesn't work the first time, instead of unplugging, just pull down the notification bar and switch back to charge only, then disk drive again. Wait for the SD card to finish mounting or unmounting each time.
     

Share This Page

Loading...