1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

Issues with CM7 please HELP!Support

Last Updated:

  1. I have been trying to get help at cyanogenmod forums for a few days and no luck, so I found a few threads here and wanted to see if you guys could help me.
    Background: I purchased a used Nook Color last week, and found root procedures and how to install CM7 on you tube. Followed it and bricked the Nook. UGH. Found restore reformat and repartition threads at XDA and restored the Nook back to stock. Found a useful thread on how to install CM7 on a SD card and load it that way, which is awesome, it took me 7 tries and then it finally installed and got the app bug worked out. Problem I am having now, is that NO matter what I do, I cannot get the thing to boot into recovery to install things, like custom mods, ect. funny thing happened last night, when I removed the SD card and hit the power and N buttons, it booted into CM recovery. Not through the SD, through the nook. But it was supposed to remove CM recovery from the tablet when I re did it. Come to find out when I was using ROM manager, in apps, it flashed CM recovery to the Nook not the SD card, when I went into it. I have tried rebooting and holding the power and N button and releasing the power button and holding the N button still, and it boots normal, I have tried holding power and N and it shuts off after a few seconds trying to reboot. I have tried every combination I have found searching the internet.

    How can I boot into recovery using the SD card? I am using CM7 7.0.2
    Any help would be appreciated!! Thanks

  2. chocophile

    chocophile Well-Known Member

    Download j4mm3r's u-boot.bin and replace the one in the root directory of the SD card with it. [ADV] Boot menu for the Nook Color [2011-03-19] [Archive] - xda-developers . This will give you a menu every time you power on, allowing you 5 seconds to choose between eMMC and SD as boot device, and normal, recovery, and alternate for boot mode. If no choice is made, it boots to the device on which u-boot.bin is installed (In other words, the SD card, CM7, in normal mode).

  3. Ok that worked, Kinda. it allows me to choose recovery and Somewhere I must not have installed the recovery right on the SD because I get the penguin, and then a few lines of code, and then it shuts off. So I am guessing I do not have CM recovery installed on the sd, Is that an easy task or do I have to start completely over again?
  4. chocophile

    chocophile Well-Known Member

    Using j4mm3r's u-boot, I think you want to choose eMMC and recovery if you want CMR. If you've installed ClockwordMod Recovery from ROM Manager, it is installed on the eMMC, not the SD, even when running CM7 from the SD card. (you've apparently already discovered this.)

    When you boot into SD recover and watch what happens in those "few lines of code" it is prepping the system to install something, then, finding nothing to install, shuts down. You'll see the message "Looking for install images" among those lines of code. This is the only thing I've found that SD recovery mode good for: unpacking and installing zip files, like a new GApps version, or updating your ROM. (If it serves some other purpose, I'm sure someone will chime in and add to that.) For one thing, you can copy the CM7.1.0 to the card and upgrade from 7.0.2. You'll find 7.1.0 more stable, faster, and with a better Market experience.
  5. What I am trying to do is add some custom stuff I made in the Uot kitchen, some Icons, and battery stuff, and animations. On my phone this was easy because it was rooted and I just did it through recovery. I have the zip file on the sd card already, and when I tried to boot into recovery to install the changes, it attempts to install them to the factory section, and causes all kinds of screw ups.

    So basically I need to take the zip file and make it an Image file for the recovery on the sd to install it to the sd OS?

Share This Page