It takes forever for my phone to ring!!??General


Last Updated:

  1. tap58892

    tap58892 New Member This Topic's Starter

    Joined:
    Feb 15, 2010
    Messages:
    4
    Likes Received:
    0
    Ok, so I am having MAJOR problems with my (now 5th) replacement HTC Eris. I just can't seem to part with it though because I do like it. Anyway...
    I remember when I first got the phone, it would ring about 5 times on the callers end before it rang on mine. I found some number that I called to fix that... now I can't find it anywhere!! HELP!!!
     

    Advertisement
  2. Steven58

    Steven58 Reformed PH VIP Member

    Joined:
    Feb 19, 2010
    Messages:
    32,920
    Likes Received:
    25,271
    I'll move this to the right forum for you to get help.

    :)
     
  3. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    Joined:
    Jan 19, 2010
    Messages:
    22,479
    Likes Received:
    9,225
    Some devices don't do well on the default slot cycle setting.

    That is the setting that determines how often the phone contacts the nearest tower, in seconds, to query for incoming calls; the stock setting is "2," which translates to three times as long as a setting of "0" and twice as long as "1." Those are not seconds, just settings. The actual seconds are longer than "0" for a setting of "0," obviously.

    The factory setting of "2" is designed to sacrifice quick caller to receiver functionality a bit in order to save battery life. The lower settings keep the device busier than the higher settings, so prudent battery saving measures taken in other areas of the system should be taken, such as lowering the screen brightness, leaving GPS off until actually needed, etc (see http://androidforums.com/htc-droid-eris/19176-optimize-your-droid-eris-battery-life-read.html).

    To adjust the slot cycle, you must access the slot cycle index, which is accomplished by doing the following (be patient between steps, a bit of a delay occurs sometimes):

    - press the "phone" button

    - dial ##778

    - press the green "call" button

    - choose "edit mode"

    - enter six zeroes as the password (000000)

    - press modem settings

    - press slot cycle index

    - make your selection

    - press "menu"

    - confirm your setting

    The device will reboot.
     
    Ted S and DEinMA like this.
  4. DEinMA

    DEinMA Well-Known Member

    Joined:
    Apr 4, 2010
    Messages:
    47
    Likes Received:
    2
    Thanks Frisco!

    Q: Does this ever get reset .. say, after a reboot or battery pull? I set this to zero a while back, but it somehow reverted back to "2". (Although, it may also be that I simply neglected to confirm.)
     
  5. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    Joined:
    Jan 19, 2010
    Messages:
    22,479
    Likes Received:
    9,225
    Neglecting to confirm is the most likely reason, DEinMA, although a factory data reset will restore the device to all default settings.

    A live battery pull would not cause the slot cycle index to change.
     
    DEinMA likes this.
  6. DEinMA

    DEinMA Well-Known Member

    Joined:
    Apr 4, 2010
    Messages:
    47
    Likes Received:
    2
    Ok, I have not factory reset so it must be the former.

    I will also say that I have had a dramatic decrease in missed calls since I received a replacement phone. And now that this setting is in place, it should be even better moving forward. :cool:

    Thanks again
     
  7. Podivin

    Podivin VIP Member VIP Member

    Joined:
    Nov 29, 2009
    Messages:
    3,679
    Likes Received:
    881
    The only time I noticed that the slot cycle changed on my phone is when I got a replacement. It seems that setting is for the specific device, not the phone number.
     
  8. v941726

    v941726 Well-Known Member

    Joined:
    Jun 2, 2010
    Messages:
    357
    Likes Received:
    4
    i dial ##778 and nothing happens! tried it 4 times now

    it worked. call confirm must have been stopping it. mine didnt reboot though. but its still at 1.
     
  9. Lagos

    Lagos Well-Known Member

    Joined:
    Jun 12, 2010
    Messages:
    195
    Likes Received:
    29

    Try removing the HTC weather/clock widget from your desktop and rebooting the phone. Also try the slot cycle tip and report back to us.
     

Share This Page

Loading...