ITVPlayerSupport


  1. rocketracer70

    rocketracer70 New Member

    Hi

    brand new to the N7 (in fact never even had a mobile phone before nevermind a tablet) and I am having trouble getting the ITVPlayer app to work.

    I get a device not compatible message in the appstore. To save me a lot of heartache could someone please tell me if the app is indeed incompatible with the N7 (latest OS)?

    Advertisement
    :
  2. Hoppy

    Hoppy Well-Known Member

    I get the same message, it does appear that at the moment it is incompatible with JB 4.2

    Sent from my Nexus 7 using Tapatalk HD
    rocketracer70 likes this.
  3. MartinS

    MartinS Well-Known Member

    If I remember correctly it needs Flash. This would rule out JB until the app has changed.

    Apologies if I don't remember correctly :)
  4. rocketracer70

    rocketracer70 New Member

    Regards flash: Wiki (I know) says ITVPlayer needs Adobe Air - which I have.
  5. Teknologic

    Teknologic Well-Known Member

    You still have the possibility of sideloading flash, the latest android build is still somewhere on the Adobe website last time I checked. In a section called discontinued or legacy flash player, something like that. I don't know if sideloading itv is an option, but technically it could work.
  6. Raymond1701

    Raymond1701 Member

    I downloaded ITV_Player_1.0.0.apk and installed it that way, BBC works as well.
    rocketracer70 likes this.
  7. rocketracer70

    rocketracer70 New Member

    That worked great. Thanks very much.

Share This Page