Jelly Bean Build for WM8850Support


  1. gordito

    gordito New Member

    Hi everyone,
    I'm fairly new with my Android Tablet, it is a WM8850-mid.
    It has Android 4.0.3 installed, I just start using it and found out Netflix does not works, it installs successfully but when you try to use it the touch screen does not responds.:mad:

    Well based on my Netflix problem, I was decided to upgrade the Android version on it to Jelly Bean (and see if that solves the problem), but it turns out the System Update option is not available :confused:so I haven't found a way to upgrade it.

    Does anybody knows where can I found the Jelly Bean version for the WM8850-mid table and where could I find some instructions on how to install/upgrade my tablet?:(

    Thanks.

    Advertisement
    :
  2. Mostly Harmless

    Mostly Harmless Well-Known Member Contributor

  3. hstrange

    hstrange New Member

    Hi I had the same problem with my tablet which had the build no. 1.2.0. Netflix did not reach when using the touch screen. I tried to ugrade it with a new firmware I found on the internet with build no. 1.3.0. Fixed some issues with wifi and overall I felt that the tablet were more smooth to use, but Netflix still didnt work. So I contacted the shop were I bough the tablet asking for the newest firmware and got build 1.4.0 which solved the problem with netflix.

    Best Regards
    Henrik
  4. BlackBeret

    BlackBeret Member

    Hi Henrik,

    just bought a cheap Android 7 inch netbook with the WM8850 board. Could you please tell me where you found firmware images on the internet? I just tried to find some of them for a few days now without any luck.

    I just rooted the device with 4.0.3 build 1.1.0 but currently I'm having some problems with wifi connection (drops after some time and won't recover) and sometimes the device freezes and has to be reset.

    Thanks in advance!

    Regards,
    Erik
  5. knuxyl

    knuxyl New Member

    find "W70-1.5.1680-WIN8-1108.zip"
    extract it, go into config folder, and get rid of the + in front of the top firmware. Then find ur model (which can be obtained by wmexporer, google) and put that + in front of it. then just copy the extracted files to the root of ur sd, then boot ur tablet, and wulah, it should update to 1.5.0. i just did this today, and there are some new features available.


    very dumb antispam block, i cant give you links, so i will not be returning to this site, so here is a very jacked up link for you. goodbye

    h t t p : / / w w w . a n d r o i d t a b l e t s . n e t / f o r u m / w o n d e r m e d i a - b a s e d / 5 0 1 1 4 - w m 8 8 5 0 - m i d - f i r m w a r e - u p d a t e - r o o t . h t m l
  6. BlackBeret

    BlackBeret Member

    @knuxyl:

    Thanks for the reply. I just searched the web and found so many firmwares and also your mentioned "W70-1.5.1680-WIN8-1108.zip".

    Currently downloading right now from a chinese ftp server. The main problem with this is the fact that the netbook doesn't have a debug mode and a usb port (female) to connect to a computer and run wm explorer to get the needed details from it (model, chipsets, etc.).

    I'm really aware that I could brickt it :(

    I'll try my best with this firmware and give you an update on it.
    Thanks!
  7. BlackBeret

    BlackBeret Member

    Finally I reviewed many firmware configurations and found the PID7_8198_usbcam.fwc which seems to be most similar to the netbook (no touchscreen) and did some changes like enabling development option and 3G. Also the wifi config was wrong and failed after booting first image. After tweaking these parameters all works pretty smooth... but now there is one more thing:

    I'm German and the layout of the integrated keyboard is specially for the German customers: QWERTZ not QWERTY

    The mapping is still QWERTY so it is now a pain in the *ss to write with this.
    Could someone help me out and give me a note how that could be fixed?

    Thanks in advance!
    chymy likes this.
  8. chymy

    chymy New Member

    Hi, I found the solution for this problem it was a really pain in the ass, you need to root it, if it's rooted download root explorer or Es File Explorer or whatever you want you need to edit the files inside /system/usr/idc check replace German_A0 with Generic in all the keyboards config and reboot it, no I have a question for you, I'm running 1.5.0 firmware version and the HDMI port is not working, is it working for you on the 1.6.0 version? Thanks!
    BlackBeret likes this.
  9. chymy

    chymy New Member

    Can you please provide me the download link for that firmware? thanks!
  10. BlackBeret

    BlackBeret Member

    @chymy:

    thanks for your respone. since i updated my system the file german_a0 is already missing in the filesystem. i solved the problem by rewriting the generic chars and layout. i know that google says "never touch these files" but it works pretty good :D

    i've not tested the hdmi port since i updated the system. i'll try it out and give you an update on this.

    the firmware is available on this server ftp://202.105.131.8
    i used the file W70-1.5.1680-NOWIN8-1108.zip

    inside the package you'll find a lot of config files but as already mentioned the PID7_8198_usbcam.fwc was the most matching one.

    good luck!
    chymy likes this.
  11. chymy

    chymy New Member

    Hi, is the hdmi port working for you? it also freaks out and clicks everywhere when I connect a 3G modem Huawei E176 (I can connect to internet but it starts random moving and clicking everywhere until I disconnect it).

    Thanks!
  12. BlackBeret

    BlackBeret Member

    Hi, I just find some time to test the HDMI port on build 1.5.0 and it runs perfectly. And a resolution option (720 or 1080) is included since build 1.1.0 for HDMI output. It also has HDMI audio support so no separate cable is needed to watch a movie with full audio experience.

    Does your HDMI output anything or is there no signal at all?

    I've no 3G modem so I can't try it. The moving and clicking cursor sounds strange, just like a mishandling the modem as an input device (mouse).

    Have you tried to reinstall build 1.1.0 to see if the 3G modem works properly with it?
    The file on the mentioned ftp server should be "W70-1.1.0--20120815.rar".

    Good luck!
  13. Kseg

    Kseg New Member

    Hi Henrik, Where did u find those firmwares (1.3.0 and 1.4.0).
    Can u give me the links, I really need it pls... :)
  14. d335t0

    d335t0 Member

    I can root my WM8850-mid, but how can you determine what ROMs (if any) are appropriate for the tablet?
  15. kimo solo

    kimo solo New Member

    hey every body
    yesterday my wondermedia 8850-mid tablet battery was empty so i put it to charge while closed but when it charged it became unusable with out the charger (as when i unplug the charger from the tablet it turns of and doesn't boot again)
    does any one have solution for this problem
  16. Ludwixx

    Ludwixx New Member

    Try the Nexus7 manual (available on the Net)
Loading...
Similar Threads
  1. Prso9
    Replies:
    2
    Views:
    224
  2. steveohim
    Replies:
    10
    Views:
    341

Share This Page