Jelly Bean Update Via KiesSupport


Last Updated:

  1. valiantexile

    valiantexile New Member This Topic's Starter

    Joined:
    Jan 15, 2013
    Messages:
    1
    Likes Received:
    0
    Hello Just wondered if anyone could help. I have unrooted Galaxy S3 and have just gone to complete latest update via Kies. All was going smoothly, download to phone was complete, when error came up on PC USB device not recognised. :( Have updated the drivers via Kies but left with phone saying "Downloading Do not turn off target." Worried now about rebooting phone. Also cannot get Kies to now connect with phone. Can anyone help please?
     

    Advertisement
  2. Digital Controller

    Digital Controller The Real Bass Creator Guide

    Joined:
    Sep 5, 2012
    Messages:
    12,645
    Likes Received:
    3,552
    First off welcome to the forums!

    I have moved this thread into the Galaxy S3 forums so that you can get some specific device support from people with your device :)

    Hope this helps! :D
     
  3. jrsharp21

    jrsharp21 Active Member

    Joined:
    Jan 11, 2013
    Messages:
    32
    Likes Received:
    3
    1. Uninstall any previous instance of Kies/USB driver
    2. Download the latest Kies, specific to your S3.
    3. Download Samsung USB drivers 1.4.6.0 (I've tried newer versions but they all failed)
    4. REBOOT
    5. Disconnect from internet (VERY IMPORTANT!!! - forcing Windows to install local drivers ONLY)
    6. With the phone disconnected, install Kies + USB drivers downloaded in steps 2,3
    7. Connect the phone and let Windows install the drivers.
    8. Reestablish the internet connection.

    I found this on another forum and it worked for me.
     
    funkylogik likes this.
  4. funkylogik

    funkylogik share the love peeps ;) VIP Member

    Joined:
    Sep 15, 2011
    Messages:
    21,470
    Likes Received:
    7,243
    thanks man.
    i hadnt heard of disconnecting from net.
    do u mean phone or pc?
     
  5. jrsharp21

    jrsharp21 Active Member

    Joined:
    Jan 11, 2013
    Messages:
    32
    Likes Received:
    3
    Disconnect your pc from the net
     
    funkylogik likes this.

Share This Page

Loading...