Jelly Bean USB Mass StorageGeneral


  1. Raryn

    Raryn Well-Known Member

    Since I upgraded to JB, when I plug the phone into my laptop, it is no longer mounting the SD card as USB Mass Storage. I went into storage options, and it is no longer even available, just "media device" and "camera" modes.

    Unable to figure out how to get it working again. Downloaded an app that purportedly lets you ("USB Mass Storage") but even when using it, my laptop wasn't mounting it as a drive.

    Is there a solution? It's bizarre that they disabled such a fundamental functionality...

    Advertisement
  2. Grecho

    Grecho Well-Known Member

    I know for the longest time i couldnt mount internal memory, but i found out debuging mode had to be enabled in your settings.... try this maybe they switched it around ... who knows,,, doesnt make sense but maybe?
  3. Raryn

    Raryn Well-Known Member

    Even with debug enabled and using the app I got off XDA, I am unable to get the phone's SD card to mount on my laptop through USB.

    It was working fine with ICS earlier this week.
  4. 007shark

    007shark Well-Known Member Contributor

    I missed that change. I just went into settings and my only choices are mtp or ptp. That is weird they would take out that option. I like to use the mass storage setting with my car stereo.
  5. Raryn

    Raryn Well-Known Member

    Tried 3-4 different apps with different versions, still can't get UMS to work. Anyone know of anything else to try? I'm willing to attempt various .prop or SQL edits.

    I do have root and all the various apps to attempt whatever.
  6. droidros

    droidros Well-Known Member

    Something as basic as that shouldn't require root. And then they don't like it when people root....
  7. Raryn

    Raryn Well-Known Member

    Every solution I've seen for other phones where USB Mass Storage was disabled (including the Galaxy S III) was an app that required root. Probably any forthcoming solution for the Razr Maxx HD would too.

    "They" might not like it, but I prefer root on my phone, for a variety of reasons (most important being TiBU. But even if not for TiBU, I prefer root as a matter of principle)
  8. PBX Tech

    PBX Tech Member

    I have Media Device (MTP) checked. When I go to My Computer and view my drives I see the Droid Razr HD as a "portable device" connected. When I click on it, I am able to see both the Internal and SD Card which allows me to copy/delete files/photos from the phone to my PC and vice versa. I have attached screen shots.

    Are any of you not able to see this?

    Attached Files:

    seVer likes this.
  9. rushmore

    rushmore Well-Known Member

    That was the the big plus of Moto phones since they still had mass storage mode- a MUCH better option than MTP. Now that the Goog has their hands all over Moto, mass storage went by-by. Well, its that or Jelly Bean zapped the feature out of its framework. One step closer to Google's desire to kill off external storage and force the herd to the cloud. Moooo!

    Without mass storage mode. Moto phones are now mortal like the rest ;)

    Added:

    Wait, no mass storage mode is bad in general :(
  10. budfox66

    budfox66 Well-Known Member

    This sux if we can't use mass storage...its one of the reasons i got this phone. No better than an iphone for me if mass storage is gone. I'm pissed, have to use it for work, and now I cant sync files or my calendar or anything.

    How do you go about changing back to ICS, i don't like anything about this "upgrad" to JB.?
  11. pegs520

    pegs520 Well-Known Member

    I'm seeing the same thing.

    I don't get what people are panicking about!

    Never mind, I did some reading up on it.

    I still don't really see too many real advantages of mass storage. What are you able to do on mass storage that you aren't able to do on media transfer?
  12. budfox66

    budfox66 Well-Known Member

    If you don't understand why mass storage is important then you might as well follow the sheep to the istore. If you can't UL/DL from a cloud or backup service OTA for compliance reasons like me, the smartphone-turned-to-dumbphone mfrs will no longer allow a private relationship between my computer and my smart-now-dumbphone...so I'm back to a clamshell phone and a pda i guess. It has to be recognized eventually that there are people like me...who don't give a crap about clouds and music and pictures and videos and streaming and sharing what color my underwear is or what i ate for breakfast on the way to work today...that simply want a real smartphone back that I can freakin hook into my computer and the rest of the marketers (I mean manufacturers) will get out of the freakin way!!!!! Imagine, they call it a smartphone, but it won't sync with outlook calendar and contacts, or drop and drag simple files without a combination of 3rd party apps, drivers, and an intruding relationship with carrier/mfr. Damn, my freakin 6yr old blackberry curve would do all that. If you want to argue the points I've made, have at it, but you dont use your phone for what I use it for. Try copying a simple excel file onto your sd card memory via pc, post jellybean "update"...I dare you to come up with a way without rooting, clouding, backupwebbing, buying apps, etc. My RMHD is now a toy with a phone and a really good battery. Motorola/Verizon must come up with something.
    mscheaf, teo.sarca, sremick and 3 others like this.
  13. robdec17

    robdec17 Well-Known Member

    OK I must be totally missing something here. I have the OTA Jelly bean update on my phone and when I plug it into my Windows 7 machine it list the phone under my computer as Droid Razr HD, When I click that I can see my internal storage and my SD card. I can copy files and folders all day long from my PC to either card. I guess I'm not understanding what isn't working?
  14. budfox66

    budfox66 Well-Known Member

    you must be the only one ive found in 2 days that can use in mass storage mode...lucky guy, something's not right. there are pages in forums about losing ums with JB ota. what's diff bout your setup?
  15. robdec17

    robdec17 Well-Known Member

    OK I just checked my daughters maxx HD. We just bought it last week . Its not rooted and has the Jelly bean OTA update. When I plug it into my Windows 7 machine the phone says " Connected as a media device" but my windows 7 machine sees both cards and I can drag and drop all day long.
  16. robdec17

    robdec17 Well-Known Member

    I do have the Motorola drivers installed if that helps
  17. budfox66

    budfox66 Well-Known Member

    what kind of files? again, im not interested in media files. i can hook up as a media device but not what im trying to do. again, try to move an excel or word file, anything but a media type file, and see if yours will do that? it won't because yours is also connected as a "media device" which means only media files can be managed.
  18. budfox66

    budfox66 Well-Known Member

    robdec17, when you connect usb, do you have an option under usb connections for "mass storage device". if not, you do have the same issue that we all have...you cannot use your phone as a mass storage device. only a media device.
  19. budfox66

    budfox66 Well-Known Member

    i know i sound snarky but i spent months of investigation and elimination to get the the RMHD. the top priority was mass storage, which it had when i bought it using my 2yr contract upgrade, and it still cost over $250. now, less than 2 months later, my phone no longer communicates with my pc, can't drag and drop files, can't sync my calendar/contacts, notification light is gone, etc. etc., and i'm out $250 plus stuck with a brick for another 22 months...unless MOT comes up with a quick fix.
  20. PowrDroid

    PowrDroid Well-Known Member

    OK, I just did it, no problem. I moved a small Excel file from my PC to my phone. I created a new folder on my phone called "Excel Files" and dragged-and-dropped the file from my PC into the new folder on my phone. I did get a pop-up window saying my phone may not be able to read the file, but it DOES read it.

    Edited to add: I moved the file to my SD card, not phone's internal memory, if that matters.

    Attached Files:

    robdec17 likes this.
  21. notalent_assclowns

    notalent_assclowns Active Member

    I have a HD Maxx (with Jelly Bean) and when plugged in I can access both the SD card and the internal storage. I use it like a thumbdrive and just copied the MS Office install files yesterday (setup files, exe's, etc). There is no difference between this and when i plug in a real thumbdrive. I'm not sure what is wrong with your phone/computer, but it doesn't seem like it's the normal behavior.
    robdec17 likes this.
  22. Dougb256

    Dougb256 Active Member

    I am connecting between my RMHD and an iMac. I have to use Android File Transfer (which can be flakey), but I can transfer all sorts of files, not just media files.
    robdec17 likes this.
  23. robdec17

    robdec17 Well-Known Member

    Yes it only shows as media device . But as I have said several times before but you refuse to believe me. I can access both internal and external cards. I CAN create files and folders to the root level of both cards. I have copied .txt, pdf, xl, zip, rar and doc files so far with NO issues. So yes I can use it as a mass storage device!
  24. hansangb

    hansangb Well-Known Member

    I think I know what's going on. I have the following:
    1) Motorola USB driver (https://motorola-global-portal.custhelp.com/app/answers/detail/a_id/88481) I don't know if this is a requirement, but I installed it as part of getting root.
    2) I set my USB Storage as Camera (Settings, Storage, - click on the menu at the top right corner -, USB Computer Connection, Camera PTP.
    3) I used the *MOTOROLA* cable. If you use a generic cable that's meant for charging it may not work. I tried two generic cables that came with chargers and it did *not* work.

    And here's the proof (couldn't embed the pic for some reason. Adding a link to my box.com where I uploaded the screenshot.

    https://www.box.com/s/7p8l1afwirhysih3f5sr
    [​IMG]
  25. hansangb

    hansangb Well-Known Member

    Interesting...someone just posted that you need an SD Card to use mass storage. And I actually an SD card. Regardless, the cable issue is still valid. If you don't have the right cable, it will not mount the drives.

Share This Page