JIT and stock Eris


Last Updated:

  1. thetingster

    thetingster Well-Known Member This Topic's Starter

    Joined:
    Dec 27, 2009
    Messages:
    504
    Likes Received:
    31
    Is it possible to install JIT on a stock/rooted Eris without installing a custom ROM? If so... how?

    Thank you!!! ;-)
     

    Advertisement
  2. Praetorian

    Praetorian Well-Known Member

    Joined:
    May 11, 2010
    Messages:
    180
    Likes Received:
    23
    If you want stock with JIT install xtrSense ROM. Looks just like stock sense and has JIT available. However the rom is so dam fast you don't even need JIT enabled anyways :).
     
  3. thetingster

    thetingster Well-Known Member This Topic's Starter

    Joined:
    Dec 27, 2009
    Messages:
    504
    Likes Received:
    31
    Thank you. I know. I just want to know if I can install JIT without installing a ROM. I have an app that does not play well with me changing ROMs.
     
  4. Haxcid

    Haxcid Well-Known Member

    Joined:
    Dec 31, 2009
    Messages:
    413
    Likes Received:
    29
    I find my phone completely unstable with JiT running. First thing I do is turn it off now. If I leave it on all apps for me with start force closing after a few days.

    xtrSense is a good choice. It is a stock sense install with expanded root options like JiT.

    Which app is giving you issues and have you actually tried xtrSense?
     
  5. thetingster

    thetingster Well-Known Member This Topic's Starter

    Joined:
    Dec 27, 2009
    Messages:
    504
    Likes Received:
    31
    My Kindle app will not work for with any custom ROM. I get the "invalid book" error. However I am able to run it with stock/rooted/over-clocked using Zanfurs kernel. If I could find a fix so my books would download I would use xtrROM as that is my current favorite.
     
  6. Praetorian

    Praetorian Well-Known Member

    Joined:
    May 11, 2010
    Messages:
    180
    Likes Received:
    23
  7. scary alien

    scary alien not really so scary Moderator

    Joined:
    Mar 5, 2010
    Messages:
    21,652
    Likes Received:
    21,997
    thetingster,

    I've got the Kindle app on my Eris which is loaded w/Ivan's Eris Official 1.0 (yeah, its kind of old, passe' ROM nowadays, but its a solid ROM that does all that I need it to). Its probably similar to PlainJaneT2 in how it was built.

    Cheers!
     
  8. doogald

    doogald Guides Guide

    Joined:
    Jan 7, 2010
    Messages:
    6,620
    Likes Received:
    1,896
    That's weird. I have run the Kindle app on Kaos Froyo, Nonsensikal, Vanilla 2.0.3, CELB Froyo and now xtrROM 4.2.1 and it runs perfectly fine. When I flash a new version I always restore from Titanium, and then it makes me log in twice, but after that, all is fine.

    I'm running xtrROM pretty stock - the only gscript I ran was to remove the Amazon MP3 Store.
     
  9. thetingster

    thetingster Well-Known Member This Topic's Starter

    Joined:
    Dec 27, 2009
    Messages:
    504
    Likes Received:
    31
    That is interesting. Does celb Froyo 3.0 come overclocked or do you also need to use setcpu?
     
  10. doogald

    doogald Guides Guide

    Joined:
    Jan 7, 2010
    Messages:
    6,620
    Likes Received:
    1,896
    I don't run SetCPU. CELB is clocked at 710 by default. I'm not sure what the min is; my guess is that it is 245.
     
  11. Conap

    Conap Well-Known Member

    Joined:
    Mar 18, 2010
    Messages:
    145
    Likes Received:
    38
    That is correct.
     
  12. thetingster

    thetingster Well-Known Member This Topic's Starter

    Joined:
    Dec 27, 2009
    Messages:
    504
    Likes Received:
    31
    Okay I flashed Celb 3.0 which was very cool. But I still had a problem with my kindle books. I noticed xtrROM's newest version, 4.6 and flashed it. Wham, everything is working, my books loaded up just right.

    I have begun to suspect that JIT is what is preventing Kindle books from loading. I currently do not have JIT enabled on xtrROM 4.6
     
  13. Praetorian

    Praetorian Well-Known Member

    Joined:
    May 11, 2010
    Messages:
    180
    Likes Received:
    23
    JIT running on 2.1 has been known to cause problems. I'm running Celb3.0 now but xtrRom is about as stable as it gets.
     

Share This Page

Loading...