Juice Defender Leaves Mobile Data DisabledSupport


  1. marx2k

    marx2k Well-Known Member

    Hey Guys...

    I'm having an issue with Juice Defender and I'm sure there's a very basic setting to change but I can't find it. Here's my issue:

    At work I sit around with the wifi on the phone working. I go outside to go home and no longer have wifi, but Juice Defender doesn't automatically switch me over to 3G mobile data. I have to always manually go into Settings -> Wireless & Networks -> Mobile Networks and check Data Enabled

    Is there a setting in Juice Defender to automatically switch me over to Mobile Data when it's out of wifi range?

    Currently I have JD on the Balanced profiole

    Advertisement
    :
  2. anttivaris

    anttivaris New Member

    Sorry for bringing up the old topic.

    I have recently bought Samsung Galaxy S II and have exactly the same problem.

    Are there any solutions? The log just says "Mobile Disabled". It wont re-enable it when syncing (and wifi not available). In Peak times if I manually start mobile data and restart JD, it disables mobile data and enabled Wifi. Mobile Data wont be enabled later.

    I have tried to use APN method, no working.

    If I even Disable the Mobile Data control in JD, still it does the same. Is it something with Android itself?
  3. i get that bug too, but Im using a custom rom that allows me to put toggle switches in the notification shade. so instead of going through all those menus, i just pull down the shade, tap "enable mobile data" and its all good. also, I dont really get the bug anymore becuase I just pull down the shade and turn wifi off with one tap and JD puts mobile data back up.

    I think the problem is that the wifi radio is still on and jd thinks it can find a wifi network before being forced to connect to 3G, and it gets stuck waiting.

    anyways, if your not on CM7 or miui, your really missing out.
  4. anttivaris

    anttivaris New Member

    --- After re-install it worked ---

    Now I feel I paid for a reason. Couldn't guess my first clean install did go wrong..
Loading...

Share This Page