Just an AVD question...


Last Updated:

  1. l0ki

    l0ki Member This Topic's Starter

    Joined:
    Oct 24, 2010
    Messages:
    5
    Likes Received:
    1
    Hey folks, been reading this site for a while now and it's been no-end of help to me, so first off - THANKS!! Hopefully in the future I can help folk out.

    I've just got a small question that's possibly quite stupid, but I can't figure it out...

    I've got a wee X10 1.6 android for dev'ing on, and the game I'm writting works flawlessly on it, however, whenever I try and run it on the emulator it "stops working suddendly" and I have to force close it... Will this mean that it just wont run on some devices?

    Is there anyway to setup emulator device models at all? I.e. Could I specify that I'd like to test it on the HTC Wildfire for example, and then the Desire or NX1?

    Thanks in advance. Possibly a really stupid question, but thought I'd ask anyway :)
     

    Advertisement
  2. sscAndroid

    sscAndroid Member

    Joined:
    Oct 23, 2010
    Messages:
    17
    Likes Received:
    1
    Hi,

    if your game runs on real devices, don't bother.
    The "Force close" dialog appears if your UI thread is not responding fast enough, what could be related to the slowness of the emulator compared with real devices. The source of this lags is the converting process of your compiled ARM code into x86 code.
    For more information see Stackoverflow
     
    l0ki likes this.
  3. l0ki

    l0ki Member This Topic's Starter

    Joined:
    Oct 24, 2010
    Messages:
    5
    Likes Received:
    1
    Thanks for your help :) I'm not sure if it runs on other devices yet. I'll cross that bridge when I come to it, but for now it runs without a hitch on my droidy, so I'll just stop using the emulator. I'd noticed it was slow, but thought it may have been some setup issue that I'd just not known about :)

    Cheers!
     

Share This Page

Loading...