Just want to get rid of Keyguard at home!

Last Updated:

  1. Pinmac1

    Pinmac1 Well-Known Member

    I'm trying to set up arofile to turn off Keyguard when connected to my home wifi (will add others e.g. Work when/if?! I get it working). I thought it would be as simple as when Wifi Connected to home wifi SSID then turn Keyguard off but it doesn't work. I have tried searching on here but haven't understood what was suggested.
    Does anyone have a simple profile they could share to do this please?

  2. Pinmac1

    Pinmac1 Well-Known Member

    This is one of the profiles I couldn't get to work. I enter the event context and when I tick it goes to a Task Selection menu with New Task, Park Maps and Plugin. Nothing here seems relevant but if I don't put something in here the profile gets deleted.
  3. bberryhill0

    bberryhill0 Well-Known Member

    You followed the directions and chose the context of Net> Wifi Near and put in your SSID? Then you have to create a task that turns off the Keyguard. It's under Display.
    Pinmac1 likes this.
  4. SUroot

    SUroot Well-Known Member Developer

    On mine I have to use Secure Settings plugin (and then secure settings helper - Root required) to do this with Pattern.
    Pinmac1 and bberryhill0 like this.
  5. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Alternatively, there's an app called UnLock With WiFi which will do it without Tasker/Root.
    Pinmac1, D-U-R-X and bberryhill0 like this.
  6. BKayrac

    BKayrac Well-Known Member

    use secure settings, and forgot all that extra weird things

    I have my tasker with a profile to automatically enable/disable wifi for me at home

    I then made a profile for 'when wifi is connected to (my home network)'

    enter task, is keyguard enable, using secure settings to 'toggle' keyguard

    then exit task again using secure settings to 'toggle' keyguard

    works perfectly now, but using it to enable/disable the keyguard does not work, the key is the toggle keyguard, and not overthinking it like many of the other profiles people create do

    looks like i spoke to soon, time to go back to the drawing board :p....it's just flakey, perhaps it's a jellybean issue?
    Pinmac1 likes this.
  7. SUroot

    SUroot Well-Known Member Developer

    With pattern lock, you supposedly need secure settings, settings helper and root. Some (matttye for example) don't need this for it to work though.

    With settings helper, mine is no longer flakey. Works every time without fail
    Pinmac1 likes this.
  8. BKayrac

    BKayrac Well-Known Member

    Yeah I got it working properly, it looks like the flakeyness was from the 'wifi connected', I changed it to use my turn wifi on profile, and it works like a charm
    Johnny LaRue and Pinmac1 like this.
  9. MaxPower1

    MaxPower1 Active Member

    I got mine to work after a bit of trial and error. I did have to download Secure Settings.

    I have a profile called "Screen Lock Off", the two contexts for that are:

    1: Display Unlocked
    2. WiFi Connected (to my SSID at home).

    The task options are:

    1. Wait 2 seconds
    2. Keyguard, Set, Off
    3. Secure Settings, Configuration, Keyguard Disabled/BG
    4. Secure Settings, Configuration, Clear Password/Wait for Unlock

    To lock the screen I have a profile called Screen Lock On, the contexts for that are:

    1.Not WiFi Connected, it's WiFi Connected one but with the "Inverted" option checked.
    2. Display State Off

    Task options are:

    Secure Settings, Configuration, Lock Device
    Secure Settings, Configuration, Set Pin

    I followed the link that bberryhill0 posted but "WiFi near" wasn't working on my EVO 3D. Maybe not every profile and task will work on every phone, who knows.
    Pinmac1 likes this.
  10. Pinmac1

    Pinmac1 Well-Known Member

    Thanks for all the replies, guys. I have been trying all your suggestions off and on for the past few days and still can't get it to work. Unlock With Wifi does look as though it would do the job but doesn't work with pattern unlock which is what I use. I tried switching to a pin code for a couple of days to try it but it drove me nuts so I'm glad I tried it before downloading UWW.

    Didn't quite understand the fix suggested by Bkayrac, is there any chance you could elaborate please? I did have a go at the fix suggested by MaxPower1 but when I got to No. 4 I couldn't see any setting for Clear Password/Wait for Unlock. Also on the Password screen it says that Device Administrator needs to be enabled but when I enable it it carries on saying it needs to be enabled. Also it looks as though it also won't work with pattern lock unless that is what you are using?

    I think that my main problem is that any method of doing this with pattern lock does not seem to work with ICS so I think I am going to have to wait until Jellybean comes out and give it another go.
  11. SUroot

    SUroot Well-Known Member Developer

    If you're rooted I'll step by step you to get mine. May even create a thread...
  12. Pinmac1

    Pinmac1 Well-Known Member

    Not rooted, I'm afraid and not feeling brave enough to go that route. Did consider it when I was getting frustrated at the lack of space on my Desire but not got that issue with the Note so don't really see the benefit and worried I'd screw it up.
  13. SUroot

    SUroot Well-Known Member Developer

    Ok. If it changes, let me know
    Pinmac1 likes this.
  14. Pinmac1

    Pinmac1 Well-Known Member

    Much appreciated, thanks. Others who are rooted might find a step-by-step useful?
  15. SUroot

    SUroot Well-Known Member Developer

    yeah will probably do it at some point. I will name it "alternative root method" or something.
  16. shauny13

    shauny13 Well-Known Member

    Hi guys, i have finally managed to get this working too with the help of secure settings app. Everything is fine until i select a notification i receive and the device locks again. Any ideas? this is on ics if it's relevent
  17. SUroot

    SUroot Well-Known Member Developer

    Rooted with secure settings helper?
  18. shauny13

    shauny13 Well-Known Member

    Rooted, but not got the helper. Do i need that also?
  19. SUroot

    SUroot Well-Known Member Developer

    It works better with the settings helper, yes.
  20. shauny13

    shauny13 Well-Known Member

    still no luck Dan, where is this wait for unlock option aswell? cant find it anywhere
  21. SUroot

    SUroot Well-Known Member Developer

    Shall I post a profile how to?
    shauny13 likes this.
  22. gcobb

    gcobb Well-Known Member

    When I upgraded to the newest OS mine stopped working properly.
  23. Johnny LaRue

    Johnny LaRue Member

    Thanks BKayrac! This was the only solution that has worked for me. This has been one of the most nagging issues for me for over a year. Being able to turn my pattern lock off at home was the only reason I bought Tasker.

    I'm using an unrooted Nexus S running Jellybean.
  24. Johnny LaRue

    Johnny LaRue Member

    I spoke too soon. BKayrac's solution worked perfectly until I plugged my phone in when I went to bed. Then the keyguard came back on and didn't turn off. I just got to work and my phone still thought it was at home, so even the 'Wifi at Home' profile was not working.

    I think Tasker is not living up to the hype.

Share This Page