1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Just want to get rid of Keyguard at home!


Last Updated:

  1. SUroot

    SUroot Well-Known Member Developer

    Joined:
    May 25, 2010
    Messages:
    23,925
    Likes Received:
    5,302
    Keygaurd is a secure setting. The very nature of this is to be secure and tamperproof. The fact it partially works is amazing to me. That's why root and secure settings helper are required. Not taskers fault
     

    Advertisement
  2. Johnny LaRue

    Johnny LaRue Member

    Joined:
    Apr 10, 2012
    Messages:
    11
    Likes Received:
    0
    OK, I'll try rooting my phone this weekend. I keep meaning to do it but just haven't found a need to do it until now. Damn that necessary keyguard!
     
  3. SUroot

    SUroot Well-Known Member Developer

    Joined:
    May 25, 2010
    Messages:
    23,925
    Likes Received:
    5,302
    Let me know if you need any help.
     
  4. Johnny LaRue

    Johnny LaRue Member

    Joined:
    Apr 10, 2012
    Messages:
    11
    Likes Received:
    0
    I rooted my phone, which was a PITA, and reinstalled Tasker, Secure Settings and its Helper. My keyguard turned off reliably for a while but now it's flaky again.

    SUroot, if you would post a howto, I'd appreciate it.
     
  5. shauny13

    shauny13 Well-Known Member

    Joined:
    May 24, 2010
    Messages:
    1,266
    Likes Received:
    300
    never got mine to work, always flaky, tried helper and secure settings without success. :(
     
  6. Johnny LaRue

    Johnny LaRue Member

    Joined:
    Apr 10, 2012
    Messages:
    11
    Likes Received:
    0
    Yeah, I thought it could have been Lookout causing the flakiness because it can control the keyguard, too. I turned that off but still no luck.

    Tried BKayrac's solution again, this time while rooted, but whenever I go and get a notification, the keyguard comes back on.

    If I turn Tasker off and on, the keyguard comes off.

    I've now also tried installing SQLite Installer for Root as per the Secure Settings site instructions.
     
  7. davoid

    davoid Well-Known Member

    Joined:
    Aug 3, 2011
    Messages:
    1,792
    Likes Received:
    700
    Have people enabled Secure Settings and Tasker in Settings>Security>Device Administrators?

    Don't know if it's necessary but it got my Lock Screen profile working ;)
     
  8. davoid

    davoid Well-Known Member

    Joined:
    Aug 3, 2011
    Messages:
    1,792
    Likes Received:
    700
    How do you normally unlock your phone? is it by pattern or PIN?

    If it is by pattern, then select Pattern Lock in the Secure Settings plugin, instead of Keyguard. It works for me.
     
  9. shauny13

    shauny13 Well-Known Member

    Joined:
    May 24, 2010
    Messages:
    1,266
    Likes Received:
    300
    Yep, still no joy. It's ok until i go to a notification, then i lose it and have to reboot to get it back.....why is this so difficult :confused:
     
  10. davoid

    davoid Well-Known Member

    Joined:
    Aug 3, 2011
    Messages:
    1,792
    Likes Received:
    700
    I used to have this problem until I used the Pattern Lock option instead of Keyguard. Which are you using?
     
  11. shauny13

    shauny13 Well-Known Member

    Joined:
    May 24, 2010
    Messages:
    1,266
    Likes Received:
    300
    nothing currently, gonna try your suggestion
     
  12. Johnny LaRue

    Johnny LaRue Member

    Joined:
    Apr 10, 2012
    Messages:
    11
    Likes Received:
    0
    I've been using a pattern lock. How do you use the pattern lock option in Secure Settings. It seems like turning it on by clicking the box is the default. Do you set up the context in reverse? For example, the first task would be leaving home, turn pattern on. Exit task would be coming home, turn pattern off?
     
  13. davoid

    davoid Well-Known Member

    Joined:
    Aug 3, 2011
    Messages:
    1,792
    Likes Received:
    700
    I have mine where first task is connected to wifi - turn pattern lock off. Exit task, turn pattern lock on.

    First setting:

    [​IMG]

    Then for the exit task I just choose On and save it.

    You need to have pattern lock setup in system settings as default, so that tasker can merely disable it.
     
  14. Pinmac1

    Pinmac1 Well-Known Member This Topic's Starter

    Joined:
    Jan 22, 2011
    Messages:
    502
    Likes Received:
    26
    I don't see Pattern Lock as an option in Secure Settings?
     
  15. davoid

    davoid Well-Known Member

    Joined:
    Aug 3, 2011
    Messages:
    1,792
    Likes Received:
    700
    In that case you need to install Helper. To do that go into your app drawer and open Secure Settings. Go to the Helper tab, and choose the install Helper option. This should then give you an additional section of options in the Secure Settings plugin in Tasker.
     
    Pinmac1 likes this.
  16. Johnny LaRue

    Johnny LaRue Member

    Joined:
    Apr 10, 2012
    Messages:
    11
    Likes Received:
    0
    OK, I'll try this and let you know how it goes.

    Just for everyone else's sake, I had Helper installed but Pattern Lock was not appearing in the options in Secure Settings. Open up SS directly and go under Options to enable it.
     
  17. Pinmac1

    Pinmac1 Well-Known Member This Topic's Starter

    Joined:
    Jan 22, 2011
    Messages:
    502
    Likes Received:
    26
    Thanks, that explains it then as I am not rooted so can't install Helper. I understand that this works better under Jellybean so I guess I'll wait until that comes out, hopefully this month, before I try again.
     
  18. shauny13

    shauny13 Well-Known Member

    Joined:
    May 24, 2010
    Messages:
    1,266
    Likes Received:
    300
    No joy here, tried everything. Just think it a one x thing
     
  19. davoid

    davoid Well-Known Member

    Joined:
    Aug 3, 2011
    Messages:
    1,792
    Likes Received:
    700
    shauny, are you rooted?

    EDIT: just saw your details under your avatar. Hmm.

    So what exactly is your situation - i.e. what do you have set up/installed?

    This is what you need:

    1. Set up pattern lock in Settings>Security and Lock Screen
    2. Install Secure Settings
    3. Open Secure Settings. Under Helper tab, install Helper. (Will need/ask for Busybox, iirc)
    4. Make sure in Secure Settings, under Options tab, Pattern Lock is ticked (as these ticked options are what become available in the Tasker plugin)
    5. In Settings>Security and Lock Screen>Device Administrators, tick Tasker and Secure Settings

    In Tasker, set up your first task (the one activated when connected to Wifi) as:

    Action:
    Plugin>Secure Settings
    Configuration: Pattern Lock>Off

    Exit Task:
    Action:
    Plugin>Secure Settings
    Configuration: Pattern Lock>On

    That should do it, really.
     
  20. shauny13

    shauny13 Well-Known Member

    Joined:
    May 24, 2010
    Messages:
    1,266
    Likes Received:
    300
    yep it's set up exactly as you have stated, always the same, it's fine till i go to a notification. have tried pin, password,pattern and nothing.

    Edit: wiped everything in tasker, started again and followed yours to the letter and seems to be working at the moment (with notifications) Fingers crossed. Will let you know how it goes, and many thanks for your help.
     
  21. davoid

    davoid Well-Known Member

    Joined:
    Aug 3, 2011
    Messages:
    1,792
    Likes Received:
    700
    (Fingers crossed) I'm glad you got it working :)
     
  22. Johnny LaRue

    Johnny LaRue Member

    Joined:
    Apr 10, 2012
    Messages:
    11
    Likes Received:
    0
    OK, I tried davoid's step by step and it turns off my pattern lock...but somehow also turns on the slide lock! My Tasker only has this one profile in it at this time. I just don't get it.
     
  23. SUroot

    SUroot Well-Known Member Developer

    Joined:
    May 25, 2010
    Messages:
    23,925
    Likes Received:
    5,302
    Dont know on your phone but on my phone if I turn pattern lock on, it replaces swipe lock (my equivalent to your slide lock) and if I turn pattern lock off, swipe lock returns so yeah, that makes sense.
     
  24. shauny13

    shauny13 Well-Known Member

    Joined:
    May 24, 2010
    Messages:
    1,266
    Likes Received:
    300
    so is it possible to disable both? pattern lock turns off for me but swipe lock comes back on
     
  25. shauny13

    shauny13 Well-Known Member

    Joined:
    May 24, 2010
    Messages:
    1,266
    Likes Received:
    300
    ok, now it doesn't work at all. Totally random, sometimes locked other times not. Gadgetwise, i've never been defeated, but this is putting up a damn good fight with my patience. :D
     

Share This Page

Loading...