1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

K-9 email client: read emails disappears


Last Updated:

  1. agentorange99

    agentorange99 Member This Topic's Starter

    Joined:
    Feb 23, 2010
    Messages:
    5
    Likes Received:
    1
    Hi,

    I got my 2 gmail accounts (as POP) and my isp email account (as POP also) in my K-9 email client.

    When i receive emails they appear in inbox just normaly. But if I leave the inbox and come back in, they have disappeared. I just can´t figure it out, what kind of setups I have to have to keep the read emails shown?

    I have the same 3 account in my laptop and k-9 doesn´t delete the emails from server, because I can download them when I use my laptop email client.

    thx!

    -timo

     

    Advertisement
    Last edited by a moderator: Mar 12, 2015
    #1
  2. jimdroid

    jimdroid Well-Known Member

    Joined:
    Oct 31, 2009
    Messages:
    805
    Likes Received:
    106
    K-9 basically mirrors the inbox of your POP account. So, let's suppose there are two messages in your POP inbox, and you read mail with K-9: it will show 2 messages in your inbox.

    Now assume that you read the mail on your laptop (you probably have the laptop set to remove mail from your POP mail's server). Now there are no messages in your POP inbox. So, if you now read mail with K-9, the two messages (headers, actually) that were there are now magically gone :)

    This is just the way K-9 is designed. The stock android mail program behaves differently.

    Hope this helps.
     
  3. agentorange99

    agentorange99 Member This Topic's Starter

    Joined:
    Feb 23, 2010
    Messages:
    5
    Likes Received:
    1
    Hi,

    Thanks from reply. That wasn´t quite what I meant... In you example situation, downloaded 2 new messages disappears before I check my email with the laptop. It notifies the new emails just correctly, but when I have read them they tends to disappear. Not right away, but if I leave the inbox folder and come back in.

    That´s true I have laptop setting so, that it deletes the messages from the server. After that K-9 doens´t find any messages.
     
    Last edited by a moderator: Mar 12, 2015
    #3
  4. oamfuchs

    oamfuchs Member

    Joined:
    May 7, 2010
    Messages:
    5
    Likes Received:
    0
    I wish to download messages from the pop to my laptop but have the messages which also came to the K9 stay on the Droid. That is how blackberry email functioned. Is there any way to do that? If not in K9, is there any other email client for Droid that will work that way?
     
  5. rhwarren

    rhwarren New Member

    Joined:
    Jun 27, 2011
    Messages:
    1
    Likes Received:
    0
    I am experiencing this issue as well.
    I have K9 on my device, thunderbird on my desktop both connecting to gmail via pop. My gmail account is too beefy for imap. I get a low space error on the phone when set up this way.
    I can understand if I have them both open at the same time, not getting all messages in both places. However, I am noticing that if a message comes in that has been labeled and had a rule applied through gmail web interface, it appears in my inbox briefly then disappears whether I've had a chance to read it or not. If K9 is totally out of the equation and I just have thunderbird with pop settings, I get all of my messages no problem. I am missing emails with the current setup and its frustrating. I need to be able to receive messages in both places with the nature of my job.
    Any suggestions? (even possibly another email client for the droid?)
     
  6. AirCatHeavy

    AirCatHeavy Well-Known Member

    Joined:
    Mar 4, 2011
    Messages:
    174
    Likes Received:
    10
    A couple years later.....same problem here.

    Version 5.001

    When I read an email on my Android phone and then go back to the list of emails for that account, OR... leave the email client and return, the email that I read is no longer visible in any folder. But...It IS still there if I go on the Internet to the web client such as online Yahoo mail. So it is not being deleted from the server. It seems to be an issue with K9 disregarding emails that have been read.

    Basically, if I read a message and it is marked as read, it no longer is visible in the list of messages.
    What should happen is that the message should be marked as read (greyed out or de-highlighted) but remain visible until I delete it.

    A few observations.....
    ***********
    I had restored my backed up settings then imported my account settings onto a new phone. Not that it cause the disappearing emails problem, but mentioned just in case there's a connection.
    ***********
    If I uncheck "Mark As Read" in account settings, the messages do not disappear
    ***********
    I have 5 email accounts set up. It only happens with some of them. Not all of them.
     
  7. Tom2droid

    Tom2droid New Member

    Joined:
    Mar 4, 2015
    Messages:
    1
    Likes Received:
    0
    V 5.002

    I download POP mails on my mobile devices with settings to not change anything at all on the mail server. However when I read Gmail mails on the mobile devices the server somehow "knows" that it has been read and the subsequent mail download by my main PC is short of the already read mails. It only affects the Gmail account.

    I also noted that the two K-9 installations I have on my 2 mobile devices must be communicating to each other as read mails on any of the two devices are not downloaded to the other device.

    I'm therefore assuming that the communication channel between K-9 installations somehow also communicated with Gmail but not with privately own mail domains.
     
  8. russ127

    russ127 New Member

    Joined:
    Mar 12, 2015
    Messages:
    1
    Likes Received:
    0
    I have a similar problem with K9. I upgraded my phone in Nov, and since then if I read an email and decide I want to keep it for a while, it disappears after a few days. That didn't happen with my old phone which I think was running an older version of K9 (now running 5.002). I saved and restored my settings from the old phone for bout accounts in K9.

    I know the emails are still on the server (Charter) because I can see them if I go through the web interface. I've tried looking on the K9 page but I couldn't find any help there.

    Does any one have any suggestions?
     
  9. Lord Vader

    Lord Vader Well-Known Member

    Joined:
    Nov 3, 2010
    Messages:
    700
    Likes Received:
    209
    I dumped K9 a while ago because of one major problem--deleted Emails constantly reappeared; they would not disappear from my phone. I'd delete a large number of Emails, they'd disappear, but within a few seconds, when I went to the message list, all of the Emails I deleted would come back.

    My primary Email account receives several hundred Emails per day. To not be able to delete them from my phone is a major problem. I switched to Mail Droid, but unfortunately, if I receive an Email with an image attached, it takes forever to download each image. One time I got an Email from my brother with 8 pics of my nephew at a golf tournament. I wanted to view the attached pictures, but it took me well over 10 minutes to do just that. Ugh!
     
  10. Crashdamage

    Crashdamage Well-Known Member

    Joined:
    Feb 25, 2011
    Messages:
    4,451
    Likes Received:
    2,728
  11. Lord Vader

    Lord Vader Well-Known Member

    Joined:
    Nov 3, 2010
    Messages:
    700
    Likes Received:
    209
    I actually tried them once. I uninstalled that app faster than once can say, "This is crap."

    It's a very cumbersome app that gave me problems similar to K9 Mail. I hated it. What sucked was that I paid for the pro version and couldn't get a refund after I learned AquaMail wasn't that good.
     
  12. Crashdamage

    Crashdamage Well-Known Member

    Joined:
    Feb 25, 2011
    Messages:
    4,451
    Likes Received:
    2,728
    To each his own. That's what choice is all about. But I gotta say, over the years I've tried most of the popular email clients (and some obscure ones) and AquaMail defeated all comers and is easily my email client of choice.
     
  13. Lord Vader

    Lord Vader Well-Known Member

    Joined:
    Nov 3, 2010
    Messages:
    700
    Likes Received:
    209
    Aqua Mail has improved, but I just tried it this week. Bad decision, because they STILL have not fixed the problem of Account Authentication errors with my Hotmail IMAP account. (Unfortunately, I can't use exchange for my Hotmail account and have to use IMAP.) Just today I tried using Aqua Mail, and after a few hours of it working, I get this red message on my account: "Incoming Server login error: NO Invalid username or password."

    I have double-checked and triple-checked my settings, but nothing I've done has helped fix it. I know the settings are correct, because I was receiving Emails all day in the app. Suddenly, within the last hour, everything stopped because of this bizarre authentication error. I even tried uninstalling and re-installing, going through the setup again. I tried rebooting the phone, wiping the cache and Dalvik cache. No dice.

    So, as of today, Aqua Mail is still an Email app that doesn't work. Unfortunately, nothing anyone has suggested has helped.
     
  14. Crashdamage

    Crashdamage Well-Known Member

    Joined:
    Feb 25, 2011
    Messages:
    4,451
    Likes Received:
    2,728
    Have you tried contacting the AquaMail developer by posting in the AquaMail forum? You will usually get a quick reply from him personally pretty quick.
     
  15. Lord Vader

    Lord Vader Well-Known Member

    Joined:
    Nov 3, 2010
    Messages:
    700
    Likes Received:
    209
    We've been Emailing about this, actually. He's as stumped as I am so far.
     
  16. Crashdamage

    Crashdamage Well-Known Member

    Joined:
    Feb 25, 2011
    Messages:
    4,451
    Likes Received:
    2,728
    I'm not surprised. I never used Hotmail but I've heard it can be fussy. He's pretty sharp. He'll get it figured out.
     
  17. Lord Vader

    Lord Vader Well-Known Member

    Joined:
    Nov 3, 2010
    Messages:
    700
    Likes Received:
    209
    Whaddya expect? It's a Microsoft product! :D
     
    Crashdamage likes this.
  18. drwiremore

    drwiremore Member

    Joined:
    Dec 14, 2009
    Messages:
    6
    Likes Received:
    2
    Same issue here: September 2015.

    A long term K9 user, and "suddenly" (okay, meaning I just noticed), mail disappears when I "refresh". And I've made no changes to k9 nor gmail in years.

    Gmail is my mail account. I have a laptop (which I rarely use) and an android phone which I use frequently. Both setup for pop.

    My primary device is my phone, setup as pop. My archive device is my laptop.
    Real-time: Phone: reads mail with unlimited storage, I expect the mail to be here unless deleted on the server.
    (Weekly) Laptop: reads mail and "pulls" it from gmail, meaning it is deleted from gmail.

    Net: I know that when I use my laptop, it is deleted from the cloud/gmail; and if I refresh my phone there will be nothing. Got it, been like that for years, works flawlessly.

    Well: with my laptop off, using my android:
    1) Refresh mail
    2) New mail mirrored and read
    3) click refresh, and read mail is gone!!
    4) Going to gmail, it has been deleted; including some mail I never saw has been deleted. WTHeck?

    K9 settings: pop; fetching:
    polls every 30 minutes
    sync server deletions ( X removed messages when deleted on server)
    When I delete a message (X delete from server) (notice it does not or should not delete a message if read)

    I managed to stop the messages from disappearing on my phone by unchecking sync server deletions (uncheck removed messages when deleted on server). However, they are still being moved to trash. (keep in mind, my laptop is not being used during this time.)

    So, what's up? Believe this is reasonably new behavior, maybe in the last 30 days August 2015.

    Configured as Pop
    K-9 version 5.006
     
  19. drwiremore

    drwiremore Member

    Joined:
    Dec 14, 2009
    Messages:
    6
    Likes Received:
    2
    Found it, self inflicted. Gmail was set to delete mail if accessed via pop. I had previously fwd my gmail to a different account; in my wisdom, back in July, I set my phone and outlook to read directly from gmail (no more fwds.) So, I've been losing mail since July, oh-my <crud> dw

    Before:
    mail was fwd to a catch-all account; but I decided to read it from gmail.

    After:
    read from both android and my laptop, removed the fwding and did not note the delete if accessed via pop. Self inflicted issue when I added a separate gmail account to my laptop (Outlook.)

    This presents a different problem, although nothing is broken:
    1) When I read from my phone, I want the mail to remain on gmail.
    2) When I read from my laptop, I want the mail to be deleted on gmail. (my laptop is the master)

    Hummm, Outlook offers me three options on delivery (all unchecked)
    1) Leave a copy of messages on the server
    1a remove from server after x days
    1b remove from server when deleted from 'Deleted Items'

    Humm, doesn't say what happens if I leave it all blank. Hopeful it will delete it from the server when accessed by Outlook. Go with that unless I reply back differently.

    dw
     
  20. MarketingGuru4

    MarketingGuru4 Member

    Joined:
    Oct 12, 2012
    Messages:
    5
    Likes Received:
    1
    Best Answer
    I am having the same problem and figured out what is occurring with my app, I believe it is a sorting issue. I will read new emails on my phone without POP downloading the email to my laptop, after an email is read and greyed out, the message is being automatically moved to the bottom of the inbox, however if you sort by date, the read messages will reappear in order by date. I must have sorted by Read/Unread.
     
    BStanZ1 likes this.
  21. BStanZ1

    BStanZ1 New Member

    Joined:
    Dec 20, 2015
    Messages:
    1
    Likes Received:
    0
    You are the best, I've been trying to find the problem in account settings for a while now. (DUH!)
    Anyway, thank you for taking the time to help.
     

Share This Page

Loading...