1. Tablet future looks bright! Read more about: Alcatel Xess | Samsung Galaxy View
    New Forums: Alcatel Xess | Samsung Galaxy View
    Dismiss Notice

[Kernel]OptimusM OC stock 2.2.1


Last Updated:

  1. reppard

    reppard Well-Known Member

    For those of you with the know how until I get a flashable kernel update with working wifi you can unpack the boot.img of a rom and just replace the zImage file with the one from the kernel update. Repack it, drop it in your rom's zip and flash. You will have functioning wifi. This may fix any boot loop problems. I still don't know why some people have boot loops while others don't :/

    Advertisement
    reilus and Seirren like this.
  2. new optimus

    new optimus Well-Known Member

    your welcome
  3. reppard

    reppard Well-Known Member

    For those stuck in a boot loop did you by chance wipe your data along with your cache? If so try flashing a working rom, boot up, reboot into recovery and wipe only your cache and dalvik cache, then flash the kernel. Let me know if this helps.
    reilus and Seirren like this.
  4. t3084

    t3084 Well-Known Member

    i was reading some articles on building the kernels and they suggest that you may have to recompile the wifi module separately for it to work.

    so like... why the 4311 can't I repack the kernel into the boot.img!!!

    what offset are you using to do this??

    i've tried doing it manually with mkbootimg, with the upack and repack scripts and liquidmkbootimg... i've even unpacked a working boot.img and repacked it... and no luck?!... i need a drink!
  5. I only wiped the two caches mentioned in the first post.
  6. hemmy.c

    hemmy.c Member

    take the battery out put it bak in ...hold those buttons while u power on ..tahts how i did it,...power+down+home ..try holding home n volume down than power
    new optimus likes this.
  7. Seirren

    Seirren Active Member

    Hello guys, i tried using this kernel on both Team Chicken Eaters and the UI ROM for 2.2.1 before i flashed i wiped both caches. And on both occasions got the same result upon my reboot. It got suck on the LG screen and wouldn't move on past it.....

    I really want to get that solved so i can OC and enjoy the most bad ass android phone for its price range :D
    esgrandebp likes this.
  8. dubtee

    dubtee Well-Known Member

    could it be the kernel zip size,using fire fox my file size is 3.2mb an it boot loops (lg logo) Rom GB_CM7_OPTMBETA
  9. blaxican25

    blaxican25 Well-Known Member

    my size was 3.19mb downloaded with internet explorer no boot loops everthing worked but the wifi.
  10. TheAmazingDave

    TheAmazingDave Well-Known Member

    I don't know if this will help, but...

    I bought SetCPU and flashed the OC kernel back in. I don't know how it's related, but the OC kernel causes my live wallpaper to chop up and not play smoothly. I already mentioned that, though. What's new; I ran my stress test stable at 787 MHz, but it crashed pretty quick at 806 MHz. Once it crashed at 806, it would not come back. It would only bootloop. Pulled the battery to reset it, went to recovery, and put my nandroid backup back on no issue.

    At 787 MHz, the Live Wallpaper remained choppy, but ADW's screen animations and other menu scrolls were beautiful smooth on the otherwise-stock ROM.
  11. new optimus

    new optimus Well-Known Member

    Thank you, I actually just was able to use the power button to power off then do the key press, had to do it 3 times though must have slipped on a key the first 2 lol.

    One thing to remember when you are using set cpu and overclocking DO NOT check the box to set on boot. If you do it will try to set the last speed before reboot and if it is not stable it will crash and reboot again, Probably all the problems with the boot loop. because this overclock kernel tells setcpu that the max of the cpu is higher, it adjusts it up to the max on boot, when it is needed to speed it up you know.

    Every cpu is different sometimes you get the lucky side and have a cpu that can go higher 845mhz is I think the highest I heard of though I could be wrong.
    Sometimes you get the short end of the stick and have one that cant got 40mhz over though I bet the short end on these phones is 747mhz or so not 640-80 some.

    My phone was able to run stress test for 5 mins, all the time I let it, at 806mhz that is not enough time to tell if it is stable though. at 825mhz it ran the test for 5 seconds and rebooted.
  12. TheAmazingDave

    TheAmazingDave Well-Known Member

    That's the thing, the box was definitely not checked. I made sure before I touched the slider.

    I forgot to add that to the last post.
  13. TheAmazingDave

    TheAmazingDave Well-Known Member

    Tried to play Speedx 3D with the OC kernel, and the game won't play. The graphics are seriously screwed.

    So I played with the different clock speeds again. I definitely, 100% sure, had the set on reboot box unchecked, and I'm sitting here watching my phone bootloop after it crashed again at 806 MHz.

    And now, after about 10 loops and the time it took to type this, it's stuck on the LG screen.

    edit: got phone to boot without a restore by clearing the caches again.
  14. reppard

    reppard Well-Known Member

    OP updated with wifi fiix.
    Seirren likes this.
  15. aihliift@

    aihliift@ Well-Known Member

    noob question... so if i already have my cyanogen mod installed all i have to do is clear cache and flash this like normally, as in no wiping? just making sure before i give this a try
  16. dubtee

    dubtee Well-Known Member

    reppard, same result boot loops then freeze's on 2nd lg logo im a restore my nad an try again wit balls crossed



    edit:Nand restore, kernel load results same.Rebooted(cm7 a2sd-Rom),restored an it 2 is boot loopin so here i wait
  17. t3084

    t3084 Well-Known Member

    I'm hesitant to flash again :|
  18. Seirren

    Seirren Active Member

    Dubtee I get the same problem as you.... I posted a thread on it so as to not contaminate this one. Maybe someone can post some help there i would appreciate it.
  19. pmb116

    pmb116 Well-Known Member

    Boot loop here too
  20. t3084

    t3084 Well-Known Member

    wiped cache and dalvik cache.
    boot past white lg logo,
    reboots after about 1 second of second lg
    after white logo again it got stuck at second boot screen for a minute of so,
    then rebooted to white logo and stuck on second for for an extended amount of time.
    no response to adb

    pulled battery, booted and stuck at second lg screen. but atleast responding to adb... if only an error!
    Code (Text):
    1.  
    2. t3084@uFREEDOM:~/android/tools/bootimages$ adb logcat
    3. - exec '/system/bin/sh' failed: No such file or directory (2) -
    4.  
    it rebooted after awhile, goes to second screen amd rebooted a couple times. now adb doesn't even give an error.

    over and over and over >.<
  21. Seirren

    Seirren Active Member

    I as well just finished trying the new OC Kernel... No luck same boot loop.
  22. t3084

    t3084 Well-Known Member

    i must say I like being able to update with the boot.img i couldn't restore my previous kernel with the first download.

    if you can't boot up the oc kernel in this boot.img, instead of flashing the whole rom, you can flash 221kernel_CM07ramdisk.zip to go back to the stock kernel.
    somedood81 likes this.
  23. blaxican25

    blaxican25 Well-Known Member

    i bet if you guys download the kernel with internet explorer you wont get the boot loops.
  24. TheAmazingDave

    TheAmazingDave Well-Known Member

    Gonna try the CM7 with the new kernel tomorrow (today) morning.
  25. reppard

    reppard Well-Known Member


    You flash the new one with no problems? If so I don't know what the hell these guys are doing :p. I tested by flashing the gbrom to revert to the old kernel and the flashed the updatem. Worked like a charm. Maybe it's something in the kernel that some people's phone doesn't like...
    Seirren likes this.

Share This Page