1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

[Kernel]OptimusM OC stock 2.2.1


  1. new optimus

    new optimus Well-Known Member

    I have always used firefox, and have not had many of the problems reported, though I may be the exception yada yada. :D

    Im running on the teamchickeneater rom could you do the boot.img thing with that rom?
    I will go back to the cm7 when I can get everything I use to work but at the moment a few things are not.
  2. reppard

    reppard Well-Known Member

    Alright I repacked and resigned the update and included the md5 sum check in the original post. I haven't figured out why people are getting bootloops as i have not had even one boot loop but hopefully this will solve some of the problem. If the sum check doesnt match then dont flash it, redownload it and check again. sorry for any inconvenience.


    MD5 Sum: c39e68e1022b7cf52dcb5b5fd29f81ac
    reilus, NoahLDiamond and Seirren like this.
  3. Seirren

    Seirren Active Member

    You know maybe what you could do would be to integrate your new Kernel into this ROM so it is 1 package. Mabye that way we wont have to flash 2 things which might lead to a possible error on our part. Idk what to say anymore lol.

    But let me try this new version i will download it with internet explorer.
  4. reppard

    reppard Well-Known Member

    Make sure the sum checks match. Seeing as how my only internet is tethering at the moment, I dont think I'll be uploading another 85 mb rom image anytime soon =). This update should be no different, all its doing is replacing the boot.img with one i made from the GBrom in the first place. So its the same thing. If this doesn't work as an update it more than likely will not work for you as a full rom package. I could be wrong though. What I did to test was wipe both cache options in custom recovery. Flashed the GB rom without the kernel update. Immediately after that I flashed the kernel update. I did this without rebooting. Everything works....for me that is.
  5. Can someone cite some evidence for this insanity? This is the only place I've ever seen where everyone thinks IE is the only browser capable of downloads. I've been using Opera and Firefox for years and have never had an issue with messed up downloads.

    Please cite some evidence for this insanity or stop spreading it around, it's absurd.
  6. Downloaded new kernel. Wiped both caches and flashed. Boot loop again.

    This was a fresh flash of cm7 last night. It had a few apps installed and I changed the cpu speed setting, i set cpu scaling every time I reboot the phone to save battery could this do it?

    Don't really know whats different here.

    Ran the md5, it's all good, I refuse to download with IE Because the md5 checks out, its not a crazy one off opera downloading error.
  7. reppard

    reppard Well-Known Member

    I would have to agree. I run a single boot, completely slackware linux which obviously doesn't have IE. I use firefox and Opera and haven't had any issues as well. The sum check should be enough to confirm a good download. I dont know how to do this in windows but in linux just type md5sum filename.zip.
  8. Ok I just Booted to recovery, wiped both caches, flashed cm7, then flashed this with no reboot in between. Still effing boot looping.

    Should I wipe ALL data?
  9. Seirren

    Seirren Active Member

    Do not bother wiping all data. I tried it already same result it will boot loop. I think the problem is with certain phones like yours and mine.
  10. Oh don't tell me that, if this thing won't overclock its gonna have a bad date with my framing hammer.
  11. I just installed the Stock kernel posted earlier in this thread. Did not fix boot loop.

    Only thing that fixes loop is re flashing rom.
  12. mikekelso421

    mikekelso421 Well-Known Member

    I Always use CHROME for everything.i had no problems at all..did a nand backup,wiped cache and dalvik,flashed the kernel and rebooted...no bootloop and im running 800mhz stable..i may even be able to go higher,but ive yet to try...i set my evo at 900 max..so im pretty happy with my optimus doing close to that.Thanks again reppard!
  13. reppard

    reppard Well-Known Member

    This has got to be an issue with the phone I would guess. The only thing about this kernel I changed was the max clock speed and adding an interactive governor. Other than that is the same .config file from stock with those 2 changes. I haven't experienced a boot loop ever so it's hard for me to diagnose. If someone could get adb shell logcat working during a boot loop it may provide some hints. Could it be I set the Max Speed higher than your phones can handle? I could try a lower max with the next update, with SetCPU you can go higher than the max set by the config anyway so it wouldnt limit people who's phones can go higher. I am consistently stable at 787. 806 is fairly stable but I did notice I get some FC on some apps. Alright, anyone care to weigh in? Any thoughts or ideas?
  14. reppard

    reppard Well-Known Member

    You are very welcome. Did you flash the new one i uploaded today and test the WiFi? I need confirmation that the new update and wifi are working from someone.
    Seirren likes this.
  15. My monitor is messed up and it has a real hard time getting a new signal to turn powersave off so I'm scared to even try to boot into linux. I'm installing sdk on this windows install to try and get a log. Hopefully I'll have a something in a little while...
  16. Seirren

    Seirren Active Member

    I recommend lowering the max speed to the default 600 that way it works for everyone. Then people can fine tune it themselves to their phones unique processors. This way we cut back on any potential problems. At least it gets rid of the Processor Variable of our problem.

    My wifi works on Cyanogen mod without the OC kernel :D Cyanogen ROCKS! Thanks Reppard
  17. TheAmazingDave

    TheAmazingDave Well-Known Member

    Singing along at 787 MHz in GB, no bootloops, but functioning WiFi and graphics.

    Still have some program crashes (unrelated to OC), but this is pretty sweet so far.

    edit: Holy Shnikies this thing's quick now!
  18. reppard

    reppard Well-Known Member


    That's the confirmation I was looking for :). It is most definitely the phones, probably due to the Max speed I set. No other reason it would work great for us and boot loop for others. I will work on compiling another kernel with a lower Max when I get off work. Then we can focus on some other kernel tweaks!
    reilus, dubtee and TheAmazingDave like this.
  19. new optimus

    new optimus Well-Known Member

    I would suggest to anyone with boot looping to uninstall setcpu before adding this kernel.

    See if you still get boot loop
  20. I can't get logcat to work without the phone being fully booted in a working kernel. I don't know what I'm doing wrong...

    EDIT: logcat works right as the cyanogen animation starts with a working kernel. The boot loop never makes it to there for me. I don't know if there is any other way to get a log from the initial boot?
  21. t3084

    t3084 Well-Known Member

    you can't make me!

    @reppard
    the only thing I could get logcat to do was post that it couldn't find /system/bin/sh and this only happens sometimes. so I KNOW it's atleast starting adbd since that would be in the ramdisk, but it's not mounting the the rest of the system

    so it would seem the system starts to boot but looses stability.

    like Seirren suggested, lower the speed to 600 and then let everyone discover their own max speeds :p i think the top for some previous optimus M's were 74X?
  22. ^ this.

    I didn't even think it returning that error ment adb was working, lol. guess we have all the log were getting.
  23. h4x0rj3ff

    h4x0rj3ff Chemist

    Working at 787 so far with wifi working!

    Btw I downloaded it directly to my device in the stock browser.
  24. TheAmazingDave

    TheAmazingDave Well-Known Member

    CardioTraner crash be damned, no way I'm going back to Froyo now... I'm converted.

    Thanks to reppard and our other dedicated devs for their hard work. You guys are turning this budget droid into an amazingly competent device.
  25. t3084

    t3084 Well-Known Member

    omg... i booted D:
Loading...

Share This Page