Keyboard Advice neededSupport


Last Updated:

  1. shttw

    shttw Active Member This Topic's Starter

    Joined:
    Sep 15, 2010
    Messages:
    36
    Likes Received:
    2
    My keyboard seems to behave erratically from time to time, ie the G key will send me home, I will be P B will be SPACE. It's all jumbled up and impossible to type a message.

    I get different errors in landscape and portrait mode.

    If I just leave it for awhile and re-open stuff it's then fine. Seems very randon.

    I tried a keyboard off the market but the same issue arises from time to time. It's immensley frustrating as I get through a lot of emails and am starting to wonder if ditching the blackberry with it's hard keyboard was the right move after all.

    The phone is great generally but these little niggles are starting to annoy.

    Any advice on a fix or work around for this issue? Or is it a faulty phone?
     

    Advertisement
  2. Rusty

    Rusty Well-Known Member

    Joined:
    Jan 21, 2010
    Messages:
    1,635
    Likes Received:
    192
    They pretty much all do it once in a while, the quick fix is to simply turn the screen off and on.
     
  3. shttw

    shttw Active Member This Topic's Starter

    Joined:
    Sep 15, 2010
    Messages:
    36
    Likes Received:
    2
    Ok, I'll try that thanks.

    Is it screen hardware quality or OS problem do you know? I ask as one can fixed and the other can't.
     
  4. Teknologic

    Teknologic Well-Known Member

    Joined:
    Mar 23, 2010
    Messages:
    969
    Likes Received:
    93
    Basically the screen hardware is the phone's weakest point but I'm not sure if this is a hardware isse or software. I think it's a combination of the 2, seeing as google would've fixed it already if it was a software issue, but turning the screen off and on fixes it.
    It seems to be a very complicated bug and I used to experience it semi-regularly. But now it's been months.. Maybe that has to do with the fact that I rooted the phone, maybe it's a bug that's more likely to happen on brand new hardware, I don't know.

    I just have to say I've not experienced it for months.

    Factors that seem to influence it are heat and connecting the charger (possibly something to do with current flowing through the bottom of your digitizer).
     
  5. shttw

    shttw Active Member This Topic's Starter

    Joined:
    Sep 15, 2010
    Messages:
    36
    Likes Received:
    2
    Actually I have noticed it happens more when on charge - much more so. Hmmm heat related makes a lot of sense. Thank you.
     

Share This Page

Loading...